Topic
  • 5 replies
  • Latest Post - ‏2013-07-25T05:18:37Z by LI Bo
ryan-soasta
ryan-soasta
4 Posts

Pinned topic Recieve Error 500 when attempting to connect to AcmeAir

‏2013-07-23T19:16:36Z |

Hello,

I have completed the installation of AcmeAir on Mac. I am able to start all sample_acmeair apps and the mongodb (which I can test connection successfully.) However, when I navigate to the URL for acmeair I receive the following error:

Error 500: javax.servlet.ServletException: Filter [com.acmeair.web.RESTCookieSessionFilter]: com.acmeair.web.RESTCookieSessionFilter was found, but is missing another required class.

I believe I may be missing a jar file so I'm going to look through what I loaded and what was required but just seeing if anyone could shed any troubleshooting ideas towards this error.

Edit: Attached pic of third-party jar list.

Thanks,

Ryan

Attachments

Updated on 2013-07-23T19:45:58Z at 2013-07-23T19:45:58Z by ryan-soasta
  • LI Bo
    LI Bo
    18 Posts

    Re: Recieve Error 500 when attempting to connect to AcmeAir

    ‏2013-07-24T03:03:26Z  

    Hi Ryan,

    Detailed logs can be found under folders similar to :

    <path-to-sandbox>/runtime/wlp/usr/servers/server.liberty.sample_acmeair_mongo_javaweb.793ebdbfc211ae23/logs

    Could you please examine the log files or upload them for further troubleshooting?

  • ryan-soasta
    ryan-soasta
    4 Posts

    Re: Recieve Error 500 when attempting to connect to AcmeAir

    ‏2013-07-24T13:16:41Z  
    • LI Bo
    • ‏2013-07-24T03:03:26Z

    Hi Ryan,

    Detailed logs can be found under folders similar to :

    <path-to-sandbox>/runtime/wlp/usr/servers/server.liberty.sample_acmeair_mongo_javaweb.793ebdbfc211ae23/logs

    Could you please examine the log files or upload them for further troubleshooting?

    Hi Li,

    Attached are the log files. I can see an exception being thrown but still not sure what the error is.

    Thanks! Ryan

  • LI Bo
    LI Bo
    18 Posts

    Re: Recieve Error 500 when attempting to connect to AcmeAir

    ‏2013-07-25T01:06:57Z  

    Hi Li,

    Attached are the log files. I can see an exception being thrown but still not sure what the error is.

    Thanks! Ryan

    Hi Ryan,

     

    According the errors in the message.log, you missed the apache-common-logging library (commons-logging-1.1.2.jar) which is required as stated in the Icap.pdf. You can download and and add this jar to your customized component library.

    Thanks,

    Li Bo.

  • ryan-soasta
    ryan-soasta
    4 Posts

    Re: Recieve Error 500 when attempting to connect to AcmeAir

    ‏2013-07-25T02:29:33Z  
    • LI Bo
    • ‏2013-07-25T01:06:57Z

    Hi Ryan,

     

    According the errors in the message.log, you missed the apache-common-logging library (commons-logging-1.1.2.jar) which is required as stated in the Icap.pdf. You can download and and add this jar to your customized component library.

    Thanks,

    Li Bo.

    Hi Li,

    Thanks for catching that. I added commons-logging-1.1.2.jar but I still receive an error. The error does appear slightly different.

    Here are the new log files (and a screenshot confirming the loading of new jar)

    Here is the slightly different error message when I try to connect to the url:


    Error 500: javax.servlet.ServletException: Filter [com.acmeair.web.RESTCookieSessionFilter]: Could not find required filter class - com.acmeair.web.RESTCookieSessionFilter.class

    Thanks!

  • LI Bo
    LI Bo
    18 Posts

    Re: Recieve Error 500 when attempting to connect to AcmeAir

    ‏2013-07-25T05:18:37Z  

    Hi Li,

    Thanks for catching that. I added commons-logging-1.1.2.jar but I still receive an error. The error does appear slightly different.

    Here are the new log files (and a screenshot confirming the loading of new jar)

    Here is the slightly different error message when I try to connect to the url:


    Error 500: javax.servlet.ServletException: Filter [com.acmeair.web.RESTCookieSessionFilter]: Could not find required filter class - com.acmeair.web.RESTCookieSessionFilter.class

    Thanks!

    Hi Ryan,

    According to the messages.log, the problem was caused by several configuration files, including message resource, were not found. 

    Can you find the files in your project, as in the screenshot?

    How did you create the projects? Did you import the projects from the sandbox, as described in the ICAP pdf? 

    Attachments