Topic
  • 3 replies
  • Latest Post - ‏2018-05-11T15:52:21Z by satishpoojari
wei.huang
wei.huang
173 Posts

Pinned topic 3.5.3 platform upgrade errors: failed to import upgrade OM Packages

‏2017-12-14T21:25:35Z |

Hello,

Our customer has met an issue when installing 3.5.3 (linux, server build number: 276955) on an exisiting DataBase (on 3.4.2 / 10.4.2)

Everything goes well until startup the server.

Generally, Tririga will run a DB upgrade on the first startup when building number difference is detected.

From the Object Migration log below, we can notice that Tririga attempted to import the Upgrade OM Package localized under ibm-tririga.jar\com\tririga\util\startup\upgrade\systemobject\resources\

Import process started with triPlatformObjectLabelManager package, but it failed to import a navigation item, which is newly created for Label manager. I haven't found any log which can explain this failure.

I've checked NAV_ITEM table, this navigation item wasn't there before upgrade process

And then all the other packages are stuck on a pending pending status: Nothing happens after "Creating package from Zip file". This behavior causes also lots of sql update failure.

 

On our dev environment(windows, Server build number: 279835), upgrade goes very well you can find the difference from logs (OM log has been set on "Debug" level on both two servers)

Remark: the build number is slightly different between these two enviroment

 

Have you met this kind of issue?

Where can I find more details about the navigation item import failure?

Thanks for your help.

 

Updated on 2017-12-14T21:30:08Z at 2017-12-14T21:30:08Z by wei.huang
  • ChrisSpencer1
    ChrisSpencer1
    20 Posts

    Re: 3.5.3 platform upgrade errors: failed to import upgrade OM Packages

    ‏2018-01-03T13:45:05Z  

    Are build numbers you reference pre-upgrade or post-upgrade?

    ...Assuming pre, then your DEV environment is already ahead of 3.5.3 (as you reference build 279835 which is the 3.5.3 install. I think build  279835 would be 3.5.3.1 fix pack or similar?)

     

  • wei.huang
    wei.huang
    173 Posts

    Re: 3.5.3 platform upgrade errors: failed to import upgrade OM Packages

    ‏2018-01-08T14:03:50Z  

    Are build numbers you reference pre-upgrade or post-upgrade?

    ...Assuming pre, then your DEV environment is already ahead of 3.5.3 (as you reference build 279835 which is the 3.5.3 install. I think build  279835 would be 3.5.3.1 fix pack or similar?)

     

    Hello Chris,

    The build numbers was retired post-upgrade.

  • satishpoojari
    satishpoojari
    1 Post

    Re: 3.5.3 platform upgrade errors: failed to import upgrade OM Packages

    ‏2018-05-11T15:52:21Z  
    • wei.huang
    • ‏2018-01-08T14:03:50Z

    Hello Chris,

    The build numbers was retired post-upgrade.

    We have the same issue with upgrade process to 3.5.2.3  from 3.4.1.1 (in one of our environments, currently in 3.5.2). We get the login screen and are able to login to see a blank screen with style template. Admin console login works fine with all the components displayed. The error we get is similar as below:

    [com.tririga.util.startup.StartupServiceManagerServlet](Default Executor-thread-2) ****  DATA BASE BUILD NUMBER  252769 ****
    2018-04-22 21:59:08,424 WARN  [com.tririga.util.startup.StartupServiceManagerServlet](Default Executor-thread-2) **** WARNING!!! The database character set is inconsistent with the character length.  When using UTF character set which supports multi-byte characters the NLS_LENGTH_PARAMETER must be set to CHAR.  TRIRIGA and the database may not properly support Multi-Byte character data.  Refer to the Administration Guide for more details. ****
    2018-04-22 21:59:08,424 INFO  [com.tririga.util.startup.StartupServiceManagerServlet](Default Executor-thread-2) ***      System is in Production Mode (ProductionMode=Y)
    2018-04-22 21:59:08,496 INFO  [com.tririga.architecture.agent.DataConnectAgent](Default Executor-thread-2) DataConnect Agent - Setting Sleep time to 60000 millis
    2018-04-22 21:59:08,812 INFO  [com.tririga.util.startup.upgrade.systemobject.AbstractPlatformSystemObjectStartupUpgrade](Default Executor-thread-2) [PlatformObjectLabelManagerUpgrade] needs upgrading.
    2018-04-22 21:59:08,828 INFO  [com.tririga.util.startup.upgrade.StartupUpgradeManager](Default Executor-thread-2) Executing upgrade class: com.tririga.util.startup.upgrade.systemobject.PlatformSystemObjectRunFirstUpgrade
    2018-04-22 21:59:12,177 INFO  [com.tririga.util.startup.upgrade.systemobject.PlatformObjectLabelManagerUpgrade](Default Executor-thread-2) Unable to import triPlatformObjectLabelManager Upgrade package, required application dependencies are most likely missing.
    2018-04-22 21:59:12,178 WARN  [com.tririga.util.startup.upgrade.systemobject.AbstractPlatformSystemObjectStartupUpgrade](Default Executor-thread-2) [PlatformObjectLabelManagerUpgrade] did not upgrade properly.
    2018-04-22 21:59:12,179 ERROR [com.tririga.util.startup.upgrade.StartupUpgradeManager](Default Executor-thread-2) Error instantiating com.tririga.util.startup.upgrade.ObjectLabelRootLabelCleanup
    java.lang.RuntimeException: Could not instantiate class: class com.tririga.util.startup.upgrade.ObjectLabelRootLabelCleanup
     at com.tririga.util.startup.upgrade.StartupUpgradeManager.createUpgradeClassInstance(StartupUpgradeManager.java:193)
     at com.tririga.util.startup.upgrade.StartupUpgradeManager.access$000(StartupUpgradeManager.java:60)
     at com.tririga.util.startup.upgrade.StartupUpgradeManager$1.execute(StartupUpgradeManager.java:114)
     at com.tririga.platform.context.ContextServiceImpl.runInNewReadOnlyContext(ContextServiceImpl.java:177)
     

    The ObjectMigration log has the below error which explains:

    ERROR [com.tririga.platform.om.service.AbstractOMObjectImportService] [__triPlatformObjectLabelManager] module 1) Module Import failed.
    2018-04-22 21:59:12,177 ERROR [com.tririga.platform.om.service.OMContainerImportServiceImpl] Importing of package [UpgradeOM1311654159447148319_PlatformObjectLabelManagerUpgrade] failed.
    2018-04-22 21:59:12,499 INFO  [com.tririga.platform.om.domain.OMPackageFactoryImpl] Creating package from Zip file [triGraphics_09012016] begins
    2018-04-22 21:59:13,384 WARN  [com.tririga.platform.om.domain.OMPackageBuilder] [\IBM-TAP 3.5.2] object have an invalid type
    2018-04-22 21:59:13,385 WARN  [com.tririga.platform.om.domain.OMPackageBuilder] [\IBM-TAP 3.5.1] object have an invalid type
    2018-04-22 21:59:13,385 WARN  [com.tririga.platform.om.domain.OMPackageBuilder] [\Root 0.0] object have an invalid type
    2018-04-22 21:59:13,385 WARN  [com.tririga.platform.om.domain.OMPackageBuilder] [\In Progress 0.0] object have an invalid type
    2018-04-22 21:59:14,140 INFO  [com.tririga.platform.om.domain.OMPackageFactoryImpl] Creating package from Zip file [triGraphics_09012016] is complete

     

    Is there a fix available?

     

    Updated on 2018-05-11T16:02:39Z at 2018-05-11T16:02:39Z by satishpoojari