Topic
  • 3 replies
  • Latest Post - ‏2017-09-14T08:30:46Z by MoragH
asadafzaal
asadafzaal
2 Posts

Pinned topic Retrieve Bulk Messages from IBM MQ Out Queue using VB.Net

‏2017-09-09T08:52:45Z | .net; mq8;

Dears,

We have recently upgraded the server. We have windows service for getting messages from MQ server. After upgrading the server, we are having a problem while receiving bilk messages from IBM MQ Server. On every service run, it picks only one message. We have installed MQ Client Ver 8 and Windows Server 2012. It was working fine with MQ Client Ver 7 and Windows Server 2003 but the same is not working with new server. Code snippet is attached for reference.

 

 

Attachments

Updated on 2017-09-09T08:55:55Z at 2017-09-09T08:55:55Z by asadafzaal
  • MoragH
    MoragH
    117 Posts

    Re: Retrieve Bulk Messages from IBM MQ Out Queue using VB.Net

    ‏2017-09-11T11:40:31Z  

    I can see from your code snippet that you log the error, whether 2033 or something else. Can you tell us what that log says please?

  • asadafzaal
    asadafzaal
    2 Posts

    Re: Retrieve Bulk Messages from IBM MQ Out Queue using VB.Net

    ‏2017-09-14T08:05:56Z  
    • MoragH
    • ‏2017-09-11T11:40:31Z

    I can see from your code snippet that you log the error, whether 2033 or something else. Can you tell us what that log says please?

    Dear MoragH,

     

    Unfortunately, there is no error recorded. It run successfully but with the single record. I am still chasing this issue but as a workaround, I put the timer of 3-sec in windows service and it is fetching the single record after every 3 seconds.

    Please note that the same is working fine on the old server.

    Regards!

     

    Updated on 2017-09-14T08:07:13Z at 2017-09-14T08:07:13Z by asadafzaal
  • MoragH
    MoragH
    117 Posts

    Re: Retrieve Bulk Messages from IBM MQ Out Queue using VB.Net

    ‏2017-09-14T08:30:46Z  

    You have a decent amount of logging in that function. If it doesn't record an error from the get what does it show? Does it show a get happening at all? Can you post the logged output?