Topic
  • 1 reply
  • Latest Post - ‏2013-10-29T10:24:02Z by Brian DePradine
Graham Ashby
Graham Ashby
5 Posts

Pinned topic Trouble with Cloud Foundary manifest

‏2013-10-28T19:38:42Z |

I'm trying to use the liberty buildpack with a simple ear file.  I've got it all packaged up, as required, but I'm having trouble with the manifest.  I'm getting an error that I haven't accepted the IBM JVM license.

My current manifest is:

---
env:
  IBM_JVM_LICENSE: L-AWON-8GALN9
  IBM_LIBERTY_LICENSE: L-JTHS-95XRL8

path: defaultServer.zip

applications:
- name: tigerbeetle2
  memory: 256M
  instances: 1
  host: tigerbeetle2
  domain: ng.w3.bluemix.net
  buildpack: https://github.com/cloudfoundry/ibm-websphere-liberty-buildpack
 

  • Brian DePradine
    Brian DePradine
    1 Post

    Re: Trouble with Cloud Foundary manifest

    ‏2013-10-29T10:24:02Z  

    Hi Graham,

     

    The license information looks fine, but the path entry looks like it is in the wrong place. It should be a peer of the other application entries. For further information on manifests see the documentation here, http://docs.cloudfoundry.com/docs/using/deploying-apps/manifest.html

     

    Brian