Topic
3 replies Latest Post - ‏2013-11-03T20:57:44Z by HermannSW
rdp87
rdp87
39 Posts
ACCEPTED ANSWER

Pinned topic Sending SOAP message with Binary Attachment

‏2013-11-01T20:49:22Z |

Hi All,

I have to send binary file as attachment with SOAP message. I have  created a web service proxy and MTOM policy. I am getting following message after MTOM policy transformation.

 
Input selected for optimization contains xop:Include element

but i am not able to see attachment when i click on attachment tab in probe.

Also I am getting following error message 

 url-open: Remote error on url 'http://127.0.0.1:xxxxx/domainattachment/rdp.jpg?Encode=base64

can someone throw some light on this if you had done this in past or any thread in this forum which i can refer to.

Thanks.....

  • JoeMorganNTST
    JoeMorganNTST
    427 Posts
    ACCEPTED ANSWER

    Re: Sending SOAP message with Binary Attachment

    ‏2013-11-01T21:18:18Z  in response to rdp87

    Are you allowing attachments?

  • rdp87
    rdp87
    39 Posts
    ACCEPTED ANSWER

    Re: Sending SOAP message with Binary Attachment

    ‏2013-11-01T21:30:09Z  in response to rdp87

    Accept MTOM message check box is checked in web service proxy. Do i have to change some other settings to allow attachments.

     

    Thanks...

    • HermannSW
      HermannSW
      4320 Posts
      ACCEPTED ANSWER

      Re: Sending SOAP message with Binary Attachment

      ‏2013-11-03T20:57:44Z  in response to rdp87

      Hi,

      the error message "... Input selected for optimization contains xop:Include element ..." indicates that your input file already contains <xop:Include> element(s). But that should be the result of doing MTOM optimization -- for some element(s) their base64 strings will be decoded, attached, and an <xop:Inlcude> element will be inserted. Passing a document with <xop:Include> to MTOP optimization sounds wrong and leads to above error. Please send an input document without <xop:Include> and optimization should work fine.


      Hermann<myXsltBlog/> <myXsltTweets/> <myCE/>