Topic
  • 4 replies
  • Latest Post - ‏2013-04-09T06:47:04Z by nasica88
PowerLinuxFAQ
PowerLinuxFAQ
18 Posts

Pinned topic Pre-req question on advance-toolchain-at6.0-perf-6.0-1.ppc64.rpm package

‏2013-03-25T18:53:30Z |
I am trying to install advance-toolchain-at6.0-perf-6.0-1.ppc64.rpm package which is failing with the following message.

# rpm -Uhv advance-toolchain-at6.0-perf-6.0-1.ppc64.rpm
warning: advance-toolchain-at6.0-perf-6.0-1.ppc64.rpm: Header V4 DSA/SHA1 Signature, key ID 00f50ac5: NOKEY
error: Failed dependencies:
        libpfm.so.3()(64bit) is needed by advance-toolchain-at6.0-perf-6.0-1.ppc64

I installed advance-toolchain-at6.0-runtime-6.0-1.ppc64, which contains the gcc 4.7.x, but I am wondering what this at6.0-perf-6.0-1 package will do for us.
 
For the libpfm pre-req, I tried and succeeded in compiling its source code, but I still get the above error message

Updated on 2013-04-09T06:47:04Z at 2013-04-09T06:47:04Z by nasica88
  • Bill_Buros
    Bill_Buros
    164 Posts

    Re: Pre-req question on advance-toolchain-at6.0-perf-6.0-1.ppc64.rpm package

    ‏2013-03-25T18:57:19Z  
     To start, we generally recommend using the latest AT package.   See a recent blog post on the availability of AT 6.0-3
     
     
    Updated on 2013-03-25T18:57:19Z at 2013-03-25T18:57:19Z by Bill_Buros
  • Bill_Buros
    Bill_Buros
    164 Posts

    Re: Pre-req question on advance-toolchain-at6.0-perf-6.0-1.ppc64.rpm package

    ‏2013-03-25T19:17:18Z  
    For the pre-req, you need the papi-4.1.3-3.el6.ppc64 package
     
    I will append some examples of how to determine that 
      
  • willschm
    willschm
    47 Posts

    Re: Pre-req question on advance-toolchain-at6.0-perf-6.0-1.ppc64.rpm package

    ‏2013-03-29T15:31:23Z  
     > but I am wondering what this at6.0-perf-6.0-1 package will do for us.
     
    Per inspection, the -perf package contains the performance measuring utilities,  (oprofile/valgrind).
     
    > error: Failed dependencies:
    >         libpfm.so.3()(64bit) is needed by advance-toolchain-at6.0-perf-6.0-1.ppc64
     
     I wonder if that is a glitch due to 'upgrade' versus 'install' on rpm?   A locally installed 6.0-3-rc1 suggests libpfm.so.4 is provided by the advance-toolchain-*-perf rpm.
  • nasica88
    nasica88
    26 Posts

    Re: Pre-req question on advance-toolchain-at6.0-perf-6.0-1.ppc64.rpm package

    ‏2013-04-09T06:47:04Z  
    I had the same trouble with advance-toolchain-at6.0-perf-6.0-1.ppc64.rpm on RHEL 6.3. 
     
     I do not know which one did solve the error, but that error did not occur when I tried advance-toolchain-at6.0-perf-6.0-3.ppc64.rpm on RHEL 6.4.