Topic
  • 7 replies
  • Latest Post - ‏2013-10-15T07:29:40Z by RA GHU
RA GHU
RA GHU
4 Posts

Pinned topic IBM SECURITY ACCESS MANAGER

‏2013-10-11T08:50:04Z |

I installed and configured the TAM/SAM completely. The TDS server is working fine. When I try to start the policy server am facing the error.

C:\Program Files\Tivoli\Policy Director\bin>pdmgrd -foreground

 

Security Access Manager policy server v7.0.0.0 (Build 121029a)

 

Copyright (C) IBM Corporation 1994-2003.  All Rights Reserved.

 

2013-10-04-11:39:17.956-04:00I----- 0x35E5102B pdmgrd FATAL pdz general E:\build

\am700\src\Z\ZProperties.cpp 619 0x000009f4

HPDPZ0043E   An access function failed for configuration file C:\PROGRA~1\Tivoli

\Policy Director\etc\ivmgrd.conf.  The access function was fsopen() and return c

ode was 2.

2013-10-04-11:39:17.971-04:00I----- 0x1354A09A pdmgrd ERROR ivc general E:\build

\am700\src\util\cfgfile.cpp 95 0x000009f4

HPDCO0154E   Could not open configuration file (C:\PROGRA~1\Tivoli\Policy Direct

or\etc\ivmgrd.conf, 1).

2013-10-04-11:39:17.987-04:00I----- 0x14C010A4 pdmgrd FATAL mgr general E:\build

\am700\src\ivmgrd\ivmgrd.cpp 231 0x000009f4

HPDMG0164E   The Policy Server could not be started (0x1354a0c8).

 

The installed components are

C:\Program Files\Tivoli\Policy Director\bin>pdversion

Security Access Manager Runtime                         7.0.0.0

Security Access Manager Policy Server                   7.0.0.0

Security Access Manager Web Portal Manager              Not Installed

Security Access Manager Application Developer Kit       7.0.0.0

Security Access Manager Authorization Server            7.0.0.0

Security Access Manager Runtime for Java                7.0.0.0

Security Access Manager Policy Proxy Server             Not Installed

IBM Security Utilities                                  7.0.0.0

Any one help is appreciated.

  • Giri_Daks
    Giri_Daks
    99 Posts

    Re: IBM SECURITY ACCESS MANAGER

    ‏2013-10-11T09:38:58Z  

    I faced the similar issue in Solaris, I tried starting the server using the below command

    pdmgrd -config etc/ivmgrd.conf -foreground

    Also better to check the permission of the files and Key files mentioned in the ivmgrd.conf

     

    Regards,

    Giri

  • RA GHU
    RA GHU
    4 Posts

    Re: IBM SECURITY ACCESS MANAGER

    ‏2013-10-11T09:52:59Z  
    • Giri_Daks
    • ‏2013-10-11T09:38:58Z

    I faced the similar issue in Solaris, I tried starting the server using the below command

    pdmgrd -config etc/ivmgrd.conf -foreground

    Also better to check the permission of the files and Key files mentioned in the ivmgrd.conf

     

    Regards,

    Giri

    HI Giri,

    Thanks for your quick reply.

    As you suggest i tried to run the server using that command but still am facing the same issue.

    My system environment is windows server-2008. 

    And the system admin user having the full permissions like read and write access.

    It would be great help to share any installation/configuration setps. I will re-check the whole configuration.

     

    Thanks,

    Raghu.

  • goonitsupport
    goonitsupport
    103 Posts

    Re: IBM SECURITY ACCESS MANAGER

    ‏2013-10-11T10:48:37Z  
    • RA GHU
    • ‏2013-10-11T09:52:59Z

    HI Giri,

    Thanks for your quick reply.

    As you suggest i tried to run the server using that command but still am facing the same issue.

    My system environment is windows server-2008. 

    And the system admin user having the full permissions like read and write access.

    It would be great help to share any installation/configuration setps. I will re-check the whole configuration.

     

    Thanks,

    Raghu.

    does the ivmgrd..conf exist? where there any errors during configuration? does the Policy Manager show as configured or partial? and it won't run as service?

  • RA GHU
    RA GHU
    4 Posts

    Re: IBM SECURITY ACCESS MANAGER

    ‏2013-10-11T11:01:46Z  

    does the ivmgrd..conf exist? where there any errors during configuration? does the Policy Manager show as configured or partial? and it won't run as service?

    Hi

    Thanks for your reply.

    The ivmgrd.conf file exist in the following location. C:\Program Files\Tivoli\Policy Director\etc . When i was trying to configure the policy manager i faced some error those errors i resolved and its configured fully not partially.

    In services i didn't seen any kind of service name like tivoli policy server. I can see only IBM Tivoli directory admin server, TDS instance, TDSWebadmin,  

    Thanks,

    Raghu.

  • Giri_Daks
    Giri_Daks
    99 Posts

    Re: IBM SECURITY ACCESS MANAGER

    ‏2013-10-11T14:54:54Z  
    • RA GHU
    • ‏2013-10-11T09:52:59Z

    HI Giri,

    Thanks for your quick reply.

    As you suggest i tried to run the server using that command but still am facing the same issue.

    My system environment is windows server-2008. 

    And the system admin user having the full permissions like read and write access.

    It would be great help to share any installation/configuration setps. I will re-check the whole configuration.

     

    Thanks,

    Raghu.

    Hi Raghu,

    HPDPZ0043E   An access function failed for configuration file C:\PROGRA~1\Tivoli

    \Policy Director\etc\ivmgrd.conf.  The access function was fsopen() and return c

    ode was 2.

    Whats the user and group mapped to the file ivmgrd.conf, I guess the service should be started as ivmgr, is ivmgr is a part of the Admin group?

     

    Regards,

    Giri

  • goonitsupport
    goonitsupport
    103 Posts

    Re: IBM SECURITY ACCESS MANAGER

    ‏2013-10-11T19:29:41Z  
    • Giri_Daks
    • ‏2013-10-11T14:54:54Z

    Hi Raghu,

    HPDPZ0043E   An access function failed for configuration file C:\PROGRA~1\Tivoli

    \Policy Director\etc\ivmgrd.conf.  The access function was fsopen() and return c

    ode was 2.

    Whats the user and group mapped to the file ivmgrd.conf, I guess the service should be started as ivmgr, is ivmgr is a part of the Admin group?

     

    Regards,

    Giri

    I don't have a TAM/SAM environment (why do we always change the names) at the moment. Personally I would unconfigure and reconfigure.

     

    You definitely should have a service. And as Giri_Daks says, I believe the user will need to be a member of the ivmgr group to be able to run.

    Might be time to start again, it shouldn't take long.

  • RA GHU
    RA GHU
    4 Posts

    Re: IBM SECURITY ACCESS MANAGER

    ‏2013-10-15T07:29:40Z  

    I don't have a TAM/SAM environment (why do we always change the names) at the moment. Personally I would unconfigure and reconfigure.

     

    You definitely should have a service. And as Giri_Daks says, I believe the user will need to be a member of the ivmgr group to be able to run.

    Might be time to start again, it shouldn't take long.

    Hi giri,

    I have not created any groups name like ivmgr. I am using windows server 2008. I created one user when i was configuring the policy server that is sec_master only. 

    Can you please guide me for this configuration for this we need to create any groups and users?

    If you have any documents for configuring the SAM please forward to me. I will follow that document and will reconfigure

    My mail id raghu673@gmail.com.

    Thanks,

    Raghu.