Topic
  • 8 replies
  • Latest Post - ‏2015-01-30T20:19:51Z by MoizQ
FadiOmar
FadiOmar
24 Posts

Pinned topic How to hide Batch fields in start panel?

‏2012-12-18T13:19:49Z |
Can I configure some Batch fields so they will not be shown  in the start panel ?
 
Please Help...
 
Thanks 
Updated on 2012-12-22T05:07:59Z at 2012-12-22T05:07:59Z by FadiOmar
  • DavidLaffitte
    DavidLaffitte
    18 Posts

    Re: How to hide Batch fields in start panel?

    ‏2012-12-18T13:55:35Z  
     Hi Fadi, 
    • Open Studio and lock the Document Hierachy
    • Right click on your field and select "Manage Variables..."
    • Click New and type in "STATUS" without the quotes
    • Set the STATUS to -1

    That will hide the field in the build in datacap interfaces.  Page 438 of the application and development guide documents the Status variable.

     
    David 
  • FadiOmar
    FadiOmar
    24 Posts

    Re: How to hide Batch fields in start panel?

    ‏2012-12-19T05:28:05Z  
     Hi Fadi, 
    • Open Studio and lock the Document Hierachy
    • Right click on your field and select "Manage Variables..."
    • Click New and type in "STATUS" without the quotes
    • Set the STATUS to -1

    That will hide the field in the build in datacap interfaces.  Page 438 of the application and development guide documents the Status variable.

     
    David 
     Hi David,
     
    Thanks for reply,Actually I tried this, only I got was that the field was highlighted  in red!
     
    Fadi 
  • DavidLaffitte
    DavidLaffitte
    18 Posts

    Re: How to hide Batch fields in start panel?

    ‏2012-12-20T15:14:42Z  
     Hmmm...is the field hidden in other interfaces such as verify?
     
    Did you use all caps? 
     
    David 
  • FadiOmar
    FadiOmar
    24 Posts

    Re: How to hide Batch fields in start panel?

    ‏2012-12-22T05:07:59Z  
     Hmmm...is the field hidden in other interfaces such as verify?
     
    Did you use all caps? 
     
    David 
     Hi David,
     
    You Know that the Batch-Level fields doesn't appear in verification pages .... 
    Just in the scan popup panel.
  • Verdarb
    Verdarb
    23 Posts

    Re: How to hide Batch fields in start panel?

    ‏2013-08-13T03:36:16Z  

    Someone solved this problem already?

  • geethajini
    geethajini
    63 Posts

    Re: How to hide Batch fields in start panel?

    ‏2015-01-29T12:34:03Z  
    • Verdarb
    • ‏2013-08-13T03:36:16Z

    Someone solved this problem already?

    hi,

    did someone find a solution for hiding few fields in start batch panel?

     

    thanks,

    Geetha

  • TomBusilloMiria
    TomBusilloMiria
    173 Posts

    Re: How to hide Batch fields in start panel?

    ‏2015-01-29T14:54:56Z  

    hi,

    did someone find a solution for hiding few fields in start batch panel?

     

    thanks,

    Geetha

    As far as I know, its not possible to hide fields on a start batch panel by changing the status to -1.  Hopefully one of the IBM guys can confirm this,

  • MoizQ
    MoizQ
    301 Posts

    Re: How to hide Batch fields in start panel?

    ‏2015-01-30T20:19:51Z  

    As far as I know, its not possible to hide fields on a start batch panel by changing the status to -1.  Hopefully one of the IBM guys can confirm this,

    You can hide fields on the start batch panel.  The origination of hidden fields was primarily centered around the verification/indexing panels; anchor fields being a primary example.  As for the start batch panel, usually variables would be used to enter data that is not to be displayed - e.g. through panel customization or during rules execution.

    However, the way the panel is generated and various underlying logic, even though this behavior was not particularly considered for the start panel, similar to verifine.aspx, as long as you assign an IFS status, the field should not be displayed.  If using a static panel, then it's even 'easier' as the ASCX markup can be modified at will to achieve whatever is necessary.

    If you assign the program name to be vscancl.aspx, then omitted from the task settings is the Page Processing section which contains setup for DFS and IFS.  Try using Multiple or maybe manually copy the section temporarily into the *.set.xml file, and ensure that IFS is setup (default of -1).  Then change the field definition in the setup hierarchy to default to STATUS of -1.  Field shouldn't show in the panel.

    Tried it myself (albeit post-FP2) and it worked fine.  Give it an attempt of your own.

    Edit: FYI, I assumed this was about Taskmaster Web.  Don't know off-hand about other clients.

    Updated on 2015-01-30T20:25:18Z at 2015-01-30T20:25:18Z by MoizQ