Topic
  • 4 replies
  • Latest Post - ‏2014-07-10T16:23:54Z by DaveN
SHADO Control
SHADO Control
2 Posts

Pinned topic CICS TG plug-in V2.1.0 with an CICS Explorer V5.2 Eclipse-based Install

‏2014-07-09T18:09:13Z |

Hi,

 

I've recently installed CICS Explorer V5.2 and was successfully able to connect into the WUI as part of the verification of CICS Explorer. Then, I performed a Direct Download of CICS Transaction Gateway plug-in V2.1.0 for CICS Explorer from the bottom of the CICS Explorer Download page. Upon following the install process, as detailed in the CICS TG release notes, the Next> bar does not highlight after selecting the product from the CICS Explorer's Help > Install New Software > Available Software pop-up.

 

Within the ctg_plugin_release_notes, there is mention of the following System Requirement:

The CICS TG plug-in must be installed in the CICS Explorer Version 5.2.0 open beta.

 

The system specifics and product installation order are as follows:

Thinkpad T440 with Windows 7 Enterprise SP1 64-bit

Oracle Java SE 8u5 64-bit

Eclipse V4.2.2 64-bit

IBM Explorer for z/OS w/MQ Explorer

CICS Explorer V5.2 32-bit

CICS TG plug-in V5.2 - attempted

 

Followed the Eclipse addressing matrix listed in blue:

Win 64  -  Java 64  -  Eclipse 64  -  CICS Explorer 32

Win 64  -  Java 32  -  Eclipse 32  -  CICS Explorer 32

Win 32  -  Java 32  -  Eclipse 32  -  CICS Explorer 32

 

Installation Notes:

1) The CICS Explorer V5.2 on-line system requirements contained a blank prerequisite section, either Eclipse or Java were listed.

2) Eclipse was installed based off of its tested and verified JRE levels, JRE 8u5 was selected and installed prior to the Eclipse install.

3) The CICS Explorer/readme/readme_eclipse file does not mention JRE 8u5 as a tested and verified version of Java, but operates without issue.

 

I'm not sure if the inability to select the CICS TG plug-in is due to:

a) the CICS TG open beta prerequisite

b) the level of JRE is higher than detailed for CICS Explorer (which runs fine). JRE levels are not mentioned in the CTG release notes.

c) another issue.

 

Any assistance would be greatly appreciated.

-Wayne

Updated on 2014-07-09T18:10:02Z at 2014-07-09T18:10:02Z by SHADO Control
  • DaveN
    DaveN
    83 Posts

    Re: CICS TG plug-in V2.1.0 with an CICS Explorer V5.2 Eclipse-based Install

    ‏2014-07-10T08:09:11Z  

    Hi Wayne,

    Thanks for the very detailed description! :-)

    The CICS Explorer supported platform would be Eclipse 32-bit with Java 7 32-bit. This means that to open a PMR and get full support, you'd need to recreate your problem in that environment. (This is what it means when it says that we support Windows 64-bit with 32 bitness in the system requirements).

    Having said that, I don't believe that using Eclipse 64-bit would cause the problems you describe (I think we would work fine on Eclipse 64-bit, it's just not a configuration that we fully test).

    I don't believe we've ever tried on Java 8, however.

    Could you attach a screenshot of what's happening, please? I am mainly interested in which URL you're using to install from, the only way I can see that next wouldn't enable is if the URL you're trying to install from didn't have any software in it.

    I would be expecting you to use this URL: http://public.dhe.ibm.com/software/htp/zos/tools/1/

    Thanks,

    Dave

  • DaveN
    DaveN
    83 Posts

    Re: CICS TG plug-in V2.1.0 with an CICS Explorer V5.2 Eclipse-based Install

    ‏2014-07-10T08:57:46Z  
    • DaveN
    • ‏2014-07-10T08:09:11Z

    Hi Wayne,

    Thanks for the very detailed description! :-)

    The CICS Explorer supported platform would be Eclipse 32-bit with Java 7 32-bit. This means that to open a PMR and get full support, you'd need to recreate your problem in that environment. (This is what it means when it says that we support Windows 64-bit with 32 bitness in the system requirements).

    Having said that, I don't believe that using Eclipse 64-bit would cause the problems you describe (I think we would work fine on Eclipse 64-bit, it's just not a configuration that we fully test).

    I don't believe we've ever tried on Java 8, however.

    Could you attach a screenshot of what's happening, please? I am mainly interested in which URL you're using to install from, the only way I can see that next wouldn't enable is if the URL you're trying to install from didn't have any software in it.

    I would be expecting you to use this URL: http://public.dhe.ibm.com/software/htp/zos/tools/1/

    Thanks,

    Dave

    Hi Wayne,

    A colleague has just pointed out that you used the direct download rather than using a URL as I implied.

    I'd still like to see the screenshot! The only thing I can of is that you've used the Installation Manager zip accidentally - I'd be expecting you to use the "file type .zip/.gz" which is unhelpfully named!

    When I use that zip, with Explorer 5.2, I see the screen attached. If I tick "IBM CICS Transaction Gateway Plugin", the Next button is enabled.

    Dave

     

    Attachments

  • SHADO Control
    SHADO Control
    2 Posts

    Re: CICS TG plug-in V2.1.0 with an CICS Explorer V5.2 Eclipse-based Install

    ‏2014-07-10T15:02:31Z  
    • DaveN
    • ‏2014-07-10T08:57:46Z

    Hi Wayne,

    A colleague has just pointed out that you used the direct download rather than using a URL as I implied.

    I'd still like to see the screenshot! The only thing I can of is that you've used the Installation Manager zip accidentally - I'd be expecting you to use the "file type .zip/.gz" which is unhelpfully named!

    When I use that zip, with Explorer 5.2, I see the screen attached. If I tick "IBM CICS Transaction Gateway Plugin", the Next button is enabled.

    Dave

     

    Hi Dave,

    Yes, I did the direct download of the CICS TG file, as it was not displayed in the list of available products after the z/OS link was added. I downloaded the CICS TG plug-in as a compressed file and placed it on a networked drive, without uncompressing it (per instructions).

    I had checked to see if the CTG plug-in was bumdled in the zos file, but it never displayed, as detailed in the attachment.

    I'm going to try and attach a MSWord document with the various screen prints that detail this installation.

    Regards,

    Wayne

  • DaveN
    DaveN
    83 Posts

    Re: CICS TG plug-in V2.1.0 with an CICS Explorer V5.2 Eclipse-based Install

    ‏2014-07-10T16:23:54Z  

    Hi Dave,

    Yes, I did the direct download of the CICS TG file, as it was not displayed in the list of available products after the z/OS link was added. I downloaded the CICS TG plug-in as a compressed file and placed it on a networked drive, without uncompressing it (per instructions).

    I had checked to see if the CTG plug-in was bumdled in the zos file, but it never displayed, as detailed in the attachment.

    I'm going to try and attach a MSWord document with the various screen prints that detail this installation.

    Regards,

    Wayne

    OK I've never seen an Available Software dialog looking like that!

    You could try resizing the dialog and see if it's some kind of bug in Java and it pings into life.

    If that doesn't help I'd try downloading a Java 7 - you don't necessarily need to install it as your main java, download the zip (rather than InstallShield) version, unzip it, and run eclipse with the option -vm c:\path\to\the\directory\called\jre

    Dave