Topic
  • 5 replies
  • Latest Post - ‏2013-05-28T12:48:46Z by JeanL
JeanL
JeanL
3 Posts

Pinned topic Installing TBSM 6.1 using Console

‏2013-05-13T14:18:55Z |

I have tried to installed TBSM using the console method with little success. In am installing TBSM on Zlinux. The portion I am having trouble is when I issue the command setup-zlinux.bin.

I follow through and provide answers to the different screens and questions and at the end, when it launches the progress bar, it has failed at least 5 times because of this error. Stop TBSM Profile and twice for TWA Marker Installation

For the Stop TBSM profile, the stopServer.sh server1 is executed but either timesout or does not get a reply that the server1 is stopped, thus is failes the installation. I got it to work once by change the timeout value in soap.client.props

 

Any insight would be helpfull

Thanks

Jean Lamoureux

===============================================================================

Install Complete

----------------

The installation failed at step: Stop TBSM Profile.

PRESS <ENTER> TO CONTINUE:

 

==============================================================================

Install Complete

----------------

The installation failed at step: TWA Marker Installation.

 PRESS <ENTER> TO CONTINUE:

 

  • DanielTNguyen
    DanielTNguyen
    2 Posts
    ACCEPTED ANSWER

    Re: Installing TBSM 6.1 using Console

    ‏2013-05-14T19:55:28Z  

    Hi Jean

    I have question about changing the value in value in soap.client.props . Did you change the value while the installer still running ?

    I am not sure why the installation failed at the TWA Marker step. In order for me to debug the bug, could you send me some logs from your machine if you still have the failed installation? The logs.zip is to big to post it here so I need the following subset of log files

    1) Zip the entire log directory IBM/tivoli/tbsm/logs/install

    2) Zip the entire log directory IBM/tivoli/tbsm/_uninst/TBSMInstall611/plan/install/MachinePlan_localhost/logs

    3) Zip the entire directory IBM/tivoli/tbsm/_uninst/TBSMInstall611/plan/install/MachinePlan_localhost/00xxx_IAGLOBAL_COI_STEP_TWA_MARKER

    I think that's all the logs I need for now.

    Thanks

    Dan Nguyen

  • GER_MCC
    GER_MCC
    13 Posts
    ACCEPTED ANSWER

    Re: Installing TBSM 6.1 using Console

    ‏2013-05-21T09:18:52Z  

    Jean

    I dont know why ApplyPoliciesFor61FP1 script doesn't work on your environment.  Please open a PMR and someone from L3 will investigate the issue.

    Hi. I see a new PMR for this issue. 37824,072,649. Is this PMR relating to this post. If not, please open a new PMR.

    The error with policy script can be given for many reasons, but in general it indicates a communication problem with the servers. If rad_radshell is producing a prompt, then this indicates that the TBSM Data Server is OK. Please check this. If no prompt is returned support will have to look at the logs. Use collect_logs script to gather logs and indicate the time when ApplyPoliciesFor61FP1 was run.

  • DanielTNguyen
    DanielTNguyen
    2 Posts

    Re: Installing TBSM 6.1 using Console

    ‏2013-05-14T19:55:28Z  

    Hi Jean

    I have question about changing the value in value in soap.client.props . Did you change the value while the installer still running ?

    I am not sure why the installation failed at the TWA Marker step. In order for me to debug the bug, could you send me some logs from your machine if you still have the failed installation? The logs.zip is to big to post it here so I need the following subset of log files

    1) Zip the entire log directory IBM/tivoli/tbsm/logs/install

    2) Zip the entire log directory IBM/tivoli/tbsm/_uninst/TBSMInstall611/plan/install/MachinePlan_localhost/logs

    3) Zip the entire directory IBM/tivoli/tbsm/_uninst/TBSMInstall611/plan/install/MachinePlan_localhost/00xxx_IAGLOBAL_COI_STEP_TWA_MARKER

    I think that's all the logs I need for now.

    Thanks

    Dan Nguyen

  • JeanL
    JeanL
    3 Posts

    Re: Installing TBSM 6.1 using Console

    ‏2013-05-17T14:45:33Z  

    Hi Jean

    I have question about changing the value in value in soap.client.props . Did you change the value while the installer still running ?

    I am not sure why the installation failed at the TWA Marker step. In order for me to debug the bug, could you send me some logs from your machine if you still have the failed installation? The logs.zip is to big to post it here so I need the following subset of log files

    1) Zip the entire log directory IBM/tivoli/tbsm/logs/install

    2) Zip the entire log directory IBM/tivoli/tbsm/_uninst/TBSMInstall611/plan/install/MachinePlan_localhost/logs

    3) Zip the entire directory IBM/tivoli/tbsm/_uninst/TBSMInstall611/plan/install/MachinePlan_localhost/00xxx_IAGLOBAL_COI_STEP_TWA_MARKER

    I think that's all the logs I need for now.

    Thanks

    Dan Nguyen

    Hi Dan

    Yes I changed the value while it was loading, I kept searching for it until it was created then i modified the timeout value to 6000. But also i modified 2 ulimit values prior to running the setup-zlinux.bin I set ulimit -f = unlimited and ulimit -n 8192

    It then succesfully installed.

     

    Now I have another issues with TBSM, I installed the fixpack 7 for TBSM and now in the section of the install where it need to apply the TBSM policied from the fixpack and I and getting these errors

    netcool@vkez-toe:/opt/IBM/tivoli/tbsm/bin> ./ApplyPoliciesFor61FP1 tipadmin tiv0li

    nci_policy: Failed to invoke command [pushPolicy] (error 1)

    nci_policy: Failed to invoke command [pushPolicy] (error 1)

    nci_policy: Failed to invoke command [pushPolicy] (error 1)

    nci_policy: Failed to invoke command [pushPolicy] (error 1)

    nci_policy: Failed to invoke command [pushPolicy] (error 1)

    nci_policy: Failed to invoke command [pushPolicy] (error 1)

    nci_policy: Failed to invoke command [pushPolicy] (error 1)

    nci_trigger: Failed to trigger policy [ResEnrichReaderRecycle] (error 1)

    This is a partial log, it seesm to indicate an issue with java, but I am not an expert in TBSM

    Any help would be appreciated

    Thanks

    Jean

    INFO: Client code attempting to load security configuration
    java.lang.NoClassDefFoundError: com.ibm.ffdc.Manager
            at com.ibm.websphere.management.AdminClientFactory.createAdminClientPrivileged(AdminClientFactory.java:765)
            at com.ibm.websphere.management.AdminClientFactory.access$000(AdminClientFactory.java:122)
            at com.ibm.websphere.management.AdminClientFactory$1.run(AdminClientFactory.java:203)
            at com.ibm.ws.security.util.AccessController.doPrivileged(AccessController.java:63)
            at com.ibm.websphere.management.AdminClientFactory.createAdminClient(AdminClientFactory.java:199)
            at com.micromuse.response.client.cli.WebSphereJmxConnection.createAdminClient(WebSphereJmxConnection.java:182)
            at com.micromuse.response.client.cli.WebSphereJmxConnection.createAdminClient(WebSphereJmxConnection.java:170)
            at com.micromuse.response.client.cli.WebSphereJmxConnection.connect(WebSphereJmxConnection.java:116)
            at com.micromuse.response.client.cli.CommandLineTool.execute(CommandLineTool.java:140)
            at com.micromuse.response.client.cli.CommandLineTool.main(CommandLineTool.java:607)
    Caused by: java.lang.ClassNotFoundException: com.ibm.ffdc.Manager
            at java.net.URLClassLoader.findClass(URLClassLoader.java:434)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:653)
            at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:358)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:619)
            ... 10 more
    May 17, 2013 10:28:23 AM null null
    INFO: Client code attempting to load security configuration
    May 17, 2013 10:28:24 AM null null
    INFO: Client code attempting to load security configuration
    java.lang.NoClassDefFoundError: com.ibm.ffdc.Manager
            at com.ibm.websphere.management.AdminClientFactory.createAdminClientPrivileged(AdminClientFactory.java:765)
            at com.ibm.websphere.management.AdminClientFactory.access$000(AdminClientFactory.java:122)
            at com.ibm.websphere.management.AdminClientFactory$1.run(AdminClientFactory.java:203)
            at com.ibm.ws.security.util.AccessController.doPrivileged(AccessController.java:63)
            at com.ibm.websphere.management.AdminClientFactory.createAdminClient(AdminClientFactory.java:199)
            at com.micromuse.response.client.cli.WebSphereJmxConnection.createAdminClient(WebSphereJmxConnection.java:182)
            at com.micromuse.response.client.cli.WebSphereJmxConnection.createAdminClient(WebSphereJmxConnection.java:170)
            at com.micromuse.response.client.cli.WebSphereJmxConnection.connect(WebSphereJmxConnection.java:116)
            at com.micromuse.response.client.cli.CommandLineTool.execute(CommandLineTool.java:140)
            at com.micromuse.response.client.cli.CommandLineTool.main(CommandLineTool.java:607)
    Caused by: java.lang.ClassNotFoundException: com.ibm.ffdc.Manager
            at java.lang.ClassNotFoundException.<init>(ClassNotFoundException.java:76)
            at java.net.URLClassLoader.findClass(URLClassLoader.java:396)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:653)
            at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:358)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:619)
            ... 10 more
    netcool@vkez-toe:/opt/IBM/tivoli/tbsm/bin>
     

     

  • DanielTNguyen
    DanielTNguyen
    2 Posts

    Re: Installing TBSM 6.1 using Console

    ‏2013-05-17T19:31:52Z  
    • JeanL
    • ‏2013-05-17T14:45:33Z

    Hi Dan

    Yes I changed the value while it was loading, I kept searching for it until it was created then i modified the timeout value to 6000. But also i modified 2 ulimit values prior to running the setup-zlinux.bin I set ulimit -f = unlimited and ulimit -n 8192

    It then succesfully installed.

     

    Now I have another issues with TBSM, I installed the fixpack 7 for TBSM and now in the section of the install where it need to apply the TBSM policied from the fixpack and I and getting these errors

    netcool@vkez-toe:/opt/IBM/tivoli/tbsm/bin> ./ApplyPoliciesFor61FP1 tipadmin tiv0li

    nci_policy: Failed to invoke command [pushPolicy] (error 1)

    nci_policy: Failed to invoke command [pushPolicy] (error 1)

    nci_policy: Failed to invoke command [pushPolicy] (error 1)

    nci_policy: Failed to invoke command [pushPolicy] (error 1)

    nci_policy: Failed to invoke command [pushPolicy] (error 1)

    nci_policy: Failed to invoke command [pushPolicy] (error 1)

    nci_policy: Failed to invoke command [pushPolicy] (error 1)

    nci_trigger: Failed to trigger policy [ResEnrichReaderRecycle] (error 1)

    This is a partial log, it seesm to indicate an issue with java, but I am not an expert in TBSM

    Any help would be appreciated

    Thanks

    Jean

    INFO: Client code attempting to load security configuration
    java.lang.NoClassDefFoundError: com.ibm.ffdc.Manager
            at com.ibm.websphere.management.AdminClientFactory.createAdminClientPrivileged(AdminClientFactory.java:765)
            at com.ibm.websphere.management.AdminClientFactory.access$000(AdminClientFactory.java:122)
            at com.ibm.websphere.management.AdminClientFactory$1.run(AdminClientFactory.java:203)
            at com.ibm.ws.security.util.AccessController.doPrivileged(AccessController.java:63)
            at com.ibm.websphere.management.AdminClientFactory.createAdminClient(AdminClientFactory.java:199)
            at com.micromuse.response.client.cli.WebSphereJmxConnection.createAdminClient(WebSphereJmxConnection.java:182)
            at com.micromuse.response.client.cli.WebSphereJmxConnection.createAdminClient(WebSphereJmxConnection.java:170)
            at com.micromuse.response.client.cli.WebSphereJmxConnection.connect(WebSphereJmxConnection.java:116)
            at com.micromuse.response.client.cli.CommandLineTool.execute(CommandLineTool.java:140)
            at com.micromuse.response.client.cli.CommandLineTool.main(CommandLineTool.java:607)
    Caused by: java.lang.ClassNotFoundException: com.ibm.ffdc.Manager
            at java.net.URLClassLoader.findClass(URLClassLoader.java:434)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:653)
            at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:358)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:619)
            ... 10 more
    May 17, 2013 10:28:23 AM null null
    INFO: Client code attempting to load security configuration
    May 17, 2013 10:28:24 AM null null
    INFO: Client code attempting to load security configuration
    java.lang.NoClassDefFoundError: com.ibm.ffdc.Manager
            at com.ibm.websphere.management.AdminClientFactory.createAdminClientPrivileged(AdminClientFactory.java:765)
            at com.ibm.websphere.management.AdminClientFactory.access$000(AdminClientFactory.java:122)
            at com.ibm.websphere.management.AdminClientFactory$1.run(AdminClientFactory.java:203)
            at com.ibm.ws.security.util.AccessController.doPrivileged(AccessController.java:63)
            at com.ibm.websphere.management.AdminClientFactory.createAdminClient(AdminClientFactory.java:199)
            at com.micromuse.response.client.cli.WebSphereJmxConnection.createAdminClient(WebSphereJmxConnection.java:182)
            at com.micromuse.response.client.cli.WebSphereJmxConnection.createAdminClient(WebSphereJmxConnection.java:170)
            at com.micromuse.response.client.cli.WebSphereJmxConnection.connect(WebSphereJmxConnection.java:116)
            at com.micromuse.response.client.cli.CommandLineTool.execute(CommandLineTool.java:140)
            at com.micromuse.response.client.cli.CommandLineTool.main(CommandLineTool.java:607)
    Caused by: java.lang.ClassNotFoundException: com.ibm.ffdc.Manager
            at java.lang.ClassNotFoundException.<init>(ClassNotFoundException.java:76)
            at java.net.URLClassLoader.findClass(URLClassLoader.java:396)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:653)
            at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:358)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:619)
            ... 10 more
    netcool@vkez-toe:/opt/IBM/tivoli/tbsm/bin>
     

     

    Jean

    I dont know why ApplyPoliciesFor61FP1 script doesn't work on your environment.  Please open a PMR and someone from L3 will investigate the issue.

  • GER_MCC
    GER_MCC
    13 Posts

    Re: Installing TBSM 6.1 using Console

    ‏2013-05-21T09:18:52Z  

    Jean

    I dont know why ApplyPoliciesFor61FP1 script doesn't work on your environment.  Please open a PMR and someone from L3 will investigate the issue.

    Hi. I see a new PMR for this issue. 37824,072,649. Is this PMR relating to this post. If not, please open a new PMR.

    The error with policy script can be given for many reasons, but in general it indicates a communication problem with the servers. If rad_radshell is producing a prompt, then this indicates that the TBSM Data Server is OK. Please check this. If no prompt is returned support will have to look at the logs. Use collect_logs script to gather logs and indicate the time when ApplyPoliciesFor61FP1 was run.

  • JeanL
    JeanL
    3 Posts

    Re: Installing TBSM 6.1 using Console

    ‏2013-05-28T12:48:46Z  
    • GER_MCC
    • ‏2013-05-21T09:18:52Z

    Hi. I see a new PMR for this issue. 37824,072,649. Is this PMR relating to this post. If not, please open a new PMR.

    The error with policy script can be given for many reasons, but in general it indicates a communication problem with the servers. If rad_radshell is producing a prompt, then this indicates that the TBSM Data Server is OK. Please check this. If no prompt is returned support will have to look at the logs. Use collect_logs script to gather logs and indicate the time when ApplyPoliciesFor61FP1 was run.