Topic
1 reply Latest Post - ‏2013-07-13T23:21:32Z by MelFowler
ENO2010
ENO2010
44 Posts
ACCEPTED ANSWER

Pinned topic RDZ 8.5.1 - PL1 IBM3557I

‏2013-06-27T14:36:38Z |

Hi,

 

I have a PL1 program where we use the NOT statement coded as "^=0".

the PL1 editor gives me the next warning :IBM3557I E Character with decimal value 176 does not belong to the PL/I character set. It is assumed to be a NOT symbol.

Can someone tell how I can solve this issue?

 

regards

 

Eric

  • MelFowler
    MelFowler
    4 Posts
    ACCEPTED ANSWER

    Re: RDZ 8.5.1 - PL1 IBM3557I

    ‏2013-07-13T23:21:32Z  in response to ENO2010

    Hello Eric,

     

    The PL/I compiler does not recognize the character ^ as a not sign by default, so uou need to specify the NOT compiler option.

    In your case NOT('^'). 

    The cleanest, and my favorite, is to use the not compile option is right in the source, in a *PROCESS card.

    The reason this is the cleanest is that if the source moves from one code page to the next, the not sign in the source

    and the not sign in the *PROCESS card will stay the same.

     

    For many, altering the source to add the NOT compile option is not an option available to them.

    So, you can specify this option in the property group, as NOT('^') or you can use the hex value of decimal 176.  NOT(X'B0').

    If the compiler was giving you an error on the Remote Build, specify this in the Compiler Options field of the Procedures And Steps page

    for your PL/I compile. 

    If you were performing a local syntax check, you will need to specify this option in the compile options entry field on the local compile tab.

     

    Depending on your source, you may need to use the OR compile option as well.  It works just like the NOT compile option. 

     

    Thanks,

     

    Mel Fowler