Topic
  • 1 reply
  • Latest Post - ‏2014-04-08T20:09:21Z by TuukkaIlomäki
paoloc
paoloc
525 Posts

Pinned topic javaServerFaces2.1

‏2014-04-08T17:09:55Z |

In a project I need to use javaServeFaces2.1 because Primefaces 4.0 requires  version 2.0 or 2.1.

When I create the project and try to change javaServeFaces to 2.0 or 2.1 I get the following error message:

If I disable the function JavaServer Faces (IBM enhanced) (Deprecated) 7.0 requires JavaServer Faces with version matching expression "1.1,1.2".

If I disable the function JavaServer Faces (IBM enhanced) (Deprecated) i get the following error message:

EGL support with JSF 7.0 requires JavaServer Faces (IBM enhanced) (Deprecated) 7.0 or newer.

Is javaServerFaces2.1 disabled ?

paoloc

  • TuukkaIlomäki
    TuukkaIlomäki
    68 Posts

    Re: javaServerFaces2.1

    ‏2014-04-08T20:09:21Z  

    Only JSF 1.1 spec is supported in EGL, but you can use JSF 1.2 runtime. As EGL for JSF development is already deprecated, you'll need to drop EGL if newer JSF is required.