Topic
  • 5 replies
  • Latest Post - ‏2013-12-04T18:41:31Z by N Campbell
AGBird
AGBird
6 Posts

Pinned topic Issues to connect with MY SQL 5.0.77 using JDBC with Cognos 10.2.1

‏2013-09-12T12:24:56Z |

Hi

We are using Cognos 10.2.1. Trying to connect with MY SQL 5.0.77 using JDBC Dynamic Query. Getting the below failure notice

XQE-JDB-0017 "MySQL" version "5.0" of the server at "jdbc:mysql://lhrrhebdolq001z.enterprisenet.org:3306/bdol" is defined as not supported with the "blacklist.serverVersion" property.

In New Data source wizard selected the JDBC type

Under JDBC connection selected the TYPE MySQL.

Provided the JDBC URL : jdbc:mysql://lhrrhebdolq001z.enterprisenet.org:3306/bdol

Driver class name : com.mysql.jdbc.Driver

provided the user name and password. Tried to test the connection, getting the "XQE-JDB-0017" error.

Placed the MYSQl driver under <Install_Cognos>\v5dataserver\lib
and <Install_Cognos>\webapps\p2pd\WEB-INF\lib
and restarted the cognos service.

We are suppose to use only Dynamic query. we should not use Virtual View Manager.

Kindly give your inputs to resolve the above error.

Thanks in advance

 

  • MDS4_Nigel_Jordan
    MDS4_Nigel_Jordan
    1 Post

    Re: Issues to connect with MY SQL 5.0.77 using JDBC with Cognos 10.2.1

    ‏2013-10-28T16:16:40Z  

    Hi, we are getting the same error with db2 jdbc connections in 10.2.1 . They work fine in 10.2. checking if you found a solution. Thanks

  • AGBird
    AGBird
    6 Posts

    Re: Issues to connect with MY SQL 5.0.77 using JDBC with Cognos 10.2.1

    ‏2013-10-29T05:24:50Z  

    Hi, we are getting the same error with db2 jdbc connections in 10.2.1 . They work fine in 10.2. checking if you found a solution. Thanks

    Hi

    We tried later with ODBC connectivity.

    • installed unixODBC and mysql-connector-odbc
    • Configure the /etc/odbc.ini file to add the following entries

    [MySQL]

    Description = ODBC for MySQL

    Driver = /usr/lib64/libmyodbc5.so

    SERVER = xxxxxx.enterprisenet.org

    PORT = 3306

    USER = xxxxxxx

    Password = xxxxxx

    Database = xxxx

    • Used isql utility to test the DSN connection. The test connection was successful.

    bash-4.1$  isql  MySQL  <<user name>> <<password>>.
    +---------------------------------------+
    | Connected!                                                                
    | sql-statement                        
    | help [tablename]                     
    | quit                                 
    +---------------------------------------+

    Then used the DSN in cognos to test the connection.

    Installed the MySQL 32 bit connectors on the application server.

    This has solved the issue

    Thanks

     

     

  • N Campbell
    N Campbell
    21 Posts

    Re: Issues to connect with MY SQL 5.0.77 using JDBC with Cognos 10.2.1

    ‏2013-11-15T23:56:46Z  

    The error messaging is thrown because you are trying to use an older version of a 3rd party product (in this case MySQL) that is tested and supported with the Dynamic Query engine. In your case MySQL must be 5.6 or 5.5. The person who posted about DB2, same statement would apply such as DB2 Z where version 10 was the oldest version tested with 10.2 with version 11 being supported in Cognos 10.2.1 RP1 FP1 released in Sept.

    http://www-01.ibm.com/support/docview.wss?uid=swg27037784

    Persons using Cognos 8.4 thru to earlier 10.x releases with the Classic (C++) query engine would have seen older versions of various vendors product supported in those release. In the case of vendors added into Dynamic Query from Cognos 10.2, 10.2.1+ ensure to check the versions.

  • HungBUI
    HungBUI
    2 Posts

    Re: Issues to connect with MY SQL 5.0.77 using JDBC with Cognos 10.2.1

    ‏2013-11-25T16:59:23Z  

    Hi AGBird!

       I am using MySQL JDBC 5.1 and Cognos 10.2.1 to access to MySQL 5.0 server and I have the same error.

    I've migrated to MySQL 5.6 and there is no more error.

     

    Cheers!

     

    Hung BUI

     

  • N Campbell
    N Campbell
    21 Posts

    Re: Issues to connect with MY SQL 5.0.77 using JDBC with Cognos 10.2.1

    ‏2013-12-04T18:41:31Z  
    • HungBUI
    • ‏2013-11-25T16:59:23Z

    Hi AGBird!

       I am using MySQL JDBC 5.1 and Cognos 10.2.1 to access to MySQL 5.0 server and I have the same error.

    I've migrated to MySQL 5.6 and there is no more error.

     

    Cheers!

     

    Hung BUI

     

    The reason for his issue and yours is explained in my previous reply