Topic
6 replies Latest Post - ‏2013-05-21T13:46:04Z by LucaUburti
LucaUburti
LucaUburti
3 Posts
ACCEPTED ANSWER

Pinned topic Apply automatic updates fails, Unexpected HTTP response: 404 Not Found

‏2013-04-22T08:28:16Z |

Hello, we recently upgraded our TEM infrastructure, from 8.2 to 9.0.

I accepted the various license agreements and ran the CPM upgrade server compontents fixlet (ID 55).

After that, I can't seem to get the "apply automatic updates" fixlet to work. As soon as I schedule it I get a bunch of errors:

 

w_857.865
 Non riuscito
 [-]
[+] Errore download: "Unexpected HTTP response: 404 Not Found" 
 Download richiesto dal client: 
 SHA1: 021a2c994959ea9774ececb818462f25ba5dc0d6 
 Dimensione: 6.603 byte 
 Tentativo successivo: 4 minuti. Riprova ora 
 
 
sspda6_1383.1393
 Non riuscito
 [-]
[+] Errore download: "Unexpected HTTP response: 404 Not Found" 
 Download richiesto dal client: 
 SHA1: 5c0da929e567bfea8d5510442c07e3607db2452d 
 Dimensione: 215 byte 
 Tentativo successivo: 4 minuti. Riprova ora 
 
 
tsc_1268.1274
 Non riuscito
 [-]
[+] Errore download: "Unexpected HTTP response: 404 Not Found" 
 Download richiesto dal client: 
 SHA1: 67a16387418485bca2caed665f74c135c23c026a 
 Dimensione: 71.244 byte 
 Tentativo successivo: 4 minuti. Riprova ora 
 
 
ssa_383.393
 Non riuscito
 [-]
[+] Errore download: "Unexpected HTTP response: 404 Not Found" 
 Download richiesto dal client: 
 SHA1: 7003699a6bc5a03e8cd1e82e0f082946721d2cd3 
 Dimensione: 56.942 byte 
 Tentativo successivo: 4 minuti. Riprova ora 
 
 
cvsapi871.zip
 Non riuscito
 [-]
[+] Errore download: "Unexpected HTTP response: 404 Not Found" 
 Download richiesto dal client: 
 SHA1: d8b666cc8c89ef8234ca566955777b1db0e44704 
 Dimensione: 80.200.862 byte 
 Tentativo successivo: 4 minuti. Riprova ora 
 

Sorry for the italian error messages, I hope you get the point though.

I already tried removing both the server components and the CPM endpoint clients from all the infrastructure and reinstall everything but I get the same errors.

Thanks in advance

Luca Uburti

 

 

  • JanStraarup
    JanStraarup
    2 Posts
    ACCEPTED ANSWER

    Re: Apply automatic updates fails, Unexpected HTTP response: 404 Not Found

    ‏2013-04-22T13:20:38Z  in response to LucaUburti

    I have the same problem so i will just follow this thread.

     

    Regards Jan

  • LucaUburti
    LucaUburti
    3 Posts
    ACCEPTED ANSWER

    Re: Apply automatic updates fails, Unexpected HTTP response: 404 Not Found

    ‏2013-04-29T07:20:39Z  in response to LucaUburti

     

    Just an update.

    I completely uninstalled and reinstalled TEM 9.0 last friday, using the TEM remove utility. After a fresh reinstall everything seemed to be working... just for one day. Today I checked and I still get the same kind of errors

     

    c_879.881

    Failed

    [-]
    Download error: "Unexpected HTTP response: 404 Not Found"
      Download requested by client:
      URL: http://127.0.0.1:52311/cpm/patterns/20130426_181830/pattern/c_879.881
      SHA1: 608a02c4c05c8f395b917c20b28d4e85cc8b0f84
      Size: 62.602 bytes
      Next retry: The download will be retried the next time it is requested. Retry now

     

     

    It looks like it needs to find some pattern from last friday, but after a few days it's not there anymore, I don't know why. I checked the cache settings and I increased from 1GB to 2GB, but I don't think this is the problem.

    A workaround I found is to have the clients updating from the Cloud, but I can't have all company computers updating directory from the Internet!

    Any help is greatly appreciated

    • vpetrell
      vpetrell
      2 Posts
      ACCEPTED ANSWER

      Re: Apply automatic updates fails, Unexpected HTTP response: 404 Not Found

      ‏2013-04-29T20:44:57Z  in response to LucaUburti

      I don't know if this has anything to do with it, but based on the April 10th announcement of version 9.0.586.0 it had the following notes.

      "Reasons for Update:

      * Fix for License Expiration.
      * Disallow upgrades to 9.0 if subscribed to Trend CPM."

      Not sure it's that's suppose to mean that CPM doesn't work properly with version 9?

       

      Based on the steps you have already taken, I think you covered what was in this technote:

      http://www-01.ibm.com/support/docview.wss?uid=swg21633690

       

       

       

       

      Updated on 2013-04-29T20:46:44Z at 2013-04-29T20:46:44Z by vpetrell
  • FlorianGroessl
    FlorianGroessl
    1 Post
    ACCEPTED ANSWER

    Re: Apply automatic updates fails, Unexpected HTTP response: 404 Not Found

    ‏2013-04-30T17:09:25Z  in response to LucaUburti

    I have the same problem.

    • JanStraarup
      JanStraarup
      2 Posts
      ACCEPTED ANSWER

      Re: Apply automatic updates fails, Unexpected HTTP response: 404 Not Found

      ‏2013-05-14T21:17:29Z  in response to FlorianGroessl

      hey all

       

      We fixed this problem with the help of support, af fix has been made and you can get it from support in case it is not included in 649.

       

      ---------------------------------------------------------------------------

       

       

      There are two known issues right now with IEM and Trend CPM.


      First Problem: the TrendMirroScript process breaks the Trend CPM process during upgrade.

      To solve this problem you need to take the following actions on the main CPM server:

      For an old/existing deployment:

      First Run:  Core Protection Module - Upgrade Server Components  ID: 55                                                     
      Then Run:  Core Protection Module - Download CPMAutoUpdateSetup Script  ID: 140

      Then execute the setup script as per the instructions in Task ID 140


      For a new deployment:

      First Run: Core Protection Module - Install Server Components   ID: 15                                                     
      Then Run:  Core Protection Module - Download CPMAutoUpdateSetup Script  ID: 140  
      Then execute the setup script as per the instructions in Task ID 140 



      Second Problem:  Once you fix the issue with the server; if you have 8.2 clients, Trend CPM should work.  If you have deployed 9.0 clients already, there is a problem with these 9.0 clients and Trend CPM which will require a special build from development.

      If you are in the 9.0 clients case please unzip the attached zip archive into a temp directory on your IEM 9.0 Server and :

      - import the "Updated Windows Client - IBM Endpoint Manager version 9.0.630.0 Now Available!.bes" in your IEM Console.
      - move the sha1 "9420ee0e3594a3c0db6050e13a3ddf725222f920" to wwwrootbes\bfmirror\downloads\sha1
      - waiting for task becomes relevant for your computers and deploy it on your IEM 9.0 clients
      - check if the problem with clients 9.0 get solved.

      • LucaUburti
        LucaUburti
        3 Posts
        ACCEPTED ANSWER

        Re: Apply automatic updates fails, Unexpected HTTP response: 404 Not Found

        ‏2013-05-21T13:46:04Z  in response to JanStraarup

        Hi,

        version 649 seems to solve this issue for us. No problems so far on the endpoints with ver.649