Topic
1 reply Latest Post - ‏2014-07-28T06:45:49Z by Maxy_f
QTW1_sherif_hosney
QTW1_sherif_hosney
1 Post
ACCEPTED ANSWER

Pinned topic SCO 2.3.0 Installation failure

‏2014-06-21T20:50:47Z |

Dear Experts,

Good Day

kindly I tried to install SCO 2.3 but the installation has been Failed due to the below error:

 

/install_images/installer/commands/../lib/deploy/task_runner.rb:103:in `run'
/install_images/installer/commands/../lib/deploy/task_runner.rb:92:in `each'
/install_images/installer/commands/../lib/deploy/task_runner.rb:92:in `run'
/install_images/installer/commands/central_server.rb:127:in `do_deploy'
/install_images/installer/deploy:175:in `do_deploy'
/install_images/installer/deploy:196
E, [2014-06-18T11:18:33.860192 #4358] ERROR -- sc-deploy: task_runner.rb::`run'::#<Thread:0x7f468952e370>
 RuntimeError: Failed to run command knife bootstrap 10.252.0.103 -c /tmp/knife.rb -N central-srv3 --template-file /install_images/installer/bootstrap/kernel-server.erb -x root -P xxx -r role[central-srv3] -E production -V
/install_images/installer/commands/../lib/deploy/central-server/../common/run_knife.rb:85:in `execute_knife'
/install_images/installer/commands/../lib/deploy/../utils/progressrunner.rb:63:in `join'
/install_images/installer/commands/../lib/deploy/../utils/progressrunner.rb:63:in `print_with_spinner'
/install_images/installer/commands/../lib/deploy/../utils/progressrunner.rb:25:in `block_wrapper'
/install_images/installer/commands/../lib/deploy/../utils/progressrunner.rb:39:in `print_with_msg'
/install_images/installer/commands/../lib/deploy/../utils/progressrunner.rb:31:in `catch_stdout'
/install_images/installer/commands/../lib/deploy/../utils/progressrunner.rb:39:in `print_with_msg'
/install_images/installer/commands/../lib/deploy/../utils/progressrunner.rb:24:in `block_wrapper'
/install_images/installer/commands/../lib/deploy/../utils/progressrunner.rb:85:in `ProgressRunner'
/install_images/installer/commands/../lib/deploy/task_runner.rb:103:in `run'
/install_images/installer/commands/../lib/deploy/task_runner.rb:92:in `each'
/install_images/installer/commands/../lib/deploy/task_runner.rb:92:in `run'
/install_images/installer/commands/central_server.rb:127:in `do_deploy'
/install_images/installer/deploy:175:in `do_deploy'
/install_images/installer/deploy:196
E, [2014-06-18T11:18:33.860461 #4358] ERROR -- sc-deploy: deploy::`do_deploy'::#<Thread:0x7f468952e370>
 RuntimeError: Failed to run command knife bootstrap 10.252.0.103 -c /tmp/knife.rb -N central-srv3 --template-file /install_images/installer/bootstrap/kernel-server.erb -x root -P xxx -r role[central-srv3] -E production -V
/install_images/installer/commands/../lib/deploy/central-server/../common/run_knife.rb:85:in `execute_knife'
/install_images/installer/commands/../lib/deploy/../utils/progressrunner.rb:63:in `join'
/install_images/installer/commands/../lib/deploy/../utils/progressrunner.rb:63:in `print_with_spinner'
/install_images/installer/commands/../lib/deploy/../utils/progressrunner.rb:25:in `block_wrapper'
/install_images/installer/commands/../lib/deploy/../utils/progressrunner.rb:39:in `print_with_msg'
/install_images/installer/commands/../lib/deploy/../utils/progressrunner.rb:31:in `catch_stdout'
/install_images/installer/commands/../lib/deploy/../utils/progressrunner.rb:39:in `print_with_msg'
/install_images/installer/commands/../lib/deploy/../utils/progressrunner.rb:24:in `block_wrapper'
/install_images/installer/commands/../lib/deploy/../utils/progressrunner.rb:85:in `ProgressRunner'
/install_images/installer/commands/../lib/deploy/task_runner.rb:103:in `run'
/install_images/installer/commands/../lib/deploy/task_runner.rb:92:in `each'
/install_images/installer/commands/../lib/deploy/task_runner.rb:92:in `run'
/install_images/installer/commands/central_server.rb:127:in `do_deploy'
/install_images/installer/deploy:175:in `do_deploy'
/install_images/installer/deploy:196
 

Please help me to find out what is the issue

this is my first installation of the application and i can't find any documents that help me in the installation

Thanks in advance

 

Sherif Hosney

 

Attachments

  • Maxy_f
    Maxy_f
    1 Post
    ACCEPTED ANSWER

    Re: SCO 2.3.0 Installation failure

    ‏2014-07-28T06:45:49Z  in response to QTW1_sherif_hosney

    Hello!

     

    I'm not a great s[ecialist in SCO. But I may try to tell what to check. The part that of the log file that you posted above says nothing but deployment fails. If it fails - look thru the whole log file and try to find out whta happened and where. Also try to check logs at your central-server3.

    What I've got from your log file is 2 moments:

    1. #4358]  WARN -- sc-deploy: install_task.rb::`log_warn'::#<Thread:0x7f4686ab01e8> Failed to resolve domain name of central-server-0 IP address '10.252.0.101'

    W, [2014-06-18T09:52:30.152079 #4358]  WARN -- sc-deploy: install_task.rb::`log_warn'::#<Thread:0x7f4686ab01e8> Failed to resolve domain name of central-server-1 IP address '10.252.0.102'
    W, [2014-06-18T09:53:45.157610 #4358]  WARN -- sc-deploy: install_task.rb::`log_warn'::#<Thread:0x7f4686ab01e8> Failed to resolve domain name of central-server-2 IP address '10.252.0.103'
    W, [2014-06-18T09:55:00.163771 #4358]  WARN -- sc-deploy: install_task.rb::`log_warn'::#<Thread:0x7f4686ab01e8> Failed to resolve domain name of central-server-3 IP address '10.252.0.104'
    I, [2014-06-18T09:55:00.164281 #4358]  INFO -- sc-deploy: 

    Something wrong with your DNS. Solve it before installation.

    2.  ERROR: remote_file[/opt/ibm/SmartCloud_Orchestrator/properties/version/SmartCloud_Orchestrator-2.3.0.swtag] (/var/chef/cache/cookbooks/sco/recipes/sco.rb:136:in `from_file') had an error:

    I, [2014-06-18T11:18:33.222632 #4358]  INFO -- sc-deploy: exec_cmd.rb::`run_cmd_log'::#<Thread:0x7f4687b6e9a8> 10.252.0.103 remote_file[/opt/ibm/SmartCloud_Orchestrator/properties/version/SmartCloud_Orchestrator-2.3.0.swtag] (sco::sco line 136) had an error: Net::HTTPServerException: 404 "Not Found"
    I, 
    I, [2014-06-18T11:18:33.222348 #4358]

    Look what's wrong with that file. 

    And, as I said, check the logs at your CS3. It could be useful.