Topic
2 replies Latest Post - ‏2013-05-07T09:32:53Z by MichaelReis
MichaelReis
MichaelReis
2 Posts
ACCEPTED ANSWER

Pinned topic Adding a remote MySQL connection to the Administration Console

‏2013-04-30T13:53:43Z |

Hello, I am currently working on an academic warehouse project using Infoshpere Warehouse. The data source is a remote MySQL database. All went well while within the Design Studio.

I am now trying to deploy the application, but in the Administration Console there is no option to add an external database.

From what I could tell, it seems I need to create a Catalog entry for the remote database. I have tried this approach, but am unable to connect to the database.

Further investigation indicates that I should create a Federated Database to connect to the remote MySQL database. I have done so, and the federated server appears in the Design Studio, but it has no attributes. When trying to create Nicknames for the source tables I get an error: The SQL statement or command failed because of a database system error. (Reason "Can not get server attribute".) SQLSTATE=58004

 

Am I pursuing the correct approach? What am I doing wrong? What do I need to do?

  • zxning
    zxning
    20 Posts
    ACCEPTED ANSWER

    回复:Adding a remote MySQL connection to the Administration Console

    ‏2013-05-07T03:34:26Z  in response to MichaelReis

    Hi MichaelReis:

    Which warehouse version are you using? Suppose you are using a version later than 9.7.x.

    You need to add the JDBC database driver in the "Manage Data Server Drivers", and then create a connection in the "Manage Connections" tab. Then you can test and use it in your flows.

  • MichaelReis
    MichaelReis
    2 Posts
    ACCEPTED ANSWER

    Re: Adding a remote MySQL connection to the Administration Console

    ‏2013-05-07T09:32:53Z  in response to MichaelReis

    I am using Infosphere Warehouse v10.1

    When I open the "Manage Data Server Drivers" tab in the Administration Console the page is empty and there are no buttons to add a driver. In the "Manage Connections" tab the button to add a new connection is there as expected.

    Please advise

     

    EDIT: I opened the admin console with Internet Explorer instead of Chrome and the options now appear. It must be a problem with chrome's flash player.

     

    EDIT2: It worked, I connected without any problems. Thanks! 

    Updated on 2013-05-07T09:58:20Z at 2013-05-07T09:58:20Z by MichaelReis