Topic
  • 3 replies
  • Latest Post - ‏2013-07-09T13:56:11Z by Rshya
Rshya
Rshya
24 Posts

Pinned topic WTX is considering comma as delimiter

‏2013-07-08T20:11:27Z |

Hi,

 

Can anyone help me fixing the below issue?

The input file is a CSV format, and the first Field has a comma within it, something like this "Abraham Consulting, Inc.". and most of the other fields are in double quotes.WTX is considering the comma within the field as a delimiter, so  When i use release character I get the correct output file, but is there a way to work without using Release character.

I want to use the input file as it is, without any changes to it.

Can anyone help please!!

 

Thanks,

Rshya

 

 

Updated on 2013-07-08T20:12:11Z at 2013-07-08T20:12:11Z by Rshya
  • jvanboga
    jvanboga
    419 Posts

    Re: WTX is considering comma as delimiter

    ‏2013-07-09T12:04:43Z  

    The quotes define the alphanumeric fields.  How complicated do you want it?  Two options might be...

    ...alter the type tree to use initiators and terminators for the related fields

    ...edit the file before mapping it.  substitute "," with | (or any other character unlikely to be in the data).  You might had to perform an additional substitute to remove other occurances like ," or ", or standalone "

  • Rshya
    Rshya
    24 Posts

    Re: WTX is considering comma as delimiter

    ‏2013-07-09T13:27:14Z  
    • jvanboga
    • ‏2013-07-09T12:04:43Z

    The quotes define the alphanumeric fields.  How complicated do you want it?  Two options might be...

    ...alter the type tree to use initiators and terminators for the related fields

    ...edit the file before mapping it.  substitute "," with | (or any other character unlikely to be in the data).  You might had to perform an additional substitute to remove other occurances like ," or ", or standalone "

    I tried the first option for the related fields but map failed saying initiator and terminators donot match, also almost al the fields have double quotes, but its just this one field that had comma within it.

    I havent tried substitute, but I have another question here. My type tree doesnot validate with the file which has commas within the field, is there anything I can do with the input type tree, to accept the comma within the field.

     

    Sorry for asking you mnay questions, I am newbie to WTX.

     

    Thanks Again!!

     

    Rshya.

  • Rshya
    Rshya
    24 Posts

    Re: WTX is considering comma as delimiter

    ‏2013-07-09T13:56:11Z  
    • Rshya
    • ‏2013-07-09T13:27:14Z

    I tried the first option for the related fields but map failed saying initiator and terminators donot match, also almost al the fields have double quotes, but its just this one field that had comma within it.

    I havent tried substitute, but I have another question here. My type tree doesnot validate with the file which has commas within the field, is there anything I can do with the input type tree, to accept the comma within the field.

     

    Sorry for asking you mnay questions, I am newbie to WTX.

     

    Thanks Again!!

     

    Rshya.

    Well thanks so much for the help, I fixed it, I tried to partition the field to 2 and then map , it worked, it really worked. :)