Topic
  • No replies
kadler
kadler
13 Posts

Pinned topic FYI: pdo_odbc prior to PHP 5.6 incompatible with 64-bit ACS ODBC driver

‏2014-01-16T19:56:29Z |

Update: This is fixed in PHP 5.6.

If you are using the new 64-bit ACS ODBC driver with php_odbc you may receive a segmentation fault executing a statement with bound parameters. This is because pdo_odbc is not fully 64-bit compatible (using SQLINTEGER instead of SQLLEN for certain parameters).

See https://bugs.php.net/bug.php?id=50444 for more details

Updated on 2014-08-29T18:06:01Z at 2014-08-29T18:06:01Z by kadler