Topic
2 replies Latest Post - ‏2013-10-21T14:24:47Z by barneda
barneda
barneda
3 Posts
ACCEPTED ANSWER

Pinned topic SCO 2.3 (Drop #K) - fails at IWD Cli install

‏2013-10-14T14:47:07Z |

I'm performing a multi server install ( onto VMware servers, running RHEL6.4 ), the install gets to the IWD Cli phase on central-srv3 and bombs out with:

9.71.38.154 [Sat, 12 Oct 2013 17:25:24 +0100] ERROR: Running exception handlers
9.71.38.154 [Sat, 12 Oct 2013 17:25:24 +0100] FATAL: Saving node information to /var/chef/cache/failed-run-data.json
9.71.38.154 [Sat, 12 Oct 2013 17:25:24 +0100] ERROR: Exception handlers complete
9.71.38.154 [Sat, 12 Oct 2013 17:25:24 +0100] FATAL: Stacktrace dumped to /var/chef/cache/chef-stacktrace.out
9.71.38.154 [Sat, 12 Oct 2013 17:25:24 +0100] FATAL: Chef::Exceptions::ShellCommandFailed: execute[Download IWD CLI via wget] (workload_deployer::install_cli line 31) had an error: Chef::Exceptions::ShellCommandFailed: Expected process to exit with [0], but received '4'
9.71.38.154 ---- Begin output of wget --no-check-certificate -O /tmp/iwd/deployer.cli.zip https://localhost/downloads/cli/ ----
9.71.38.154 STDOUT:
9.71.38.154 STDERR: --2013-10-12 17:25:20--  https://localhost/downloads/cli/
9.71.38.154 Resolving localhost... ::1, 127.0.0.1
9.71.38.154 Connecting to localhost|::1|:443... connected.
9.71.38.154 Unable to establish SSL connection.
9.71.38.154 ---- End output of wget --no-check-certificate -O /tmp/iwd/deployer.cli.zip https://localhost/downloads/cli/ ----
9.71.38.154 Ran wget --no-check-certificate -O /tmp/iwd/deployer.cli.zip https://localhost/downloads/cli/ returned 4)
E, [2013-10-12T17:25:25.056239 #4720] ERROR -- sc-deploy: task_runner.rb::`run'::#<Thread:0x7f2f5435e370>
 RuntimeError: Failed to run command knife bootstrap 9.71.38.154 -c /tmp/knife.rb -N central-srv3 --template-file /install_images/installer/bootstrap/kernel-server.erb -x root -P xxx -r role[central-srv3] -E production -V

There doesn't seem to be anything further back in the log file that overtly suggests an issue ( no prior errors! )

Any thoughts would be appreciated!

 

  • barneda
    barneda
    3 Posts
    ACCEPTED ANSWER

    Re: SCO 2.3 (Drop #K) - fails at IWD Cli install

    ‏2013-10-15T08:18:53Z  in response to barneda

    I'm able to get around the issue to continue the install by altering the 'workload_deployer/recipes/install_cli.rb' file to perform a copy of the file instead of using wget....I'm not sure as yet if the initial problem is indicative of an underlying problem that will cause further problem when trying to run SCO ( once the install completes )

  • barneda
    barneda
    3 Posts
    ACCEPTED ANSWER

    Re: SCO 2.3 (Drop #K) - fails at IWD Cli install

    ‏2013-10-21T14:24:47Z  in response to barneda

    Issue found!

    Don't use an exclamation mark in your admin password!! I chose a different admin password ( without any dodgy chars ) and the install went through!