Topic
3 replies Latest Post - ‏2014-04-10T17:39:49Z by mazogi
vica
vica
2 Posts
ACCEPTED ANSWER

Pinned topic Corrupted EST CICS project wsdl file

‏2014-03-26T12:56:04Z |

I create this wsdl using the CICS web service assistance procedure.  I then import with the Remote the wsdl to a EST web service for cics project top down approach. I use the wsdl and all if fine. I try to open the wsdl in the local EST project with the wsdl editor and it is no longer readable, it appears to be in binary or the wrong code page. I need to determine the root cause and what the z/OS code page and the local code page in the EST project should be set to?  At times I have seen the host z/OS connection code page set to IBM-1140 and IBM-1047.  I also have seen it set to cp1252 the windows code page?   I see the local page set to 1252 and also UTF-8 inherited.

Updated on 2014-03-26T13:03:21Z at 2014-03-26T13:03:21Z by vica
  • mazogi
    mazogi
    109 Posts
    ACCEPTED ANSWER

    Re: Corrupted EST CICS project wsdl file

    ‏2014-03-27T15:21:04Z  in response to vica

    Hi,

    If you generate WSDL on z using CICS Web services assistant, the default code page the WSDL is generated in is 037.  This is configurable through the WSDLCP parameter.

    In RDz, the default transfer mode for WSDL files is Binary because it is assumed to be in one of the "web" encodings (usually UTF-8).  So the solution is either to generate WSDL on z using UTF-8 for WSDLCP or transfer it from z as text.

    • vica
      vica
      2 Posts
      ACCEPTED ANSWER

      Re: Corrupted EST CICS project wsdl file

      ‏2014-04-02T19:56:32Z  in response to mazogi

      Thank you for your reply, I have tried both of the choices you presented but neither of them worked. 

      The first one I changed the transfer type for .wsdl to Text from XML (which is the default value I have in RDz V9) and then I did a remote import of the wsdl into the web service for cics project, it is now readable in the EST project, but then the opposite happens, the wsdl is no longer readable in USS.  Prior to trying that change I had the opposite result the wsdl is readable in USS but not in the EST project.   Also once one project with a wsdl is opened and it is in binary or corrupted it also corrupts all the other wsdl in any of the other projects.  So once one is not readable others that were ok are also now not readable.  So any changes I make to one affects all the others.  For example when I changed the transfer mode to binary all the other wsdls in projects that were readable are now not.  The wsdl is linked to the USS, so when I change a setting in RDz EST then that changes how the file looks in USS since they are linked thru a temporary file.

      Then I tried the second choice. I generated with WSDLCP=UTF-8 and changed the transfer mode to binary in RDz file preferences. I then did a remote import from USS and the file is readable in the EST project, but it is not readable now in USS.  When I regenerate the wsdl and I do not specify the WSDLCP then I can look at the wsdl in USS or the remote system view. 

      I can continue to try different combinations of these settings but each time I am afraid I am corrupting other wsdls as well.

      When I look at the properties of the wsdl file the code page is set to UTF-8 in the EST project.  When I look at the properties of the wsdl file in USS the code page is set to IBM-1047.  These properties did not change with either of the two tests.

       

      • mazogi
        mazogi
        109 Posts
        ACCEPTED ANSWER

        Re: Corrupted EST CICS project wsdl file

        ‏2014-04-10T17:39:49Z  in response to vica

        Hi Victoria,

        I just wanted to close the loop on this question: The recommended way in your case is to manually set the encoding on the WSDL symbolic link in the EST project to match the encoding of the linked WSDL generated by CICS on the zOS side.  In your case, the encoding would be IBM-1047.

        To set the encoding, click on the right mouse button on the WSDL file link in the EST project, go to Properties action, and in the Properties Wizard go to Attributes->Text file encoding, and type "IBM-1047" (without the qoutes) into the Other text field



        hope this helps.

        Attachments

        Updated on 2014-04-10T17:40:19Z at 2014-04-10T17:40:19Z by mazogi