Topic
2 replies Latest Post - ‏2012-08-03T15:05:07Z by jerberstark
ThinkOpenly
ThinkOpenly
27 Posts
ACCEPTED ANSWER

Pinned topic IBM SDK and Advance Toolchain interdependence

‏2012-08-02T12:10:12Z |
I downloaded the latest Advance Toolchain (5.0.6) and the latest PowerLinux SDK (1.0.0).  The Advance Toolchain installed fine, but the SDK appears to depend on having version 4 of the Advance Toolchain installed:
 
 # rpm -Uvh /media/cdrom/ibm-sdk-lop-1.0.0-1.ppc64.rpm /media/cdrom/ibm-sdk-lop-stp-rhel-1.0.0-1.ppc64.rpm
error: Failed dependencies:
    advance-toolchain-at4.0-runtime >= 4.0-1 is needed by ibm-sdk-lop-1.0.0-1.ppc64
    advance-toolchain-at4.0-perf >= 4.0-1 is needed by ibm-sdk-lop-1.0.0-1.ppc64
    advance-toolchain-at4.0-devel >= 4.0-1 is needed by ibm-sdk-lop-1.0.0-1.ppc64
 
Is this expected?
Updated on 2012-08-03T15:05:07Z at 2012-08-03T15:05:07Z by jerberstark
  • wainersm
    wainersm
    8 Posts
    ACCEPTED ANSWER

    Re: IBM SDK and Advance Toolchain interdependence

    ‏2012-08-02T13:08:33Z  in response to ThinkOpenly
     Hi Paul,
     
    You are required to install Advance Toolchain (AT) v4 in order to install the SDK although you've already installed 5.0.6.
     
    However, upcoming SDK 1.1 (scheduled to Aug 7h)  will change that annoying behaviour in such a way any installed AT of series v5 or v6 will match the dependency criteria of the SDK package.
    • jerberstark
      jerberstark
      30 Posts
      ACCEPTED ANSWER

      Re: IBM SDK and Advance Toolchain interdependence

      ‏2012-08-03T15:05:07Z  in response to wainersm
       Hi Paul,
       
      You can find the documentation for the PowerLinux SDK and its requirements here: http://publib.boulder.ibm.com/infocenter/lnxinfo/v3r0m0/index.jsp?topic=%2Fliaal%2Fiplsdkreq.htm
       
      As Wainer pointed out, things change on August 7. The docs will be updated with the new info on 8/7 as well. 
       
      If there is anything else that we can clarify in the documentation, please let me know.