Topic
  • 1 reply
  • Latest Post - ‏2013-08-09T18:53:48Z by OpherB
BhagatS
BhagatS
150 Posts

Pinned topic Multifile Cube help

‏2013-08-09T09:00:06Z |

I have created a Multifile cube by setting the multifilethreshold value at 500,000. but the cube build failed with the this error message in the logfile.

(TR1901) PDS-PPE-0197 The local data cache size exceeded the allowed maximum of 2147418112 bytes.

I have changed the multifilethreshold value to 10,000,000 and still fails. I have noticed that mdp file it creates is 1.99GB, so I think it has reached the limit.

The Maximum number of transactions per commit  is set to 500,000 and the last Performing Database Commit at record number is 66,000,000

Any suggestions please?

Thanks in advance.

  • OpherB
    OpherB
    664 Posts
    ACCEPTED ANSWER

    Re: Multifile Cube help

    ‏2013-08-09T18:53:48Z  

    The 2GB limit to file size is a pretty hard limit, and getting beyond it requires some delicate work.

    First, is there anything you can eliminate from the cube or cube build process? Any levels that aren't used? Any  Dimensions that are out of scope, or measures that no one analyzes? Are there data elements in the source queries which are not needed? Whatever you can remove should be removed.

    If that doesn't solve the problem, you'll need to build a virtual cube set. The Transformer User Guide has information about this.

    The next option is to upgrade to 10.2 and use Dynamic Cubes which do not have similar limits.

    Good luck,
    Opher

     

  • OpherB
    OpherB
    664 Posts

    Re: Multifile Cube help

    ‏2013-08-09T18:53:48Z  

    The 2GB limit to file size is a pretty hard limit, and getting beyond it requires some delicate work.

    First, is there anything you can eliminate from the cube or cube build process? Any levels that aren't used? Any  Dimensions that are out of scope, or measures that no one analyzes? Are there data elements in the source queries which are not needed? Whatever you can remove should be removed.

    If that doesn't solve the problem, you'll need to build a virtual cube set. The Transformer User Guide has information about this.

    The next option is to upgrade to 10.2 and use Dynamic Cubes which do not have similar limits.

    Good luck,
    Opher