Topic
2 replies Latest Post - ‏2013-09-11T15:56:05Z by AlixLourme
AlixLourme
AlixLourme
2 Posts
ACCEPTED ANSWER

Pinned topic Plugin WDT v8.5.1 not compatible with m2e-wtp v1.0.0

‏2013-08-21T11:04:11Z |

Developing with Eclipse Indigo (v3.7.2) requires Web Development Tools plugin v8.5.1(documentation).

For better integration you can use m2e-wtp plugin (documentation).

 

But WDT v8.5.1002.v20130402_2058 is not compatible with m2e-wtp v1.0.0.20130613-0136 (WDT dependencies rules exclude v1.0.0).

A workaround / hack exists (Stackoverflow thread), but it could be annoying later if you want update the plugin (the plugin signing change).

 

=> The best solution should be a WDT version v8.5.1003, with an update about m2e-wtp (as WDT v8.5.5). Could IBM team deploye this new artifact ? Thanks in advance.

  • rsanchezh
    rsanchezh
    26 Posts
    ACCEPTED ANSWER

    Re: Plugin WDT v8.5.1 not compatible with m2e-wtp v1.0.0

    ‏2013-08-27T19:05:04Z  in response to AlixLourme

    Hello,
     
    Unfortunately we cannot discuss details about future releases of WDT. But as you mention, this problem does not occur in WDT 855. Is it possible for you to move to WDT 855 and Eclipse Juno?
    If that is not possible, then the work around you mention can be used. Another option is to use the steps described here http://pic.dhe.ibm.com/infocenter/radhelp/v8r5/index.jsp?topic=%2Fcom.ibm.rad.install.doc%2Ftopics%2Ft_intsall_wdt_m2e.html, which will install m2e-wtp version 0.16.0, which is the version originally tested in WDT 8.5.1. And another work around is to use, in step 10 of the previous link, the update site  http://download.eclipse.org/m2e-wtp/snapshots/juno, and install the version 0.18.0.

    • AlixLourme
      AlixLourme
      2 Posts
      ACCEPTED ANSWER

      Re: Plugin WDT v8.5.1 not compatible with m2e-wtp v1.0.0

      ‏2013-09-11T15:56:05Z  in response to rsanchezh

      Hello,

      > Is it possible for you to move to WDT 855 and Eclipse Juno?

      No. The context is an Eclipse bundle provisioning for all developpers in company, so this changes and Websphere Liberty Profile v8.5.5 with Base / extension (REST, WS) / EJB Lite introduce too many impacts to do quickly.

      Currently, our standard is still Eclipse Indigo. Major change is planned next year with Eclipse Kepler SR3.

       

      > Solutions

      1) Patch WDT (workaround / hack describe on Stackoverflow thread).

      But with this solution, the developper can't remove/updat WDT plugin (Eclipse doesn't like the change of plugin signing).

       

      2) Using previous version of m2e

      About m2e-wtp : "0.18.0 was the development version that was eventually promoted to 1.0.0" (cf. m2e-wtp-dev mailing list) ... so no majors differences between 018.0 and 1.0.0.

      So this combinaison :

      works but :

      • m2e-wtp is a snapshot version
      • if developpers upgrade m2e-wtp plugin with stable version (m2e and derived are considered as a nice Eclipse feature, therefore some people could want do the last update for these plugins) ... the problem occurs again.

      I'll probably use the solution 2 (then 1 for people concerned by problem explained above), but I still think that the best solution is an little updgrade of range dependency in a WDT v8.5.1003 version.

      I want promote the WLP usage as development server in my company, but with the initial performance problems of WLP v8.5.0.0 (resolved in 8.5.0.2) and this incompatibility (Eclipse Indigo + m2e and derived in "stable" version + WDT) ... it's a little bit complicated.

      Best regards.