Topic
  • 2 replies
  • Latest Post - ‏2014-05-19T15:09:55Z by viva0521
viva0521
viva0521
32 Posts

Pinned topic Run OPL example on Linux

‏2014-05-16T20:17:23Z |

Hi, there,

I am pretty new to OPL and I just started to learn how to use it. I am wondering how can I run examples, tried " oplrun blending.mod blending.dat" , didn't work. Thanks in advance for any comment.

 

P.L

Updated on 2014-05-16T20:49:13Z at 2014-05-16T20:49:13Z by viva0521
  • AlexFleischer
    AlexFleischer
    1855 Posts
    ACCEPTED ANSWER

    Re: Run OPL example on Linux

    ‏2014-05-19T08:11:29Z  

    Hi

    in doc IDE and OPL > Starting Kit > Working Environment > Supported platforms
    Linux platforms

    Only the environment variable LD_LIBRARY_PATH is needed to point to the shared libraries of the CPLEX Studio distribution.

    <Install_dir>/opl/bin/x86_sles10_4.1

    or

    <Install_dir>/opl/bin/x86-64_sles10_4.1

    In doc IDE and OPL > CPLEX Studio IDE > Getting Started with the IDE > Introduction to the CPLEX Studio IDE > Launching the CPLEX Studio IDE

    Starting the IDE from Linux

    You can start the IDE from a Linux terminal.

    To launch the IDE from a Linux terminal:

        Open a terminal window.

        Change directory to <installdir>/opl/oplide

        Enter the command ./oplide

    Or, from any terminal location, type the absolute path:

    <installdir>/opl/oplide/oplide

     

    regards

  • AlexFleischer
    AlexFleischer
    1855 Posts

    Re: Run OPL example on Linux

    ‏2014-05-19T08:11:29Z  

    Hi

    in doc IDE and OPL > Starting Kit > Working Environment > Supported platforms
    Linux platforms

    Only the environment variable LD_LIBRARY_PATH is needed to point to the shared libraries of the CPLEX Studio distribution.

    <Install_dir>/opl/bin/x86_sles10_4.1

    or

    <Install_dir>/opl/bin/x86-64_sles10_4.1

    In doc IDE and OPL > CPLEX Studio IDE > Getting Started with the IDE > Introduction to the CPLEX Studio IDE > Launching the CPLEX Studio IDE

    Starting the IDE from Linux

    You can start the IDE from a Linux terminal.

    To launch the IDE from a Linux terminal:

        Open a terminal window.

        Change directory to <installdir>/opl/oplide

        Enter the command ./oplide

    Or, from any terminal location, type the absolute path:

    <installdir>/opl/oplide/oplide

     

    regards

  • viva0521
    viva0521
    32 Posts

    Re: Run OPL example on Linux

    ‏2014-05-19T15:09:55Z  

    Hi

    in doc IDE and OPL > Starting Kit > Working Environment > Supported platforms
    Linux platforms

    Only the environment variable LD_LIBRARY_PATH is needed to point to the shared libraries of the CPLEX Studio distribution.

    <Install_dir>/opl/bin/x86_sles10_4.1

    or

    <Install_dir>/opl/bin/x86-64_sles10_4.1

    In doc IDE and OPL > CPLEX Studio IDE > Getting Started with the IDE > Introduction to the CPLEX Studio IDE > Launching the CPLEX Studio IDE

    Starting the IDE from Linux

    You can start the IDE from a Linux terminal.

    To launch the IDE from a Linux terminal:

        Open a terminal window.

        Change directory to <installdir>/opl/oplide

        Enter the command ./oplide

    Or, from any terminal location, type the absolute path:

    <installdir>/opl/oplide/oplide

     

    regards

    Alex,

    Thanks for your comment.

    First, the error information for my  "oplrun didn't work" is permission denied,

    :/usr/CPLEX_Studio126/opl/bin/x86-64_linux> oplrun /usr/CPLEX_Studio126/opl/examples/opl/blending>blending.mod /usr/CPLEX_Studio126/opl/examples/opl/blending>blending.dat
    -bash: blending.mod: Permission denied

     

    so I guess my account (remote control on linux terminal) has limited authority. More, when I tried to launch IDE on linux terminal, it is another error:

    :/usr/CPLEX_Studio126/opl/oplide> ./oplide

    Oplide:
    An error has occurred. See the log file.

    Do you think this is because the authority issue of my account or the process of  installation? Thanks!

    Update: Alex, finally I fixed this problem by adding the library path into my linux environment setting. However, I still can not execute IDE on my terminal, it looks like the system missed some clips file there. Anyway, it may be helpful for other newbie like me to solve this kinda issue. Thanks again!

    Updated on 2014-05-19T19:43:59Z at 2014-05-19T19:43:59Z by viva0521