Topic
  • 6 replies
  • Latest Post - ‏2014-10-30T16:23:15Z by ArnaudGrignan
Evan Kedzierski
Evan Kedzierski
5 Posts

Pinned topic RedHat 7 VNC

‏2014-07-09T20:21:33Z |

I am having trouble in a Power8 lpar getting a VNC properly working. I have followed the steps in the System administrators guide for redhat 7

i can get the VNC service running, I can connect to the session. after connecting to the session it presents an error stating: "Oh no! Sonthing has gone wroung. A problem has occurred and the system can't recover. please log out and try again" and below is a log out button that will black out the screen (attached below is a picture)

Has anyone else ran into this and found a fix?

 

Thanks

Attachments

  • Bill_Buros
    Bill_Buros
    182 Posts

    Re: RedHat 7 VNC

    ‏2014-07-10T12:25:59Z  

    Yes, this has been seen before, and people have worked around it.      Trying to find a definitive solution since debugging assistance was offered but I never saw the final answer.

    I assume you're using the RHEL 7 GA'ed bits.

    We recommend adding xterm to the xstartup contents, commenting out the automatic gnome-session invocation.

    #!/bin/sh
    unset SESSION_MANAGER
    unset DBUS_SESSION_BUS_ADDRESS
    exec /etc/X11/xinit/xinitrc
    # exec gnome-session &
    /usr/bin/xterm &

    (this assumes you have xterm installed - and you use the right path from the xterm install to invoke...)

    Restart vnc session.     When you reconnect, you should see the xterm, and be able to start gnome-session directly, and hopefully the error should be obvious.

     

     

     

     

    Updated on 2014-07-10T12:36:46Z at 2014-07-10T12:36:46Z by Bill_Buros
  • cascardo
    cascardo
    3 Posts

    Re: RedHat 7 VNC

    ‏2014-07-10T12:34:54Z  

    One of the reasons this might happen is the system has ran out of memory, and killed a process. This may happen if you have many IO adapters on the LPAR and not enough memory for the device drivers. Can you try increasing the LPAR memory?

  • Evan Kedzierski
    Evan Kedzierski
    5 Posts

    Re: RedHat 7 VNC

    ‏2014-07-10T17:26:27Z  

    Correct it is the GA version of Redhat 7.

    I attached the xstartup file which i copied from about.

    Issue is still occuring

    Lpar has 32GB of memory and is a clean install.

    Are there any other files to look into?

     

    Thanks

     

    Attachments

  • wrt
    wrt
    8 Posts

    Re: RedHat 7 VNC

    ‏2014-07-11T07:54:08Z  

    Correct it is the GA version of Redhat 7.

    I attached the xstartup file which i copied from about.

    Issue is still occuring

    Lpar has 32GB of memory and is a clean install.

    Are there any other files to look into?

     

    Thanks

     

    I too had faced this error, later found out that relevant gnome/GUI packages are not installed... 

    Do the following and you should successfully enable vnc session..

    #yum groupinstall "Server with GUI"

    # vncserver -kill :1   ; ##### I assume your port number is 1

    # # cat ~/.vnc/xstartup 

    #!/bin/sh
     
    unset SESSION_MANAGER
    unset DBUS_SESSION_BUS_ADDRESS
    exec /etc/X11/xinit/xinitrc
    exec gnome-session &
     

    # vncserver 

     

    Thanks,

    ======================================

    PS: the work around what Bill has mentioned will also work, 

    #yum install xterm

    # # vncserver -kill :1   ; ##### I assume your port number is 1

    # # cat ~/.vnc/xstartup 

    #!/bin/sh
     
    unset SESSION_MANAGER
    unset DBUS_SESSION_BUS_ADDRESS
    exec /etc/X11/xinit/xinitrc
    /usr/bin/xterm &
     

    # vncserver 

     
  • Evan Kedzierski
    Evan Kedzierski
    5 Posts

    Re: RedHat 7 VNC

    ‏2014-09-12T13:34:37Z  

    There are a few RPM's that needed a recompile

    here is what you need to do

    Grab the a copy of the recompiled rpm to the system then,

    Rpms are

    mesa-private-llvm-3.3-0.8.20131023.el7.ppc64.rpm

    mesa-private-llvm-debuginfo-3.3-0.8.20131023.el7.ppc64.rpm

    mesa-private-llvm-devel-3.3-0.8.20131023.el7.ppc64.rpm

    # rpm -e mesa-private-llvm --nodeps
    # rpm -ihv  mesa-priva\u200bte-llvm-3.\u200b3-0.8.2013\u200b1023.el7.p\u200bpc64.rpm --nodeps

    reboot server and start VNC.
     

    Best of luck

  • ArnaudGrignan
    ArnaudGrignan
    1 Post

    Re: RedHat 7 VNC

    ‏2014-10-30T16:23:15Z  

    There are a few RPM's that needed a recompile

    here is what you need to do

    Grab the a copy of the recompiled rpm to the system then,

    Rpms are

    mesa-private-llvm-3.3-0.8.20131023.el7.ppc64.rpm

    mesa-private-llvm-debuginfo-3.3-0.8.20131023.el7.ppc64.rpm

    mesa-private-llvm-devel-3.3-0.8.20131023.el7.ppc64.rpm

    # rpm -e mesa-private-llvm --nodeps
    # rpm -ihv  mesa-priva\u200bte-llvm-3.\u200b3-0.8.2013\u200b1023.el7.p\u200bpc64.rpm --nodeps

    reboot server and start VNC.
     

    Best of luck

    Hi Evan,

    I'm sorry, but i can't find the RPMs you are writing about.

    Could you provide us a link for these files please ?

    I tried all the previous suggestions bu twith no luck. I hope your solution will work.

    Best regards