Topic
4 replies Latest Post - ‏2013-07-15T16:03:52Z by oschoett
oschoett
oschoett
3 Posts
ACCEPTED ANSWER

Pinned topic Equinox dependency error in RAD 8.0.4.2 iFix1

‏2013-07-15T13:16:43Z |

I installed RAD version 8.0.4.2 iFix1 using the Installation Manager.  Selecting update site

http://download.eclipse.org/eclipse/updates/3.4

and performing "Help > Check for Updates" shows the available updates

Equinox CORE SDK Patch (bugzillas 344855,350739), Version 1.0.1, Id org.eclipse.equinox.core.sdk.R362patch.feature.group

Equinox Server CORE SDK Patch (bugzillas 344855,350739), Version 1.0.1, Id org.eclipse.equinox.server.core.sdk.R362patch.feature.group

and the error

Cannot complete the install because one or more required items could not be found.
  Software currently installed: Shared profile 1.0.0.1373638065788 (SharedProfile_bootProfile 1.0.0.1373638065788)
  Missing requirement: Equinox Server P2 Patch (bugzillas 338600,345549) 1.0.1 (org.eclipse.equinox.server.p2.R362patch.feature.group 1.0.1) requires 'org.eclipse.equinox.server.p2.feature.group [1.0.1.R36x_v20101007-7x7IFI3FOf7yk63X6z0kz-Z2T158]' but it could not be found
  Cannot satisfy dependency:
    From: Shared profile 1.0.0.1373638065788 (SharedProfile_bootProfile 1.0.0.1373638065788)
    To: org.eclipse.equinox.server.p2.R362patch.feature.group [1.0.1]

This error is independent of which update site I select (another example is http://subclipse.tigris.org/update_1.10.x), so I suspect it is a problem of the RAD installation itself  How can I fix it?

One special property of my installation: I have Data Studio 3.1.1 installed already, and the RAD got integrated with it during installation.  For example, the RAD start icon appears in the Start Menu folder "IBM Data Studio > IBM Rational Application Developer".

Regards,

Oliver Schoett

 

Updated on 2013-07-15T13:17:03Z at 2013-07-15T13:17:03Z by oschoett
  • rsanchezh
    rsanchezh
    45 Posts
    ACCEPTED ANSWER

    Re: Equinox dependency error in RAD 8.0.4.2 iFix1

    ‏2013-07-15T14:59:47Z  in response to oschoett

    Hello,

    RAD manages its own Eclipse dependencies, therefore you cannot update Eclipse SDK related plugins (including equinox) using the Check for updates option.

    For non-Eclipse SDK plugins, you should be able to update.

    • oschoett
      oschoett
      3 Posts
      ACCEPTED ANSWER

      Re: Equinox dependency error in RAD 8.0.4.2 iFix1

      ‏2013-07-15T15:16:40Z  in response to rsanchezh

      Ok, but this error comes up when I try to install the subclipse plug-in (using the subclipse URL given in my first posting or using the zip archive of the subclipse repository), so it blocks me from installing add-ons like subclipse (which I need to work in my team).

      It seems to me that there is an inconsistency in the RAD installation that blocks any use of the update mechanism.

      Updated on 2013-07-15T15:18:07Z at 2013-07-15T15:18:07Z by oschoett
  • oschoett
    oschoett
    3 Posts
    ACCEPTED ANSWER

    Solved: Equinox dependency error in RAD 8.0.4.2 iFix1

    ‏2013-07-15T16:03:52Z  in response to oschoett

    The IRAD installation somehow got integrated with the Data Studio 3.1.1 I already had installed. Using the Installation Manager, I removed both Data Studio and RAD, and then only installed RAD again. The dependency problem is gone.