Topic
3 replies Latest Post - ‏2014-06-19T10:10:44Z by DaveN
cfdonatucci
cfdonatucci
5 Posts
ACCEPTED ANSWER

Pinned topic Stand Alone CMCI connection

‏2014-06-09T18:36:41Z |

Hi

I'm testing a CMCI stand-alone connection between CICS 42 region and Cics Explorer 5.1.

I defined all resources needed (i guess) into the region, the URI and the TCPIPService provided in group DFH$WU and DFHWU.

I TCPIPS                                                   
STATUS:  RESULTS - OVERTYPE TO MODIFY                      
 Tcpips(DFH$WUTC) Ope Por(01490) Http Nos Tra(CWXN)        
    Con(00000) Bac( 00010 ) Maxd( 000032 ) Urm( DFHWBAAX )

I URI                                                                      
STATUS:  RESULTS - OVERTYPE TO MODIFY                                      
 Uri(DFH$WUUR) Ser Ena     Http     Tcp(DFH$WUTC)                          
    Host(*                         ) Path(/CICSSystemManagement/*         )

Libs SEYUAUTH and SEYULOAD are in the proper places into the JCL.

A CMCI connection was defined into Cics explorer pointing to 1490 port.

When I connect a timeout is reached. Similar connection thru CMCI-WUI works fine.

Any suggestion?

TKS
                                                                         

  • DaveN
    DaveN
    69 Posts
    ACCEPTED ANSWER

    Re: Stand Alone CMCI connection

    ‏2014-06-19T08:15:58Z  in response to cfdonatucci

    Hi there,

    Sorry for the lack of reply! This question's more of a CPSM/CICS question than Explorer - I'll email round and see if I find someone to advise. :-)

    Dave

    • DaveN
      DaveN
      69 Posts
      ACCEPTED ANSWER

      Re: Stand Alone CMCI connection

      ‏2014-06-19T08:29:48Z  in response to DaveN

      A couple of questions/thoughts. What port is your WUI connection on? Could you grab the service data from the file menu in Explorer and email it to dave.nice@uk.ibm.com or attach it here?

      Thanks :-)

  • DaveN
    DaveN
    69 Posts
    ACCEPTED ANSWER

    Re: Stand Alone CMCI connection

    ‏2014-06-19T10:10:44Z  in response to cfdonatucci

    OK a few more ideas from the experts.

    1) In terms of the setup, the info center states "You must define the following transactions to RACF®, or an equivalent external security manager, and ensure that CMCI users are authorized to access the transactions: CODB, COD0, COD1, COD2, COIE, COSH, COLU, COND, CONL, CWWU, and CWXN." - are your RACF permissions in order?

    2) Considering the connection time-outs, to get closer towards you understanding the issue (or us being able to help!), it would be good to do a bit of further investigation...
    a) How long does it take before timing out?
    b) Looking at the CMCI request and any response in the CICS Explorer log in the CICS Explorer service data
    c) Have you got any CICS trace? Is there anything in the region's log?
    d) Have you definitely got different ports for the WUI and the CMCI? Could it be a firewall issue?

    3) We're interested to know why you're running a single-server when you've already got an established CPSM environment? We would have expected you to be isolating the region in a separate CICSplex if need be.

    Thanks in advance,

    Dave