Topic
  • 4 replies
  • Latest Post - ‏2013-12-11T18:28:17Z by giocot
giocot
giocot
164 Posts

Pinned topic Help with com.ibm.egl.rui.shopcart

‏2013-12-11T15:46:05Z |

Hi all

i have downloaded the example com.ibm.egl.rui.shopcart  (https://www.ibm.com/developerworks/community/blogs/3e2b35ae-d3b1-4008-adee-2b31d4be5c92/entry/egl_shoppingcart_from_jsf_to_rich_ui?lang=en)  but after the import i see my project in error and if i try to run the "generate" option i receive the errors in the attached image; can some one help me to understand where i'm wrong

 

Thanks in advance

 

Attachments

  • markevans
    markevans
    3032 Posts

    Re: Help with com.ibm.egl.rui.shopcart

    ‏2013-12-11T17:44:58Z  

    Hi,

    You don't say what version of RBD you are using, but I am guessing it is RBD 8.5 or 9.0.

    I am guessing you have messages in the Problems view that related to "Missing Required Projects" similar to the following:

    Description                    Resource                                     Path  
    Missing required EGL project: com.ibm.egl.rui_4.0.0.                        com.ibm.egl.rui.shopcart
    Missing required EGL project: com.ibm.egl.rui_4.0.0.                        com.ibm.egl.rui.util   
    Missing required EGL project: com.ibm.egl.rui.dojo.runtime.local_1.6.1.     com.ibm.egl.rui.shopcart

    Missing required EGL project: com.ibm.egl.rui.dojo.runtime.local_1.6.1.     com.ibm.egl.rui.util
    Missing required EGL project: com.ibm.egl.rui.dojo.widgets_2.0.0.           com.ibm.egl.rui.shopcart  

     

    A version of these are projects that are created when you create a new EGL RUI project.   The instructions for the BLOG entry say to create a new EGL RUI project so these will be added to the workspace.   I created something like zzRUI and these three projects are added.

    However, when you create a RUI project in the later levels of RBD, these versions (_4.0.0, _1.61., _2.0.0) will no longer be the current version.  So, let it create the new versions and then go in the EGL Build Path (from project properties for com.ibm.egl.rui.shopcar and  com.ibm.egl.rui.util) and change the Build Path to the version currently added to the workspace.

     

    Hope that helps.

  • giocot
    giocot
    164 Posts

    Re: Help with com.ibm.egl.rui.shopcart

    ‏2013-12-11T18:08:09Z  
    • markevans
    • ‏2013-12-11T17:44:58Z

    Hi,

    You don't say what version of RBD you are using, but I am guessing it is RBD 8.5 or 9.0.

    I am guessing you have messages in the Problems view that related to "Missing Required Projects" similar to the following:

    Description                    Resource                                     Path  
    Missing required EGL project: com.ibm.egl.rui_4.0.0.                        com.ibm.egl.rui.shopcart
    Missing required EGL project: com.ibm.egl.rui_4.0.0.                        com.ibm.egl.rui.util   
    Missing required EGL project: com.ibm.egl.rui.dojo.runtime.local_1.6.1.     com.ibm.egl.rui.shopcart

    Missing required EGL project: com.ibm.egl.rui.dojo.runtime.local_1.6.1.     com.ibm.egl.rui.util
    Missing required EGL project: com.ibm.egl.rui.dojo.widgets_2.0.0.           com.ibm.egl.rui.shopcart  

     

    A version of these are projects that are created when you create a new EGL RUI project.   The instructions for the BLOG entry say to create a new EGL RUI project so these will be added to the workspace.   I created something like zzRUI and these three projects are added.

    However, when you create a RUI project in the later levels of RBD, these versions (_4.0.0, _1.61., _2.0.0) will no longer be the current version.  So, let it create the new versions and then go in the EGL Build Path (from project properties for com.ibm.egl.rui.shopcar and  com.ibm.egl.rui.util) and change the Build Path to the version currently added to the workspace.

     

    Hope that helps.

    Hi

    my RBD version is  8.0.1.5; is too old ?

    thanks in advance

     

     

  • markevans
    markevans
    3032 Posts

    Re: Help with com.ibm.egl.rui.shopcart

    ‏2013-12-11T18:21:48Z  
    • giocot
    • ‏2013-12-11T18:08:09Z

    Hi

    my RBD version is  8.0.1.5; is too old ?

    thanks in advance

     

     

    nope...the BLOG article was written using RBD 8.0.1.2/8.0.1.3, so you are fine.

    You just need to do the same steps, but your version of the required projects just need to be used.

  • giocot
    giocot
    164 Posts

    Re: Help with com.ibm.egl.rui.shopcart

    ‏2013-12-11T18:28:17Z  
    • markevans
    • ‏2013-12-11T18:21:48Z

    nope...the BLOG article was written using RBD 8.0.1.2/8.0.1.3, so you are fine.

    You just need to do the same steps, but your version of the required projects just need to be used.

    Ok

    after you suggestion , i don't have more errors

    thanks