IC SunsetThe developerWorks Connections platform will be sunset on December 31, 2019. On January 1, 2020, this forum will no longer be available. More details available on our FAQ.
Topic
  • 2 replies
  • Latest Post - ‏2017-11-08T20:00:16Z by TRI_Harder
TRI_Harder
TRI_Harder
98 Posts

Pinned topic Data Integrator not defaulting the System Organization

‏2017-09-26T00:06:07Z | data integrator

Hi All,

I noticed that when I am using the Data Integrator to load building, floor, or space records.  The System Organization does not default based on the 'Primary Organization' of the Employee record.  Instead, it leaves the System Organization for records null.  As such, I have to go back and initiate a Workflow to populate the System Organization value.


How does the System Organization value get set when it is loaded via the Data Integrator?  And should it have used the Primary Organization from the user that is logged in and uploading the records via Data Integrator?


Thanks in advance!

  • scott_ruch_wipro
    scott_ruch_wipro
    13 Posts
    ACCEPTED ANSWER

    Re: Data Integrator not defaulting the System Organization

    ‏2017-09-27T16:33:42Z  

    When data is loaded via Data Integrator, there is really no reference to a user in that case. It may be better to use Integration Object or Data Connect in that case. Another possibility might be to create a workflow to simply add a static value when Location records are created if you are the only user adding Location data. Does that clarify things for you?

  • scott_ruch_wipro
    scott_ruch_wipro
    13 Posts

    Re: Data Integrator not defaulting the System Organization

    ‏2017-09-27T16:33:42Z  

    When data is loaded via Data Integrator, there is really no reference to a user in that case. It may be better to use Integration Object or Data Connect in that case. Another possibility might be to create a workflow to simply add a static value when Location records are created if you are the only user adding Location data. Does that clarify things for you?

  • TRI_Harder
    TRI_Harder
    98 Posts

    Re: Data Integrator not defaulting the System Organization

    ‏2017-11-08T20:00:16Z  

    When data is loaded via Data Integrator, there is really no reference to a user in that case. It may be better to use Integration Object or Data Connect in that case. Another possibility might be to create a workflow to simply add a static value when Location records are created if you are the only user adding Location data. Does that clarify things for you?

    Hi Scott,

    Thanks for the response.

    Yes, it seems that DI does not recognize the User's Primary Organization value.  As such, importing via DI requires creating a WF to query those records that were loaded via DI and using a Modify Task to update the value of the System Organization for those records.