• 2 replies
  • Latest Post - ‏2014-05-01T15:37:06Z by TFQC_Jeremy_Flicker
2 Posts

Pinned topic trouble with 'Open copy member' in LPEX

‏2014-04-23T14:28:47Z | lpex


  I'm able to hover and see the definition of a field (which is made in a copybook) in LPEX editor, but when I right-click and click 'Open Copy Member', I'm getting crrzI0019E, which says I should fix my SYSIPT.  I've tried every SYSIPT setting I can find but it's still not working.  Any input?

  • amyxhcui
    1 Post

    Re: trouble with 'Open copy member' in LPEX


    Which version of RDz are you using? I found below defect which is similar to your issue. It was fixed RDz 8.0.2.

  • TFQC_Jeremy_Flicker
    13 Posts

    Re: trouble with 'Open copy member' in LPEX


    2 thoughts come to mind:

    1) If you are developing using a local project, the editor can resolve (and display things like hovers of copy info) copy files that are just present in the project hierarchy even without a property group or one configured with a correct Local Compiler SYSLIB value, while the Open Copybook action requires an accurate Property Group to function.  If you are not using Local Projects, this will not be relevant.  If you are, then be sure to create a Local Property Group, associate it with the resources you are working with, and on the COBOL tab, on the Local Compiler section, set the SYSLIB value to the path containing your copybook resources.   To figure out what value to enter here, right click on the folder containing your copybooks and copy the "Path" value into the SYSLIB field in the property group editor.   Save your changes, and try the Open Copybook action again.

    2) The Open Copybook action in LPEX is sensitive to the amount of text you have selected in the editor when you invoke it.  If you have 6 of the 8 letters of your copybook name selected when you run the Open action, the editor will look specifically for those 6 letters, not the full 8 letters.  You can double click on the copy name to auto-select the full text of the copy name, then right click and select the Open Copybook action.