Topic
7 replies Latest Post - ‏2013-08-29T23:18:57Z by VANCITY604
VANCITY604
VANCITY604
9 Posts
ACCEPTED ANSWER

Pinned topic modified banner image file but not showing the change?

‏2013-08-27T07:13:04Z |

Hi community,

 

I am trying to configure the banner image on the top left corner (banner_swoosh) so it display which environment you are in (production, test, dev etc)

 

before customization:

 

what it should be after customization, I did not get this:

 

I did some research and I did the following:

1.   Made sure system is using tivoli09 skin

2.   Locate the banner_swoosh PNG file at D:\ibm\SMP\maximo\applications\maximo\maximouiweb\webmodule\webclient\skins\tivoli09\images\banner images

3.   Modify the banner_swoosh PNG file using Paint

4.  Stop MXServer on WebSphere

5.  Uninstall Maximo application from Websphere enterprise applications

6. Rebuild Maximo EAR file

7. Redeploy Maximo on Websphere

8. Start MXServer and Maximo application

 

However, when I log into the system, the banner image is still showing the same as before, (the second image I posted is simply an illustration of what it should be). What could I be doing wrong?  Any input would be greatly appreciated.

Thanks!

 

Updated on 2013-08-27T07:14:16Z at 2013-08-27T07:14:16Z by VANCITY604
  • AndreasBr
    AndreasBr
    7 Posts
    ACCEPTED ANSWER

    Re: modified banner image file but not showing the change?

    ‏2013-08-27T07:54:05Z  in response to VANCITY604

    have you tried deleting the cache after redeploying the EAR file?

     

    should be in <websphere appserver>/profiles/<nodename>/temp

     

    also delete the cache of the browser

    Updated on 2013-08-27T07:55:00Z at 2013-08-27T07:55:00Z by AndreasBr
    • VANCITY604
      VANCITY604
      9 Posts
      ACCEPTED ANSWER

      Re: modified banner image file but not showing the change?

      ‏2013-08-29T17:07:22Z  in response to AndreasBr

      I think this might be it. Let me give it a try.

       

    • VANCITY604
      VANCITY604
      9 Posts
      ACCEPTED ANSWER

      Re: modified banner image file but not showing the change?

      ‏2013-08-29T17:47:34Z  in response to AndreasBr

      Hi There, I cleared the cache after redeployment, it didn't work for me.  Do I have to do it after rebuild ear file and before redeployment, or even before rebuild?

      • AndreasBr
        AndreasBr
        7 Posts
        ACCEPTED ANSWER

        Re: modified banner image file but not showing the change?

        ‏2013-08-29T19:42:51Z  in response to VANCITY604

        Hi Vancity,

        We changed the color of the banner in each environment, looked better that just text for us and is "faster" to see.

        we just deleted the cache after redeployment. We had some problems til the browser re-read that file.

        Best try if your webserver serves the file, so just enter the url of the image in your browser and see if it loads.

        if it is still not loading in sccd, delete the browsercache and keep hitting ctrl+f5 :)

         

        Just as reminder, there is a second banner, if you switch via go to to another application. I can't access my system right now, else i would tell you which it is. And keep in mind, there are some patches that overwrite the files.

         

        Andreas

        • VANCITY604
          VANCITY604
          9 Posts
          ACCEPTED ANSWER

          Re: modified banner image file but not showing the change?

          ‏2013-08-29T23:18:57Z  in response to AndreasBr

          Okay the problem is the image file needs to be modified is located at one level up in the directory in D:\ibm\SMP\maximo\applications\maximo\maximouiweb\webmodule\webclient\skins\tivoli09\images  not  D:\ibm\SMP\maximo\applications\maximo\maximouiweb\webmodule\webclient\skins\tivoli09\images\banner images.  Thanks everyone!

  • GinaBarry
    GinaBarry
    2 Posts
    ACCEPTED ANSWER

    Re: modified banner image file but not showing the change?

    ‏2013-08-27T09:22:07Z  in response to VANCITY604

    You may be better off changing the Welcome message instead of changing the image. It is a much simpler change and can be done quickly. You would go to System Configuration>Platform Configuration>Databse Configuration. Once in the application just Select Messages from the Select Action Menu. Then search for Welcome in the Message value field. This is where I would normally show which environment is currently logged into along with the user logged in. 

     

    Once the change has been made simply log out and back in and you should see your changes. 

     

     

    • VANCITY604
      VANCITY604
      9 Posts
      ACCEPTED ANSWER

      Re: modified banner image file but not showing the change?

      ‏2013-08-29T17:06:01Z  in response to GinaBarry

      Hi GinaBarry,

      Thanks for your suggestion. I agree it's a very clean cut solution. However it's not what our client wants.