Topic
  • 2 replies
  • Latest Post - ‏2014-07-29T07:50:49Z by JesperLarsen
JesperLarsen
JesperLarsen
4 Posts

Pinned topic 414 -- Request-URI Too Long

‏2014-07-11T12:55:14Z |

Hey

I am getting some of these :

414 -- Request-URI Too Long

I know data should be POST'ed instead...... BUT does anyone know how to configure the TEM/REST/Reporting  to accept longer get requests?? My guess is some config in the reqistry or a conf-file somewhere... but cant seem to find any pointer towards this issue.

 

/Jesper

 

  • MikeOttum
    MikeOttum
    55 Posts
    ACCEPTED ANSWER

    Re: 414 -- Request-URI Too Long

    ‏2014-07-21T22:21:56Z  

    Hi Jesper,

    Setting the _BESRelay_HTTPServer_MaxRequestLineLength client setting on the root server will control this. The value is represented in bytes and the default is 32768.

  • MikeOttum
    MikeOttum
    55 Posts

    Re: 414 -- Request-URI Too Long

    ‏2014-07-21T22:21:56Z  

    Hi Jesper,

    Setting the _BESRelay_HTTPServer_MaxRequestLineLength client setting on the root server will control this. The value is represented in bytes and the default is 32768.

  • JesperLarsen
    JesperLarsen
    4 Posts

    Re: 414 -- Request-URI Too Long

    ‏2014-07-29T07:50:49Z  
    • MikeOttum
    • ‏2014-07-21T22:21:56Z

    Hi Jesper,

    Setting the _BESRelay_HTTPServer_MaxRequestLineLength client setting on the root server will control this. The value is represented in bytes and the default is 32768.

    Hey Mike

    This solved my issue! I had been looking for a parameter like this using Google and the IBM Search tools, but have not found ANY documentation describing this settings and other 'normal web service settings. So, how did you know? Is there a paper floating around with all the magic settings i need to be aware of?