Topic
  • 3 replies
  • Latest Post - ‏2013-11-19T12:05:42Z by memet_tiike
Enrique Valdez
Enrique Valdez
2 Posts

Pinned topic Data Studio 3.2 won't UnConfig

‏2013-10-01T15:33:37Z |

Hi:

In the process of installing DS 4.1, I need to uninstall DS 3.2 previously.

When I go to Install Manager, it tells me that before I'm allowed to uninstall, I need to run 'unconfig_DSWC'.

When I execute 'unconfig_DSWC', I get a MS-DOS windows telling me 'Eliminating IBM Data Studio Web Console Configuration' and nothing else happens....

Is there a shortcut out there that would allow me to overcome this issue?

I'd appreciate you input.

Thanks in advance

Enrique Valdez

 

  • Enrique Valdez
    Enrique Valdez
    2 Posts

    Re: Data Studio 3.2 won't UnConfig

    ‏2013-10-02T10:28:06Z  

    Hi:

    In the process of finding out answers for this issue, I cancelled the DOS 'cmd.exe' process corresponding to the , I'm presented with an error sign pointing to the log file generated by the unconfig_DSWC.bat file.

    Within that log I see this:

    !SESSION 2013-10-02 00:38:20.240 -----------------------------------------------
    eclipse.buildId=unknown
    java.fullversion=JRE 1.7.0 IBM J9 2.6 Windows XP x86-32 20120809_118929 (JIT enabled, AOT enabled)
    J9VM - R26_Java726_SR2_20120809_0948_B118929
    JIT  - r11.b01_20120808_24925
    GC   - R26_Java726_SR2_20120809_0948_B118929
    J9CL - 20120809_118929
    BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=es_ES
    Framework arguments:  -ssi C:\ARCHIV~1\IBM\DS32~1.0\CONTRO~1\DSWCSS~1.XML
    Command-line arguments:  -os win32 -ws win32 -arch x86 -ssi C:\ARCHIV~1\IBM\DS32~1.0\CONTRO~1\DSWCSS~1.XML

    !ENTRY org.eclipse.osgi 4 0 2013-10-02 22:00:39.300
    !MESSAGE Error de aplicación
    !STACK 1
    com.ibm.im.dt.dca.base.utils.ConfigRuntimeException: Error in starting DCA in Wizard mode using file C:\DOCUME~1\lev1377\CONFIG~1\Temp\ibmdt_lev1377\DswcConfigWizard.xml7227443104441038483.xml.
        at com.ibm.im.dt.dca.base.app.DcaApplicationBase.startDcaGui(Unknown Source)
        at com.ibm.im.dt.dca.base.app.DcaApplicationBase.startDca(Unknown Source)
        at com.ibm.im.dt.dca.dswc.app.DcaDswcApplication.start(Unknown Source)
        at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:88)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:55)
        at java.lang.reflect.Method.invoke(Method.java:613)
        at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:620)
        at org.eclipse.equinox.launcher.Main.basicRun(Main.java:575)
        at org.eclipse.equinox.launcher.Main.run(Main.java:1408)
    Caused by: com.ibm.im.dt.dca.base.utils.ConfigRuntimeException: generate(): Error in generating value of widget DsServerStatus on page UnconfigSummaryPage.
        at com.ibm.im.dt.dca.base.widget.ValueGeneratorBase.generate(Unknown Source)
        at com.ibm.im.dt.dca.base.widget.ValueGeneratorBase.getGeneratedValue(Unknown Source)
        at com.ibm.im.dt.dca.base.widget.ValueGeneratorGui.setWidgetValue(Unknown Source)
        at com.ibm.im.dt.dca.base.page.DtPageGui.updateImpactedWidget(Unknown Source)
        at com.ibm.im.dt.dca.base.page.DtPageGui.loadInitialValues(Unknown Source)
        at com.ibm.im.dt.dca.base.page.DtPageGui.setVisible(Unknown Source)
        at org.eclipse.jface.wizard.WizardDialog.showStartingPage(WizardDialog.java:1266)
        at org.eclipse.jface.wizard.WizardDialog.createContents(WizardDialog.java:608)
        at org.eclipse.jface.window.Window.create(Window.java:431)
        at org.eclipse.jface.dialogs.Dialog.create(Dialog.java:1089)
        at org.eclipse.jface.window.Window.open(Window.java:790)
        ... 15 more

    Do you have any ideas on how to overcome this message?

    Thanks in advance!!

    Regards

    Enrique Valdez

    Updated on 2013-10-02T10:28:45Z at 2013-10-02T10:28:45Z by Enrique Valdez
  • QiM
    QiM
    13 Posts

    Re: Data Studio 3.2 won't UnConfig

    ‏2013-11-19T05:49:26Z  

    Hi:

    In the process of finding out answers for this issue, I cancelled the DOS 'cmd.exe' process corresponding to the , I'm presented with an error sign pointing to the log file generated by the unconfig_DSWC.bat file.

    Within that log I see this:

    !SESSION 2013-10-02 00:38:20.240 -----------------------------------------------
    eclipse.buildId=unknown
    java.fullversion=JRE 1.7.0 IBM J9 2.6 Windows XP x86-32 20120809_118929 (JIT enabled, AOT enabled)
    J9VM - R26_Java726_SR2_20120809_0948_B118929
    JIT  - r11.b01_20120808_24925
    GC   - R26_Java726_SR2_20120809_0948_B118929
    J9CL - 20120809_118929
    BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=es_ES
    Framework arguments:  -ssi C:\ARCHIV~1\IBM\DS32~1.0\CONTRO~1\DSWCSS~1.XML
    Command-line arguments:  -os win32 -ws win32 -arch x86 -ssi C:\ARCHIV~1\IBM\DS32~1.0\CONTRO~1\DSWCSS~1.XML

    !ENTRY org.eclipse.osgi 4 0 2013-10-02 22:00:39.300
    !MESSAGE Error de aplicación
    !STACK 1
    com.ibm.im.dt.dca.base.utils.ConfigRuntimeException: Error in starting DCA in Wizard mode using file C:\DOCUME~1\lev1377\CONFIG~1\Temp\ibmdt_lev1377\DswcConfigWizard.xml7227443104441038483.xml.
        at com.ibm.im.dt.dca.base.app.DcaApplicationBase.startDcaGui(Unknown Source)
        at com.ibm.im.dt.dca.base.app.DcaApplicationBase.startDca(Unknown Source)
        at com.ibm.im.dt.dca.dswc.app.DcaDswcApplication.start(Unknown Source)
        at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:88)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:55)
        at java.lang.reflect.Method.invoke(Method.java:613)
        at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:620)
        at org.eclipse.equinox.launcher.Main.basicRun(Main.java:575)
        at org.eclipse.equinox.launcher.Main.run(Main.java:1408)
    Caused by: com.ibm.im.dt.dca.base.utils.ConfigRuntimeException: generate(): Error in generating value of widget DsServerStatus on page UnconfigSummaryPage.
        at com.ibm.im.dt.dca.base.widget.ValueGeneratorBase.generate(Unknown Source)
        at com.ibm.im.dt.dca.base.widget.ValueGeneratorBase.getGeneratedValue(Unknown Source)
        at com.ibm.im.dt.dca.base.widget.ValueGeneratorGui.setWidgetValue(Unknown Source)
        at com.ibm.im.dt.dca.base.page.DtPageGui.updateImpactedWidget(Unknown Source)
        at com.ibm.im.dt.dca.base.page.DtPageGui.loadInitialValues(Unknown Source)
        at com.ibm.im.dt.dca.base.page.DtPageGui.setVisible(Unknown Source)
        at org.eclipse.jface.wizard.WizardDialog.showStartingPage(WizardDialog.java:1266)
        at org.eclipse.jface.wizard.WizardDialog.createContents(WizardDialog.java:608)
        at org.eclipse.jface.window.Window.create(Window.java:431)
        at org.eclipse.jface.dialogs.Dialog.create(Dialog.java:1089)
        at org.eclipse.jface.window.Window.open(Window.java:790)
        ... 15 more

    Do you have any ideas on how to overcome this message?

    Thanks in advance!!

    Regards

    Enrique Valdez

    Hi,

    If you just want to install DS 4.1, you can install DS4.1 into a new package without uninstall 3.2. DS support multiple copies on the system.

    If you want to uninstall DS3.2, you can just select to uninstall DS3.2 without uninstall DSWC.

  • memet_tiike
    memet_tiike
    19 Posts

    Re: Data Studio 3.2 won't UnConfig

    ‏2013-11-19T12:05:42Z  

    Hi:

    In the process of finding out answers for this issue, I cancelled the DOS 'cmd.exe' process corresponding to the , I'm presented with an error sign pointing to the log file generated by the unconfig_DSWC.bat file.

    Within that log I see this:

    !SESSION 2013-10-02 00:38:20.240 -----------------------------------------------
    eclipse.buildId=unknown
    java.fullversion=JRE 1.7.0 IBM J9 2.6 Windows XP x86-32 20120809_118929 (JIT enabled, AOT enabled)
    J9VM - R26_Java726_SR2_20120809_0948_B118929
    JIT  - r11.b01_20120808_24925
    GC   - R26_Java726_SR2_20120809_0948_B118929
    J9CL - 20120809_118929
    BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=es_ES
    Framework arguments:  -ssi C:\ARCHIV~1\IBM\DS32~1.0\CONTRO~1\DSWCSS~1.XML
    Command-line arguments:  -os win32 -ws win32 -arch x86 -ssi C:\ARCHIV~1\IBM\DS32~1.0\CONTRO~1\DSWCSS~1.XML

    !ENTRY org.eclipse.osgi 4 0 2013-10-02 22:00:39.300
    !MESSAGE Error de aplicación
    !STACK 1
    com.ibm.im.dt.dca.base.utils.ConfigRuntimeException: Error in starting DCA in Wizard mode using file C:\DOCUME~1\lev1377\CONFIG~1\Temp\ibmdt_lev1377\DswcConfigWizard.xml7227443104441038483.xml.
        at com.ibm.im.dt.dca.base.app.DcaApplicationBase.startDcaGui(Unknown Source)
        at com.ibm.im.dt.dca.base.app.DcaApplicationBase.startDca(Unknown Source)
        at com.ibm.im.dt.dca.dswc.app.DcaDswcApplication.start(Unknown Source)
        at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:88)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:55)
        at java.lang.reflect.Method.invoke(Method.java:613)
        at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:620)
        at org.eclipse.equinox.launcher.Main.basicRun(Main.java:575)
        at org.eclipse.equinox.launcher.Main.run(Main.java:1408)
    Caused by: com.ibm.im.dt.dca.base.utils.ConfigRuntimeException: generate(): Error in generating value of widget DsServerStatus on page UnconfigSummaryPage.
        at com.ibm.im.dt.dca.base.widget.ValueGeneratorBase.generate(Unknown Source)
        at com.ibm.im.dt.dca.base.widget.ValueGeneratorBase.getGeneratedValue(Unknown Source)
        at com.ibm.im.dt.dca.base.widget.ValueGeneratorGui.setWidgetValue(Unknown Source)
        at com.ibm.im.dt.dca.base.page.DtPageGui.updateImpactedWidget(Unknown Source)
        at com.ibm.im.dt.dca.base.page.DtPageGui.loadInitialValues(Unknown Source)
        at com.ibm.im.dt.dca.base.page.DtPageGui.setVisible(Unknown Source)
        at org.eclipse.jface.wizard.WizardDialog.showStartingPage(WizardDialog.java:1266)
        at org.eclipse.jface.wizard.WizardDialog.createContents(WizardDialog.java:608)
        at org.eclipse.jface.window.Window.create(Window.java:431)
        at org.eclipse.jface.dialogs.Dialog.create(Dialog.java:1089)
        at org.eclipse.jface.window.Window.open(Window.java:790)
        ... 15 more

    Do you have any ideas on how to overcome this message?

    Thanks in advance!!

    Regards

    Enrique Valdez

    Hi,

    is the locale of the machine English?

    If not, change the locale to English if possible and then run unconfig.

    To change the locale, change locale on the "Formats" tab of "Region and Language" settings and also on the Administrative tab.

    I had a similar issue and this had helped me.

    Good luck.