Topic
  • 12 replies
  • Latest Post - ‏2014-01-08T10:19:53Z by FredericDelhoume
qtbgo
qtbgo
116 Posts

Pinned topic cannot use Chinese character in file name in ILOG 12.6

‏2014-01-05T08:40:30Z |

Hi, I install ILOG CPLEX 12.6 Chinese version, and I find that if you use Chinese character to name a mod file, then ILOG will quit when you double click the project. Do you have this problem?

  • FredericDelhoume
    FredericDelhoume
    10 Posts

    Re: cannot use Chinese character in file name in ILOG 12.6

    ‏2014-01-06T09:38:39Z  

    Can you describe exactly what steps you are doing ?

  • qtbgo
    qtbgo
    116 Posts

    Re: cannot use Chinese character in file name in ILOG 12.6

    ‏2014-01-06T10:03:51Z  

    Can you describe exactly what steps you are doing ?

    In ilog 12.5, I can open a project which has a mod file using chinese name.

    I cannot open this same project in ilog 12.6, I just double click the project in the OPL 项目 view, then  an error ocurs and it quits.

     

  • FredericDelhoume
    FredericDelhoume
    10 Posts

    Re: cannot use Chinese character in file name in ILOG 12.6

    ‏2014-01-06T10:06:36Z  
    • qtbgo
    • ‏2014-01-06T10:03:51Z

    In ilog 12.5, I can open a project which has a mod file using chinese name.

    I cannot open this same project in ilog 12.6, I just double click the project in the OPL 项目 view, then  an error ocurs and it quits.

     

    Can you give the error that happens ?

    Do you have some entries in .log file in your .workspace directory ?

  • qtbgo
    qtbgo
    116 Posts

    Re: cannot use Chinese character in file name in ILOG 12.6

    ‏2014-01-06T10:37:54Z  

    Can you give the error that happens ?

    Do you have some entries in .log file in your .workspace directory ?

    pls see attached error. by the way,  I use 64bit ilog on win7 chinese version.

    Attachments

  • FredericDelhoume
    FredericDelhoume
    10 Posts

    Re: cannot use Chinese character in file name in ILOG 12.6

    ‏2014-01-06T10:43:38Z  
    • qtbgo
    • ‏2014-01-06T10:37:54Z

    pls see attached error. by the way,  I use 64bit ilog on win7 chinese version.

    It happens when you try to import the project ?

    Can you attach the zipped project ?

    With no content in .mod and .dat for confidentiality it is fine.

  • qtbgo
    qtbgo
    116 Posts

    Re: cannot use Chinese character in file name in ILOG 12.6

    ‏2014-01-06T12:04:44Z  

    It happens when you try to import the project ?

    Can you attach the zipped project ?

    With no content in .mod and .dat for confidentiality it is fine.

    In fact, I just now build a new empty opl project in ilog 12.6. Then I create a new mod and give it a chinese name, then I click Ok, then it quits.

    That means I cannot create a mod with chinese name in ilog 12.6.

     

  • FredericDelhoume
    FredericDelhoume
    10 Posts

    Re: cannot use Chinese character in file name in ILOG 12.6

    ‏2014-01-06T12:49:13Z  
    • qtbgo
    • ‏2014-01-06T12:04:44Z

    In fact, I just now build a new empty opl project in ilog 12.6. Then I create a new mod and give it a chinese name, then I click Ok, then it quits.

    That means I cannot create a mod with chinese name in ilog 12.6.

     

    I have tried this and it seems to work.

    Do you have something in your .log file in workspace ?

     

     

    Attachments

  • qtbgo
    qtbgo
    116 Posts

    Re: cannot use Chinese character in file name in ILOG 12.6

    ‏2014-01-07T00:32:45Z  

    I have tried this and it seems to work.

    Do you have something in your .log file in workspace ?

     

     

    it's very strange. I attach the log file.

    By the way, I report another two problems.

    1 I cannot use help now. When I click menu item "帮助内容",a dialog appear, see the attached 1.png. This problem dispeared now, but the following problem 2 still  exists.

       

    2 I also cannot use F1 to search a keyword, if so, it will quit. See the attached 2.png.

     

    Attachments

    Updated on 2014-01-07T12:31:54Z at 2014-01-07T12:31:54Z by qtbgo
  • FredericDelhoume
    FredericDelhoume
    10 Posts

    Re: cannot use Chinese character in file name in ILOG 12.6

    ‏2014-01-07T12:50:03Z  
    • qtbgo
    • ‏2014-01-07T00:32:45Z

    it's very strange. I attach the log file.

    By the way, I report another two problems.

    1 I cannot use help now. When I click menu item "帮助内容",a dialog appear, see the attached 1.png. This problem dispeared now, but the following problem 2 still  exists.

       

    2 I also cannot use F1 to search a keyword, if so, it will quit. See the attached 2.png.

     

    I see nothing really suspicious in .log file, or crash related.

    My guess is that there is something on your machine that disturbs normal OPL IDE behaviour, but I do not

    know what.

  • HowardGe
    HowardGe
    9 Posts

    Re: cannot use Chinese character in file name in ILOG 12.6

    ‏2014-01-08T02:19:17Z  

    I see nothing really suspicious in .log file, or crash related.

    My guess is that there is something on your machine that disturbs normal OPL IDE behaviour, but I do not

    know what.

    hi ,i came cross the same  trouble when i wanted to create a new project with a Chinese name.Error information can be found in the attachment.

    Attachments

  • qtbgo
    qtbgo
    116 Posts

    Re: cannot use Chinese character in file name in ILOG 12.6

    ‏2014-01-08T06:50:31Z  

    I see nothing really suspicious in .log file, or crash related.

    My guess is that there is something on your machine that disturbs normal OPL IDE behaviour, but I do not

    know what.

    I tested it in two other machines, still cannot use Chinese name.

    I test it on 64bit Win7 Chinese version, win XP Chinese version.

    I guess it is because Chinese operating system. Did you test it on Chinese perating system?

  • FredericDelhoume
    FredericDelhoume
    10 Posts

    Re: cannot use Chinese character in file name in ILOG 12.6

    ‏2014-01-08T10:19:53Z  
    • qtbgo
    • ‏2014-01-08T06:50:31Z

    I tested it in two other machines, still cannot use Chinese name.

    I test it on 64bit Win7 Chinese version, win XP Chinese version.

    I guess it is because Chinese operating system. Did you test it on Chinese perating system?

    I tested on an English (US) OS, Win7 64 bit