Topic
  • 5 replies
  • Latest Post - ‏2013-08-06T06:15:17Z by KKNW_jack
KKNW_jack
KKNW_jack
4 Posts

Pinned topic CRFCN0564E : Could not find a Browser role attribute for the object.

‏2013-07-26T01:18:35Z |

Hi There,

i am having issue with browser, i was using ie6 before that was working fine with my RFT 8.3 but when i upgraded my ie to ie8, since than i am getting below - i would be very thankful of any help from you guys. - i have enabled my browser also

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Could not find a Browser role attribute for the object.
CRFCN0564E: The application is either not running or the environment is not enabled properly.
com.rational.test.ft.ObjectNotFoundException
    at com.rational.test.ft.object.interfaces.ClientTestObject.invokeProxy(ClientTestObject.java:411)
    at com.rational.test.ft.object.interfaces.BrowserTestObject.loadUrl(BrowserTestObject.java:110)
    at Utility.Browser.loadUrl(Browser.java:334)
    at Utility.Browser.openAdminUrl(Browser.java:348)
    at Utility.Browser.startAdmin(Browser.java:367)
    at Tests.LoginAndOut.testMain(LoginAndOut.java:39)
    at org.eclipse.equinox.internal.app.EclipseAppContainer.callMethodWithException(EclipseAppContainer.java:587)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:198)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:353)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:180)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:629)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
    at org.eclipse.equinox.launcher.Main.main(Main.java:1414)
    at org.eclipse.core.launcher.Main.main(Main.java:34)

------------------------------------------------------------------------------------------------------------------------

Many thanks for you help in advance

Attachments

Updated on 2013-07-26T01:21:16Z at 2013-07-26T01:21:16Z by KKNW_jack
  • KKNW_jack
    KKNW_jack
    4 Posts
    ACCEPTED ANSWER

    Re: CRFCN0564E : Could not find a Browser role attribute for the object.

    ‏2013-08-06T06:15:17Z  
    • KKNW_jack
    • ‏2013-08-02T06:59:27Z

    Hi there !!

    its hard to send you code because it calls methods from one java code to another but ( i will try ) to make it more clear and post for you

    at this point i can tell is it fails at

    browser_htmlBrowser().loadUrl;  // loadUrl >>> loads url from csv data pool

    and throws above message

    thanks again

     

    Hi there,

    update :

    i uninstalled my JAVA and reinstalled it. i had two version of JAVA 6 and 7, i reinstall jre6 and its working now

    many be multiple java version was causing the problem ??

    may be jre7 was not compatible with RFT 8.5 ??

    i have no idea, but now it all fine with jre6  :)

    Many thanks for your effort and help

    Updated on 2013-08-06T06:16:27Z at 2013-08-06T06:16:27Z by KKNW_jack
  • cagin.uludamar
    cagin.uludamar
    66 Posts

    Re: CRFCN0564E : Could not find a Browser role attribute for the object.

    ‏2013-07-26T10:37:33Z  

    Hi, first did you check that your ie version is supported by RFT? Then did you re-enable your browser?

  • KKNW_jack
    KKNW_jack
    4 Posts

    Re: CRFCN0564E : Could not find a Browser role attribute for the object.

    ‏2013-07-29T05:38:58Z  

    Hi, first did you check that your ie version is supported by RFT? Then did you re-enable your browser?

    Hi there,

    thanks for reply,

    i am using RFT 8.3 with ie8 (32 bit), i re-enabled also

    i am launching browser using my own custom code which was working fine with ie6, as i upgraded my ie from 6 to 8, it start giving me above error

    Many thanks

  • cagin.uludamar
    cagin.uludamar
    66 Posts

    Re: CRFCN0564E : Could not find a Browser role attribute for the object.

    ‏2013-07-29T13:24:51Z  
    • KKNW_jack
    • ‏2013-07-29T05:38:58Z

    Hi there,

    thanks for reply,

    i am using RFT 8.3 with ie8 (32 bit), i re-enabled also

    i am launching browser using my own custom code which was working fine with ie6, as i upgraded my ie from 6 to 8, it start giving me above error

    Many thanks

    Is it possible to share your custom code? What happens it you start your application using startApp() method?

  • KKNW_jack
    KKNW_jack
    4 Posts

    Re: CRFCN0564E : Could not find a Browser role attribute for the object.

    ‏2013-08-02T06:59:27Z  

    Is it possible to share your custom code? What happens it you start your application using startApp() method?

    Hi there !!

    its hard to send you code because it calls methods from one java code to another but ( i will try ) to make it more clear and post for you

    at this point i can tell is it fails at

    browser_htmlBrowser().loadUrl;  // loadUrl >>> loads url from csv data pool

    and throws above message

    thanks again

     

  • KKNW_jack
    KKNW_jack
    4 Posts

    Re: CRFCN0564E : Could not find a Browser role attribute for the object.

    ‏2013-08-06T06:15:17Z  
    • KKNW_jack
    • ‏2013-08-02T06:59:27Z

    Hi there !!

    its hard to send you code because it calls methods from one java code to another but ( i will try ) to make it more clear and post for you

    at this point i can tell is it fails at

    browser_htmlBrowser().loadUrl;  // loadUrl >>> loads url from csv data pool

    and throws above message

    thanks again

     

    Hi there,

    update :

    i uninstalled my JAVA and reinstalled it. i had two version of JAVA 6 and 7, i reinstall jre6 and its working now

    many be multiple java version was causing the problem ??

    may be jre7 was not compatible with RFT 8.5 ??

    i have no idea, but now it all fine with jre6  :)

    Many thanks for your effort and help

    Updated on 2013-08-06T06:16:27Z at 2013-08-06T06:16:27Z by KKNW_jack