Topic
4 replies Latest Post - ‏2013-08-26T15:48:18Z by BillBulfin
SAB
SAB
2 Posts
ACCEPTED ANSWER

Pinned topic "New from..." not doing anything on Program

‏2013-07-05T19:15:48Z |

I am admittedly a newbie on CICS Explorer, but I'm trying to get a feel for it. When I bring up program definitions for a region (click on Definitions, then Program Definitions, while my desired region is highlighted), and want to define a new program based on an existing one, I right click on the program I want to use as a model, and it looks like the thing to do would be click on "New from...". As I understand it, that should start up a wizard to define a new program with all the attributes of the one I right-clicked. However, nothing is happening; no messages, nothing. When I click on "New", a wizard starts. I also get a wizard to start if I click on "New from..." on a other types of definitions (terminal, transaction, etc) - it just seems to be Program that is being stubborn. Am I overlooking something basic that is different about Programs that just hasn't become obvious to me? I am running the new CICS Explorer 5.1.1.

Thanks,

SAB

  • DaveN
    DaveN
    57 Posts
    ACCEPTED ANSWER

    Re: "New from..." not doing anything on Program

    ‏2013-07-08T16:06:27Z  in response to SAB

    Hi SAB,

    I'm sorry you're not getting much luck using New From on Programs!

    I've just tested on a CICS 5.1 system and can do New From on Programs that originate in both BAS and CSD repositories. I think we're going to need a bit more information on your exact setup.

    Can I ask you to do two things, please?

    1) Open the Error Log (ctrl+3 then type error, to find it) and look for a new red cross appearing when you try new from. Often when a dialog like a wizard just doesn't appear, it's because there's been an error caught by Eclipse and it's just given up on opening the dialog.

    2) Collect your service data and send it to me (dave.nice@uk.ibm.com) - you can do this from the File, Trace, Collect Service Data option. This should give me an idea of the kind of thing you're doing (e.g. CMCI or CPSM data connection, selected a Program in BAS or CSD, etc etc).

    Thanks in advance,

    Dave

    • SAB
      SAB
      2 Posts
      ACCEPTED ANSWER

      Re: "New from..." not doing anything on Program

      ‏2013-07-18T16:45:40Z  in response to DaveN

      Thanks, Dave. I have just emailed you the two items you asked for on this "unhandled event loop exception". Please let me know if there is any further info I can provide.

      Thanks again,

      Steve (SAB)

  • BillBulfin
    BillBulfin
    3 Posts
    ACCEPTED ANSWER

    Re: "New from..." not doing anything on Program

    ‏2013-08-08T23:52:38Z  in response to SAB

    It looks like we've opened RTD defect 75464 for this.  SR 47900,004,000 has been opened.  I will see if we can take an APAR.

  • BillBulfin
    BillBulfin
    3 Posts
    ACCEPTED ANSWER

    Re: "New from..." not doing anything on Program

    ‏2013-08-26T15:48:18Z  in response to SAB

    APAR IV46853 is now available and delivered in IBM Fix Central as:

    IBM CICS Explorer 5.1.1 CICSEX-5.1.1-FP0001

    See http://www-01.ibm.com/support/docview.wss?crawler=1&uid=swg1IV46853

    This fix will also be made available in Version 5.1.1.1 of the CICS Explorer.