Topic
  • 4 replies
  • Latest Post - ‏2013-05-14T02:31:52Z by GBaddeley
sacstsb
sacstsb
3 Posts

Pinned topic How to resolve MQRC_HOST_NOT_AVAILABLE error ?

‏2013-04-25T19:19:15Z |

Hello,

Here is the error code : CompCode:2, Reason:2538

I am trying to use CCDT to connect from .NET 4.0 .

1. Environment variables set for (MQCHLLIB & MQCHLTAB)

2. Referenced amqmdnet to project

3. MQQueueManager QueManager = new MQQueueManager();

How to trace whether its loding TAB file or not? Why I am getting MQRC_HOST_NOT_AVAILABLE error?

Thanks for your help

 

 

 

  • GBaddeley
    GBaddeley
    302 Posts

    Re: How to resolve MQRC_HOST_NOT_AVAILABLE error ?

    ‏2013-04-25T23:26:07Z  

    Check the MQ Client error log AMQERR01.LOG on the windows host.  It should contain further diagnostics.  [This should always be the first step]

    If you are using MQ Client, the name of the queue manager you are connecting to is mapped to a Channel Name and CONNAME by the CCDT (if you have it correctly configured). The CONNAME must be a resolvable TCP host name.  Try nslookup or ping of this host name.  If the host exists, check that a queue manager is listening on the specified port on that host.

    HTH, G.

  • sharpeye500
    sharpeye500
    5 Posts

    Re: How to resolve MQRC_HOST_NOT_AVAILABLE error ?

    ‏2013-04-29T16:41:05Z  

    Check whether your network connection is there, most of the times, if all of your parameters are set rightly, if you get that 2538, it could be your network is disabled.

  • sacstsb
    sacstsb
    3 Posts

    Re: How to resolve MQRC_HOST_NOT_AVAILABLE error ?

    ‏2013-05-13T13:51:46Z  

    Check whether your network connection is there, most of the times, if all of your parameters are set rightly, if you get that 2538, it could be your network is disabled.

    Hi GBaddeley and sharpeye500,

    Its working now. Thank you for your help.

  • GBaddeley
    GBaddeley
    302 Posts

    Re: How to resolve MQRC_HOST_NOT_AVAILABLE error ?

    ‏2013-05-14T02:31:52Z  
    • sacstsb
    • ‏2013-05-13T13:51:46Z

    Hi GBaddeley and sharpeye500,

    Its working now. Thank you for your help.

    Would you like to share how you got it to work? Readers of this forum would like to learn from your experience.