Topic
  • 7 replies
  • Latest Post - ‏2013-03-08T04:51:05Z by dtoolman.dan
dtoolman.dan
dtoolman.dan
20 Posts

Pinned topic Booting PowerLinux Toolkit 5.3 and RHEL 6.3 ISO from the same VM Library & Errors

‏2013-02-01T20:36:26Z |
. VM LIbrary is created on VIO and both PowerLinux Toolkit and RHEL iso is copied into the dir 
. single VIO serving 2 vSCSI devices toa single LPAR
. 2 Virtual Optical devices are created and bound to each of the vSCSI hosts above (vhost2 and vhost3)  
. PowerLinux ISO is presented to LPAR on vhost2
. RHEL ISO is presented to LPAR on vhost3 
. booting to the Toolkit works from LPAR SMS menu ... resulting in the boot: prompt 
. issuing "boot: linux" (hoping to boot the 2ndary device RHEL ISO) results in the following errors below 
. is there a easier way to do this? 
 
Advise, Thanks! 
Dan 
 
=== Errors 
boot: linux
Please wait, loading kernel...
   Elf64 kernel loaded...
Loading ramdisk...
Claim failed for initrd memory at 02000000 rc=ffffffff
ENTER called ok
0 >

Updated on 2013-03-08T04:51:05Z at 2013-03-08T04:51:05Z by dtoolman.dan
  • ManasKumarNayak
    ManasKumarNayak
    6 Posts

    Re: Booting PowerLinux Toolkit 5.3 and RHEL 6.3 ISO from the same VM Library & Errors

    ‏2013-02-04T07:13:25Z  
     Dear Dan,
    Two vhosts might be complicate for Powerlinux toolkit. It might be getting confused which one to be choosed and usually lack of that intelligence to select automatically  
    There is a simple way to do installation using PowerLinux toolkit .
    Instead of two Vhosts scsi attached to the same lpar, attach only one Vhost scsi (or DVD rom).
    Then attach Powerlinux toolkit first and boot the system with it.
    Once installation gets started , it will ask to attach RHEL6.3 distro dvd , then remove the Powerlinux toolkit from the DVD rom , and attach RHEL6.3 to it.
    And now you can proceed for the installation , after installation gets finished , it will ask for Powerlinux toolkit again for the last time.
    This will help to configure post installation stuffs & your system would be ready to use.
     
    Thanks...
    Manas
  • dtoolman.dan
    dtoolman.dan
    20 Posts

    Re: Booting PowerLinux Toolkit 5.3 and RHEL 6.3 ISO from the same VM Library & Errors

    ‏2013-02-04T16:36:19Z  
     Dear Dan,
    Two vhosts might be complicate for Powerlinux toolkit. It might be getting confused which one to be choosed and usually lack of that intelligence to select automatically  
    There is a simple way to do installation using PowerLinux toolkit .
    Instead of two Vhosts scsi attached to the same lpar, attach only one Vhost scsi (or DVD rom).
    Then attach Powerlinux toolkit first and boot the system with it.
    Once installation gets started , it will ask to attach RHEL6.3 distro dvd , then remove the Powerlinux toolkit from the DVD rom , and attach RHEL6.3 to it.
    And now you can proceed for the installation , after installation gets finished , it will ask for Powerlinux toolkit again for the last time.
    This will help to configure post installation stuffs & your system would be ready to use.
     
    Thanks...
    Manas
     So in the meantime, while I was waiting on a resp. I attempted this ...
    (ps. thanks for the thoughts above, I will be trying that idea on a diff. lpar) 
     
     dev nvram
     wipe-nvram
     
     Since wiping the nvram ... when attempting to boot PowerLinux TK ... I get this endless reboot loop now ... ?
     
    boot:
    Please wait, loading kernel...
       Elf64 kernel loaded...
    Loading ramdisk...
    ramdisk loaded at 03880000, size: 18682 Kbytes
    OF stdout device is: /vdevice/vty@30000000
    Preparing to boot Linux version 2.6.32-220.17.1.34.mcp7.2.ppc64 (mockbuild@mcpbldp1) (gcc version 4.4.6 20110731 (gcc 4.4.6-7) (GCC) ) #1 SMP Mon Oct 8 11:35:34 CDT 2012
    Max number of cores passed to firmware: 0x0000000000000100
    Calling ibm,client-architecture-support... done
    command line: root=/dev/ram init=/linuxrc ramdisk_size=49152 quiet timestamp=201211131155
    memory layout at init:
      memory_limit : 0000000000000000 (16 MB aligned)
      alloc_bottom : 0000000004ac0000
      alloc_top    : 0000000010000000
      alloc_top_hi : 0000000010000000
      rmo_top      : 0000000010000000
      ram_top      : 0000000010000000
    instantiating rtas at 0x000000000ee90000... done
    boot cpu hw idx 0000000000000000
    copying OF device tree...
    Building dt strings...
    Building dt structure...
    Device tree strings 0x0000000004bd0000 -> 0x0000000004bd15c6
    Device tree struct  0x0000000004be0000 -> 0x0000000004c00000
    Calling quiesce...
    returning from prom_init
    Loading network modules.
    vxge: Copyright(c) 2002-2009 Neterion Inc
    vxge: Driver version: 2.0.8.20182-k
    Available memory: 1008512 KB
    Timestamp or CD drives not found. Rebooting.
    SysRq : Resetting
     
    Hmmm 
     
  • 411M_kevin_tan
    411M_kevin_tan
    1 Post

    Re: Booting PowerLinux Toolkit 5.3 and RHEL 6.3 ISO from the same VM Library & Errors

    ‏2013-02-23T13:55:08Z  
    to solve this problem pls refer to URL:
     https://www.ibm.com/developerworks/mydeveloperworks/blogs/powermeup/entry/rhel_kernel_image_to_large?lang=en
  • dtoolman.dan
    dtoolman.dan
    20 Posts

    Re: Booting PowerLinux Toolkit 5.3 and RHEL 6.3 ISO from the same VM Library & Errors

    ‏2013-02-25T20:02:16Z  
    to solve this problem pls refer to URL:
     https://www.ibm.com/developerworks/mydeveloperworks/blogs/powermeup/entry/rhel_kernel_image_to_large?lang=en
    so my error does match your URL above ... and I tweak the real-base size to 1000000 then reset-all ... 
     
    I am attempting to boot the IBM PowerLinux Toolkit 5.3 ...  
     
    Now the error is a reboot loop which says this ... this is on a LPAR provisioned with a Client SCSI Virtual Optical Device via the VIO VM Library facility
     
    [snip] 
    Timestamp or CD drives not found. Rebooting.
    SysRq : Resetting
     
  • dtoolman.dan
    dtoolman.dan
    20 Posts

    Re: Booting PowerLinux Toolkit 5.3 and RHEL 6.3 ISO from the same VM Library & Errors

    ‏2013-02-26T19:33:08Z  
    so my error does match your URL above ... and I tweak the real-base size to 1000000 then reset-all ... 
     
    I am attempting to boot the IBM PowerLinux Toolkit 5.3 ...  
     
    Now the error is a reboot loop which says this ... this is on a LPAR provisioned with a Client SCSI Virtual Optical Device via the VIO VM Library facility
     
    [snip] 
    Timestamp or CD drives not found. Rebooting.
    SysRq : Resetting
     
    This is with PowerLinux Toolkit 5.3 ... at the boot prompt I gave it
    Trying to boot the toolkit to an LPAR, so I can install Linux (RHEL 6.x) to it 
    Toolkit presented via a Virtual Optical Device on the backing VIO
    VIO @ 2.2.0.10-FP-24
     
    boot: linux debug rdinitdebug 
     
    And captured the following ... is the Toolkit just not finding the Virtual Optical Device, is this a logic issue? Toolkit issue? or VIO f/w issue?
     
    dracut: +++ [[ -f /proc/sys/dev/cdrom/info ]]
    dracut: +++ [[ -f /proc/sys/dev/cdrom/info ]]
    dracut: ++++ cat /proc/sys/dev/cdrom/info
    dracut: ++++ cat /proc/sys/dev/cdrom/info
    dracut: ++++ grep 'drive name'
    dracut: ++++ grep 'drive name'
    dracut: ++++ sed 's/.*:s*([^ ]*)$/1/'
    dracut: ++++ sed 's/.*:s*([^ ]*)$/1/'
    dracut: +++ cdDevices=
    dracut: +++ cdDevices=
    dracut: +++ '[' -z '' ']'
    dracut: +++ '[' -z '' ']'
    dracut: +++ sleep 1
    dracut: +++ sleep 1
    dracut: +++ i=10
    dracut: +++ i=10
    dracut: +++ '[' 10 -lt 10 ']'
    dracut: +++ '[' 10 -lt 10 ']'
    dracut: ++ local cdDevices=
    dracut: ++ local cdDevices=
    dracut: ++ [[ -z '' ]]
    dracut: ++ [[ -z '' ]]
    dracut: ++ echo 'Timestamp or CD drives not found. Rebooting.'
    dracut: ++ echo 'Timestamp or CD drives not found. Rebooting.'
    dracut: Timestamp or CD drives not found. Rebooting.
    dracut: Timestamp or CD drives not found. Rebooting.
    dracut: ++ sleep 3
    dracut: ++ sleep 3
    dracut: ++ reboot
    dracut: ++ reboot
     
  • JayFurmanek
    JayFurmanek
    103 Posts

    Re: Booting PowerLinux Toolkit 5.3 and RHEL 6.3 ISO from the same VM Library & Errors

    ‏2013-03-08T04:43:45Z  
    This is with PowerLinux Toolkit 5.3 ... at the boot prompt I gave it
    Trying to boot the toolkit to an LPAR, so I can install Linux (RHEL 6.x) to it 
    Toolkit presented via a Virtual Optical Device on the backing VIO
    VIO @ 2.2.0.10-FP-24
     
    boot: linux debug rdinitdebug 
     
    And captured the following ... is the Toolkit just not finding the Virtual Optical Device, is this a logic issue? Toolkit issue? or VIO f/w issue?
     
    dracut: +++ [[ -f /proc/sys/dev/cdrom/info ]]
    dracut: +++ [[ -f /proc/sys/dev/cdrom/info ]]
    dracut: ++++ cat /proc/sys/dev/cdrom/info
    dracut: ++++ cat /proc/sys/dev/cdrom/info
    dracut: ++++ grep 'drive name'
    dracut: ++++ grep 'drive name'
    dracut: ++++ sed 's/.*:s*([^ ]*)$/1/'
    dracut: ++++ sed 's/.*:s*([^ ]*)$/1/'
    dracut: +++ cdDevices=
    dracut: +++ cdDevices=
    dracut: +++ '[' -z '' ']'
    dracut: +++ '[' -z '' ']'
    dracut: +++ sleep 1
    dracut: +++ sleep 1
    dracut: +++ i=10
    dracut: +++ i=10
    dracut: +++ '[' 10 -lt 10 ']'
    dracut: +++ '[' 10 -lt 10 ']'
    dracut: ++ local cdDevices=
    dracut: ++ local cdDevices=
    dracut: ++ [[ -z '' ]]
    dracut: ++ [[ -z '' ]]
    dracut: ++ echo 'Timestamp or CD drives not found. Rebooting.'
    dracut: ++ echo 'Timestamp or CD drives not found. Rebooting.'
    dracut: Timestamp or CD drives not found. Rebooting.
    dracut: Timestamp or CD drives not found. Rebooting.
    dracut: ++ sleep 3
    dracut: ++ sleep 3
    dracut: ++ reboot
    dracut: ++ reboot
     
     Are you still using two separate vHosts for each virtual optical drives? That's neither necessary or recommended, really.
     Usually, you just need one vHost adapter per client, and then you can attach multiple client vscsi devices to that, similar to how a real scsi chain would work.
     
    It seems you are having issues with IBMIT, however. Have you tried just booting the RHEL media and installing that way?
    Use the VNC graphical install option. (just issue "linux vnc"at the boot prompt and away you go)
  • dtoolman.dan
    dtoolman.dan
    20 Posts

    Re: Booting PowerLinux Toolkit 5.3 and RHEL 6.3 ISO from the same VM Library & Errors

    ‏2013-03-08T04:51:05Z  
     Are you still using two separate vHosts for each virtual optical drives? That's neither necessary or recommended, really.
     Usually, you just need one vHost adapter per client, and then you can attach multiple client vscsi devices to that, similar to how a real scsi chain would work.
     
    It seems you are having issues with IBMIT, however. Have you tried just booting the RHEL media and installing that way?
    Use the VNC graphical install option. (just issue "linux vnc"at the boot prompt and away you go)
     I'm back down to 1 vhost provisioning the single Virtual Optical drive ... but discovered by issue was a dual pathed vFC device presented to the lpar which was causing it to choke. When I reduced this vFC device to a single path ... I got further.
     
    I could not boot direct to the RHEL media via the Virtual Optical drive ... it kept saving No Software Found.
     
    Advise ...