Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
4 replies Latest Post - ‏2013-11-06T12:39:21Z by bstroup
bstroup
bstroup
26 Posts
ACCEPTED ANSWER

Pinned topic Error when logging into CQ Designer

‏2013-04-15T20:22:17Z |

When I try to login to CQ Designer (both the Eclipse and the old Windows versions) I get the following error:

CRMCU0018E Failed condition: master_ro->IsMaster()

Location: ClearQuest Core:adsessionmgr.cpp:1301

I am able to login successfully on another computer so its not a problem with the user account. I tried uninstalling and reinstalling with no luck. There are no issues with the CQ client itself, just the Designer

 

This is with CQ 7.1.2, Win 7, and SQL Server 2008. Has anyone else gotten this or a similar error and resolved it?

  • MrCalm
    MrCalm
    2 Posts
    ACCEPTED ANSWER

    Re: Error when logging into CQ Designer

    ‏2013-10-03T10:43:40Z  in response to bstroup

    Since this problem is only occurring on one machine there may have been a problem during install.
    Did you receive any errors or warnings when you installed CQ?
    You may want to take a look at the install logs and see if the install was successful or not?
    Windows 2008, Vista or Windows 7:
    C:\ProgramData\IBM\Installation Manager\logs

    You may also want to turn on diagnostic tracing to see what cq is doing just before the error
    See:http://www-01.ibm.com/support/docview.wss?uid=swg21231445

    You may also want to try and create a a new schema repository and SAMPL
    database using MS_ACCESS on the machine and see if you can use the CQ designer
    as it could be a combination of CQ on that machine and you DBset.

    All of the above should help narrow the scope of the problem.
    Hope this helps!

  • DonaldN
    DonaldN
    246 Posts
    ACCEPTED ANSWER

    Re: Error when logging into CQ Designer

    ‏2013-10-04T00:21:42Z  in response to bstroup

    Years ago someone got the same error when running a script and the problem seemed to be at the API GetAccessibleDatabases(). Check the diagnostic trace and see if the problem lies there.

    https://www.ibm.com/developerworks/community/forums/html/topic?id=77777777-0000-0000-0000-000014166908

  • GlennSkinner
    GlennSkinner
    58 Posts
    ACCEPTED ANSWER

    Re: Error when logging into CQ Designer

    ‏2013-10-04T13:22:51Z  in response to bstroup

    I have seen this error a few times over the years. In those cases it was one of the following:

    1) the registry settings for your connections did not get written correctly

    2) Several dll files did not get registered properly during install

    3) There are old clearquest dll files in the windows/system32 folder

    As the others have suggested a trace might help. I would personally run process monitor on the system to see what files it is trying to load and where they are located. Process monitor is a free diagnostic tool from Microsoft. If you have never used it, the log it creates can be overwhelming, but you can filter out the processes that do not apply to make it easier to review. The link to download it is here:
    http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx

    I would first, check your windows/system32 folder for old clearquest dll files.

    One additional thing to check is the DEP setting for the system. If you open the system properties and go to performance, you will see a tab called "Data Execution Prevention" if the setting is set to "Turn on for all programs and services except those I select" add the cqdesigner.exe to the safe list.

    Glenn

    Updated on 2013-10-04T13:28:24Z at 2013-10-04T13:28:24Z by GlennSkinner
  • bstroup
    bstroup
    26 Posts
    ACCEPTED ANSWER

    Re: Error when logging into CQ Designer

    ‏2013-11-06T12:39:21Z  in response to bstroup

    My computer was rebuilt and the problem hasn't resurfaced, so far anyway (fingers crossed).