Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
6 replies Latest Post - ‏2014-07-22T04:37:34Z by prusty
prusty
prusty
15 Posts
ACCEPTED ANSWER

Pinned topic Chrome V35 does not work with RFT 8.5

‏2014-07-09T07:02:58Z |

Hi, I have RFT V8.5. I am trying to automate a code for a web apps in Chrome Version 35.0.1916.153 m. When I do the enablement test, I always get the status as Passed. But when I try to automate something, it does not recognize the browser. And if I click on say a button, it works during recording, but not during play back.

 

As per http://www-01.ibm.com/support/docview.wss?uid=swg27038243, RFT 8.5 supports all versions of Chrome (but validated upto 22). Please help me on how to proceed. Thanks

Attachments

  • Sathish804
    Sathish804
    1286 Posts
    ACCEPTED ANSWER

    Re: Chrome V35 does not work with RFT 8.5

    ‏2014-07-09T07:30:01Z  in response to prusty

    From the technote it is clear that they are not sure about the Chrome 35.

    Update RFT to 8.5.1.3 and see whether it is able to recognise it.

    RFT 8.5.1.3 has been validated upto Chrome version 32.

    http://www-01.ibm.com/support/docview.wss?uid=swg27040118

    • prusty
      prusty
      15 Posts
      ACCEPTED ANSWER

      Re: Chrome V35 does not work with RFT 8.5

      ‏2014-07-09T08:21:36Z  in response to Sathish804

      Ok, I think I got confused with all the versions mentioned in the url. I thought validated means RFT has validated till 22 and rest are also going to work but RFT has not validated.

       

      • Sathish804
        Sathish804
        1286 Posts
        ACCEPTED ANSWER

        Re: Chrome V35 does not work with RFT 8.5

        ‏2014-07-09T08:29:00Z  in response to prusty

        You can try Selenium Web driver for Web App Automation with Chrome 35 support.

  • swethasivaram
    swethasivaram
    1 Post
    ACCEPTED ANSWER

    Re: Chrome V35 does not work with RFT 8.5

    ‏2014-07-10T06:09:46Z  in response to prusty

    Chrome 35 was released almost a year after RFT 8.5 was released. Chrome has undergone internal changes in version 32 and 33 that might cause issues with older RFT versions. Please upgrade to RFT 8.5.1.3 which is more likely to work with Chrome 35.

    Newer versions of RFT are tested against with the latest versions of Chrome browser that are available at the time.

    Alternately, you can pick up the latest version of the Chrome enabler from the Chrome Web Store in a few days.

  • NaveenEshwar
    NaveenEshwar
    24 Posts
    ACCEPTED ANSWER

    Re: Chrome V35 does not work with RFT 8.5

    ‏2014-07-21T14:48:56Z  in response to prusty

    Hi Prusty

    are you still having any issue ??, with 8.5.1.3 i am able to automate chrome 35 ...

    • prusty
      prusty
      15 Posts
      ACCEPTED ANSWER

      Re: Chrome V35 does not work with RFT 8.5

      ‏2014-07-22T04:37:34Z  in response to NaveenEshwar

      Hello, Yes, RFT 8.5.1.3 + Chrome 35 works fine. There are few issues with recognizing the pop up issues. May be I will start a separate thread. Thanks all for the help.

      - Sisir