Topic
2 replies Latest Post - ‏2013-07-05T15:07:01Z by U4UE_xie_zhi
SystemAdmin
SystemAdmin
2233 Posts
ACCEPTED ANSWER

Pinned topic WASCE does NOT comply with JavaEE 6 spec due to missing JDBC4 support

‏2013-04-05T18:36:39Z |
Although the release notes explicitly state that WASCE is JavaEE 6 compliant this is NOT true.

The JDBC Support in WASCE 3.0.0.3 ( And Geronimo ) is at a JDBC3 level where it should be JDBC4 as described in the spec:
http://www.oracle.com/technetwork/java/javaee/tech/index-jsp-142185.html

I encountered this while I tried to work with the IBM DB2 v10.1.2 Graph Store protocol.
This needs JDBC4 support for its internal functions, after consulting the DB2 team we concluded that some JDBC4 calls seemed not implemented.
More specifically the TranQL version v1.7 shipped with WASCE only supports JDBC3

We reopened a issue in the Geronimo issue tracker with patches, https://issues.apache.org/jira/browse/GERONIMO-6138

If we rebuild Geromino with the patches in the issue tracker the DB2 Graph Store functionality works like it should.

I hope this issue can be resolved soon, especially since WASCE does not comply to the specs it advertises.

With Kind Regards
Bart van Leeuwen
  • BartvanLeeuwen
    BartvanLeeuwen
    1 Post
    ACCEPTED ANSWER

    Re: WASCE does NOT comply with JavaEE 6 spec due to missing JDBC4 support

    ‏2013-04-27T16:35:47Z  in response to SystemAdmin

    This was my post !?

    Since the upgrade it is not anymore ?

    Any update on the subject would be highly appreciated!

     

    With Kind Regards

    Bart van Leeuwen

    • U4UE_xie_zhi
      U4UE_xie_zhi
      49 Posts
      ACCEPTED ANSWER

      Re: WASCE does NOT comply with JavaEE 6 spec due to missing JDBC4 support

      ‏2013-07-05T15:07:01Z  in response to BartvanLeeuwen

      WASCE3.0.0.4 has supported JDBC4.