Topic
  • 1 reply
  • Latest Post - ‏2013-10-15T09:03:16Z by bfloriang
SystemAdmin
SystemAdmin
51 Posts

Pinned topic remote control fails to start on OS X

‏2013-03-31T17:03:52Z |
hello,

i am trying to start the remote control java client (IBM Flex System x240, IMM2 v.1.88 build 1AOO40A) on MacOS 10.8 but it fails to do so miserably as the referenced in the JNLP file respective nativelib jar file is missing:

excerpt from the jnlp:
<resources os="Mac OS X" arch="x86_64">
<nativelib href="/designs/imm/aessrp/avctKVMIOMac64.jar" download="eager"/>
</resources>

err:
com.sun.deploy.net.FailedDownloadException: Unable to load resource: https://<imm2-ip-address>:443/designs/imm/aessrp/avctKVMIOMac64.jar
at com.sun.deploy.net.DownloadEngine.actionDownload(DownloadEngine.java:1421)
at com.sun.deploy.net.DownloadEngine.getCacheEntry(DownloadEngine.java:1574)
at com.sun.deploy.net.DownloadEngine.getCacheEntry(DownloadEngine.java:1552)
at com.sun.deploy.net.DownloadEngine.getResourceCacheEntry(DownloadEngine.java:1659)
at com.sun.deploy.net.DownloadEngine.getResourceCacheEntry(DownloadEngine.java:1583)
at com.sun.deploy.net.DownloadEngine.getResource(DownloadEngine.java:216)
at com.sun.javaws.LaunchDownload$DownloadTask.call(LaunchDownload.java:1983)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
at java.util.concurrent.FutureTask.run(FutureTask.java:138)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918)
at java.lang.Thread.run(Thread.java:680)

java.io.FileNotFoundException: https://<imm2-ip-address>:443/designs/imm/aessrp/avctKVMIOMac64.jar
at sun.reflect.GeneratedConstructorAccessor17.newInstance(Unknown Source)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
at sun.net.www.protocol.http.HttpURLConnection$6.run(HttpURLConnection.java:1491)
at java.security.AccessController.doPrivileged(Native Method)
at sun.net.www.protocol.http.HttpURLConnection.getChainedException(HttpURLConnection.java:1485)
at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1139)
at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(HttpsURLConnectionImpl.java:234)
at com.sun.deploy.net.BasicHttpRequest.doRequest(BasicHttpRequest.java:231)
at com.sun.deploy.net.BasicHttpRequest.doRequest(BasicHttpRequest.java:113)
at com.sun.deploy.net.BasicHttpRequest.doGetRequest(BasicHttpRequest.java:78)
at com.sun.deploy.net.DownloadEngine.actionDownload(DownloadEngine.java:1231)
at com.sun.deploy.net.DownloadEngine.getCacheEntry(DownloadEngine.java:1574)
at com.sun.deploy.net.DownloadEngine.getCacheEntry(DownloadEngine.java:1552)
at com.sun.deploy.net.DownloadEngine.getResourceCacheEntry(DownloadEngine.java:1659)
at com.sun.deploy.net.DownloadEngine.getResourceCacheEntry(DownloadEngine.java:1583)
at com.sun.deploy.net.DownloadEngine.getResource(DownloadEngine.java:216)
at com.sun.javaws.LaunchDownload$DownloadTask.call(LaunchDownload.java:1983)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
at java.util.concurrent.FutureTask.run(FutureTask.java:138)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918)
at java.lang.Thread.run(Thread.java:680)
Caused by: java.io.FileNotFoundException: https://<imm2-ip-address>:443/designs/imm/aessrp/avctKVMIOMac64.jar
at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1434)
at java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:379)
at sun.net.www.protocol.https.HttpsURLConnectionImpl.getResponseCode(HttpsURLConnectionImpl.java:318)
at com.sun.deploy.net.BasicHttpRequest.doRequest(BasicHttpRequest.java:192)
... 14 more

this is very annoying... where is the avctKVMIOMac64.jar file?
is there a fix for this?
greetings,

Stoyan
  • bfloriang
    bfloriang
    1 Post

    Re: remote control fails to start on OS X

    ‏2013-10-15T09:03:16Z  

    We have seen the same for our machines. Is there any update on this?