Topic
5 replies Latest Post - ‏2013-04-01T08:49:14Z by SystemAdmin
SystemAdmin
SystemAdmin
6908 Posts
ACCEPTED ANSWER

Pinned topic BUILDDATE requisite failure

‏2013-03-28T10:51:38Z |
Dear Team,

I am trying to upgrade my aix box from AIX 6.1 TL5 SP9 to AIX 6.1 TL6
But getting following error when i am trying to install.

-----------------------------------------------------------------------------
Pre-installation Verification...
-----------------------------------------------------------------------------
Verifying selections...done
Verifying requisites...done
Results...

SUCCESSES

Filesets listed in this section passed pre-installation verification
and will be installed.

Mandatory Fileset Updates

(being installed automatically due to their importance)
bos.rte.install 6.1.6.1 # LPP Install Commands

<< End of Success Section >>

-----------------------------------------------------------------------------
BUILDDATE Verification ...
-----------------------------------------------------------------------------
Verifying build dates...
installp: The build date requisite check failed for fileset bos.rte.install.
Installed fileset build date of 1228 is more recent than the selected fileset build date of 1043.
installp: Installation failed due to BUILDDATE requisite failure.
Updated on 2013-04-01T08:49:14Z at 2013-04-01T08:49:14Z by SystemAdmin
  • jeffschaller42
    jeffschaller42
    2 Posts
    ACCEPTED ANSWER

    Re: BUILDDATE requisite failure

    ‏2013-03-28T19:19:19Z  in response to SystemAdmin
    I've seen this in two situations:
    1. the TL that you're trying to apply (TL6 SP ???) is actually older than the TL 5 SP 9 that you already have, or

    2. you ran the inutoc on the fileset directory from a machine that was at an older OS level

    The fix for #1 is to download a later SP of TL6 (or not upgrade, or ...). The fix for #2 is to run the inutoc from a newer OS level'd machine.
  • SystemAdmin
    SystemAdmin
    6908 Posts
    ACCEPTED ANSWER

    Re: BUILDDATE requisite failure

    ‏2013-03-29T13:49:26Z  in response to SystemAdmin
    TL5 SP9 was released in July 2012.

    If you are trying to install TL6 SP1, it was released in September 2010.

    Installp is keeping you from regressing your system.

    You should pick a new service pack level for your TL6 upgrade.

    TL6 Service Pack 11 was released on March 29,2013 and includes support for the Power 710-Power 760 Power7+ systems.

    If you don't need the latest hardware support then TL6 Service Pack 10 was released on Dec 12,2012.

    AIX 6 TL5 went out of support April 2012 so you are wise to move off it but be aware that AIX 6 TL6 will go out of support in 4Q 2013 so you might want to move to TL7 instead.

    TL lifecycle can be found at https://www-304.ibm.com/support/docview.wss?uid=isg3T1012517
    Jay
    • SystemAdmin
      SystemAdmin
      6908 Posts
      ACCEPTED ANSWER

      Re: BUILDDATE requisite failure

      ‏2013-03-30T09:59:02Z  in response to SystemAdmin
      current os level of my server is 6100-05-09-1228.
      Can i upgrade to 6100-06-09-1228?
      Kindly help me in this regard.
      • dukessd
        dukessd
        337 Posts
        ACCEPTED ANSWER

        Re: BUILDDATE requisite failure

        ‏2013-03-31T01:46:56Z  in response to SystemAdmin
        Yes.
        The last four digits are the release date - YYWW
        1228 - Week 28 of 2012.
        As they are the same this should be OK.
        You cannot go backwards in terms of date but the same or later is OK.

        HTH