Topic
  • 5 replies
  • Latest Post - ‏2013-04-03T09:27:21Z by SystemAdmin
SystemAdmin
SystemAdmin
6420 Posts

Pinned topic JSF Portlet Issue

‏2013-03-28T05:47:43Z |
Hello,

I'm trying a jsf2 portlet on portal 7.0.0.2. Portlet is getting deployed, but when I access it I'm getting the attached exception trace in the logs.
Any ideas..

Thanks.
Updated on 2013-04-03T09:27:21Z at 2013-04-03T09:27:21Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    6420 Posts

    Re: JSF Portlet Issue

    ‏2013-04-02T06:03:40Z  
    Can you please share which JSF 2.0 portlet bridge you are using? JSF 2.0 portlet bridge is now a part of WAS 8.0.0.3 onwards runtime.
  • SystemAdmin
    SystemAdmin
    6420 Posts

    Re: JSF Portlet Issue

    ‏2013-04-02T06:19:38Z  
    Can you please share which JSF 2.0 portlet bridge you are using? JSF 2.0 portlet bridge is now a part of WAS 8.0.0.3 onwards runtime.
    I'm using the com.ibm.faces.portlet.FacesPortlet from the jsf-portletbridge.jar. This jar is present at the location C:\IBM\WebSphere\AppServer\optionalLibraries\IBM\JSF_Portlet\7.0
  • SystemAdmin
    SystemAdmin
    6420 Posts

    Re: JSF Portlet Issue

    ‏2013-04-02T06:59:41Z  
    I'm using the com.ibm.faces.portlet.FacesPortlet from the jsf-portletbridge.jar. This jar is present at the location C:\IBM\WebSphere\AppServer\optionalLibraries\IBM\JSF_Portlet\7.0
    Version details of the jsf-portletbridge.jar

    Manifest-Version: 1.0
    Ant-Version: Apache Ant 1.6.5
    Created-By: 1.4.2 (IBM Corporation)
  • SystemAdmin
    SystemAdmin
    6420 Posts

    Re: JSF Portlet IssueppServer8005\plugins

    ‏2013-04-02T16:42:42Z  
    Version details of the jsf-portletbridge.jar

    Manifest-Version: 1.0
    Ant-Version: Apache Ant 1.6.5
    Created-By: 1.4.2 (IBM Corporation)
    jsf-portletbridge.jar is for JSF 1.2 applications.
    For JSF 2.0 app , the bridge is now a part of WAS 8.0.0.3(onwards ) runtime.
    So for a JSF 2.0 application, you do not need to keep bridge binary in portlet lib folder , its present in WAS runtime i.e AppServer\plugins\com.ibm.ws.prereq.jsfportlet.jar.
    You can create JSF 2.0 portlet app with target runtime as WP8
  • SystemAdmin
    SystemAdmin
    6420 Posts

    Re: JSF Portlet IssueppServer8005\plugins

    ‏2013-04-03T09:27:21Z  
    jsf-portletbridge.jar is for JSF 1.2 applications.
    For JSF 2.0 app , the bridge is now a part of WAS 8.0.0.3(onwards ) runtime.
    So for a JSF 2.0 application, you do not need to keep bridge binary in portlet lib folder , its present in WAS runtime i.e AppServer\plugins\com.ibm.ws.prereq.jsfportlet.jar.
    You can create JSF 2.0 portlet app with target runtime as WP8
    I'm on WP 7.0.0.2 on WAS 7.0.0.27. I think I should be able to write JSF 2.0 portlet here too; maybe with a different bridge jar

    I'm new to writing JSF portlets (and JSF itself too :-) ) .... if you could help me with a sample JSF2 portlet app, it wud b great!

    Thanks.