Topic
2 replies Latest Post - ‏2013-03-29T12:00:43Z by michael.muceno
michael.muceno
michael.muceno
33 Posts
ACCEPTED ANSWER

Pinned topic Issue with Static Text control on Web Form

‏2013-03-27T12:42:01Z |
I am on ClearQuest 7.1.2.08 on a Windows Server. This issue occurs on the Web Client and with only IE7 and IE8. However, it does not seem to be an issue with Chrome or FireFox, nor the thick client. On one of my record forms, I have a couple of Static Text controls that are associated to a record field. However, when this field is (null) in the database, the word "null" is displayed on the web form. It also displays 'null' when the field value in the database is "" (blank) or " " (space) - it appears to trim spaces, but it is not actually null in the database, but it still displays "null" on the web form. When the field is populated with text, it works fine, but the displayed "null" is a nuisance.

As I stated earlier, this only occurs with IE7 and IE8. Another strange thing is that it doesn't occur in my test and development environments.

Has anyone else come across this? I have a PMR open with IBM, but I'm just checking to see if anyone has seen this behavior and if there is a solution or workaround. I could use ".", but it seems like a "hokey" workaround.

Could it be a configuration setting on CM Server?

Thanks,
Michael Muceno
Updated on 2013-03-29T12:00:43Z at 2013-03-29T12:00:43Z by michael.muceno
  • SystemAdmin
    SystemAdmin
    24948 Posts
    ACCEPTED ANSWER

    Re: Issue with Static Text control on Web Form

    ‏2013-03-29T11:12:33Z  in response to michael.muceno
    Hi Michael,

    Yes... this is a known defect with CQ 7.1.2.8/7.1.2.9. Please open a PMR with Rational support to get added to the existing APAR.

    Thank you
    -Iman
    • michael.muceno
      michael.muceno
      33 Posts
      ACCEPTED ANSWER

      Re: Issue with Static Text control on Web Form

      ‏2013-03-29T12:00:43Z  in response to SystemAdmin
      Thanks Iman,

      I did submit a PMR - which will probably require a patch to fix. I landed up just initializing the field value to "...", instead of "" (blank) to workaround the issue. Although it's not the most elegant solution, it's better than having the word "null" displayed.