Topic
1 reply Latest Post - ‏2013-04-25T08:53:04Z by pmcwatt
pmcwatt
pmcwatt
6 Posts
ACCEPTED ANSWER

Pinned topic cldump works but clstat doesn't...??

‏2013-03-25T21:31:06Z |
This is a new clean install of AIX and PowerHA so nothing goofy going on with snmp.
AIX 7.1 TL2 SP01
PowerHA 7.1.2 SP1

Cluster goes through verify and synch ok.
Initially cldump and clstat both don't work.

I then go through the process of changing from snmpv3 to snmpv1:
  1. stopsrc -s snmpd
0513-044 The snmpd Subsystem was requested to stop.

  1. ls -alrt /usr/sbin/snmpd
lrwxrwxrwx 1 root system 9 27 Jun 11:23 /usr/sbin/snmpd -> snmpdv3ne

  1. /usr/sbin/snmpv3_ssw -1
Stop daemon: snmpmibd
In /etc/rc.tcpip file, comment out the line that contains: snmpmibd
In /etc/rc.tcpip file, remove the comment from the line that contains: dpid2
Make the symbolic link from /usr/sbin/snmpd to /usr/sbin/snmpdv1
Make the symbolic link from /usr/sbin/clsnmp to /usr/sbin/clsnmpne
Start daemon: dpid2

  1. ls -alrt /usr/sbin/snmpd
lrwxrwxrwx 1 root system 17 30 Jun 15:07 /usr/sbin/snmpd -> /usr/sbin/snmpdv1

  1. startsrc -s snmpd
0513-059 The snmpd Subsystem has been started. Subsystem PID is 12910626.
cldump now works but clstat still doesn't.
This is the second customer i have been to in 3 three weeks where this is the case. Same version of PowerHA. In the other case the customer was doing various things with snmp so we put it down to that and used cldump.

I checked psdb and there are similar cases there where they change the snmpv3.conf file rather than drop to snmpv1.
In those cases they imply that cldump and clstat don't work.

In my case cldump works but clstat won't.

Anyone got any ideas?
  • pmcwatt
    pmcwatt
    6 Posts
    ACCEPTED ANSWER

    Re: cldump works but clstat doesn't...??

    ‏2013-04-25T08:53:04Z  in response to pmcwatt

    The customer opened a call with support and got the solution:

    =====================================

    switch this back to snmpdv3                          
                                                                   
    # snmpv3_ssw -n will switch to SNMPv3 non-encrypted            
                                                                   
    Then refresh daemons...                                        
                                                                   
    1.stopsrc -s clinfoES                                          
    2.stopsrc -s snmpd                                             
    3.refresh -s clstrmgrES                                        
    4.startsrc -s snmpd                                            
    5.startsrc -s clinfoES                                         
    6.sleep 30                                                     
    7.clstat       
    ============================================

    It's interesting that this now works as snmpdv3 didn't work originally, hence the change to snmpdv1.

    The -n flag uses non-encypted snmpdv3 so wonder if that's what's made the difference.