Topic
  • 5 replies
  • Latest Post - ‏2013-03-25T19:11:19Z by SystemAdmin
SystemAdmin
SystemAdmin
7615 Posts

Pinned topic IMPORTED TOOLKIT ASSETS ARE NOT EDITABLE

‏2013-03-25T06:25:40Z |
Hi ,

I am working on one of the POC for migrating our application from 7.0.1 version to WLE 7.2. The first thing which i am trying to do is that, exporting the application from 7.0.1 to 7.2 , this I could do successfully without any issues. While doing this, I found that imported toolkits are not editable. Could anyone help me, how should i make the imported toolkit editable.

Thanks
Updated on 2013-03-25T19:11:19Z at 2013-03-25T19:11:19Z by SystemAdmin
  • vlit
    vlit
    933 Posts

    Re: IMPORTED TOOLKIT ASSETS ARE NOT EDITABLE

    ‏2013-03-25T07:01:58Z  
    Try this, but!!!

    It's hack.
    Be attentive.

    Stop your server, execute (depend on your DB)

    UPDATE DB2ADMIN.LSW_PROJECT LSW_PROJECT
    SET IS_IMMUTABLE = 'F'
    WHERE LSW_PROJECT.SHORT_NAME = 'TWSYS' (it's an acronym of your toolkit PA)

    and start.
    Vladlen | http://bpmadmin.blogspot.com
  • SystemAdmin
    SystemAdmin
    7615 Posts

    Re: IMPORTED TOOLKIT ASSETS ARE NOT EDITABLE

    ‏2013-03-25T08:03:03Z  
    • vlit
    • ‏2013-03-25T07:01:58Z
    Try this, but!!!

    It's hack.
    Be attentive.

    Stop your server, execute (depend on your DB)

    UPDATE DB2ADMIN.LSW_PROJECT LSW_PROJECT
    SET IS_IMMUTABLE = 'F'
    WHERE LSW_PROJECT.SHORT_NAME = 'TWSYS' (it's an acronym of your toolkit PA)

    and start.
    Vladlen | http://bpmadmin.blogspot.com
    Hi Mr. Vladlen Litvinov,

    Excellent!!!.

    I tried the script which you have given, it works fine.

    Thanks for your quick solution.

    I have one more problem in Upgrading existing database, I followed the instruction which is given in 7.2 upgrade guide (Pge -7) (ftp://public.dhe.ibm.com/software/integration/lombardi-edition/WebSphere_Lombardi_Edition-7.2.0-Upgrade_Guide.pdf).

    I am getting the error and i couldn't complete the step.

    Please find the error in the attachment.

    Thanks
  • SystemAdmin
    SystemAdmin
    7615 Posts

    Re: IMPORTED TOOLKIT ASSETS ARE NOT EDITABLE

    ‏2013-03-25T11:14:27Z  
    Hi Mr. Vladlen Litvinov,

    Excellent!!!.

    I tried the script which you have given, it works fine.

    Thanks for your quick solution.

    I have one more problem in Upgrading existing database, I followed the instruction which is given in 7.2 upgrade guide (Pge -7) (ftp://public.dhe.ibm.com/software/integration/lombardi-edition/WebSphere_Lombardi_Edition-7.2.0-Upgrade_Guide.pdf).

    I am getting the error and i couldn't complete the step.

    Please find the error in the attachment.

    Thanks
    Can any one reply my query.
  • SystemAdmin
    SystemAdmin
    7615 Posts

    Re: IMPORTED TOOLKIT ASSETS ARE NOT EDITABLE

    ‏2013-03-25T19:06:28Z  
    Can any one reply my query.
    I strongly recommend you use separate threads for separate questions. It makes it much easier for other to follow. I have not seen this error before, but wonder why you are upgrading to 7.2. I would recommend a customer today upgrade to either 7.5.1 (if they were resistant to the new portal) or 8.0.1.

    Andrew Paier | Director of Special Operations | BP3 Global, Inc. www.bp-3.com
  • SystemAdmin
    SystemAdmin
    7615 Posts

    Re: IMPORTED TOOLKIT ASSETS ARE NOT EDITABLE

    ‏2013-03-25T19:11:19Z  
    • vlit
    • ‏2013-03-25T07:01:58Z
    Try this, but!!!

    It's hack.
    Be attentive.

    Stop your server, execute (depend on your DB)

    UPDATE DB2ADMIN.LSW_PROJECT LSW_PROJECT
    SET IS_IMMUTABLE = 'F'
    WHERE LSW_PROJECT.SHORT_NAME = 'TWSYS' (it's an acronym of your toolkit PA)

    and start.
    Vladlen | http://bpmadmin.blogspot.com
    FYI, this isn't a particularly dangerous hack. This plus some cache updates is essentially what the current supported UI in the Process Center do for the same use case.

    Andrew Paier | Director of Special Operations | BP3 Global, Inc. www.bp-3.com