Topic
2 replies Latest Post - ‏2013-03-23T16:39:50Z by SystemAdmin
SystemAdmin
SystemAdmin
1632 Posts
ACCEPTED ANSWER

Pinned topic Bug in Data Studio 3.1.1 - Stored Procedure Parameters are not showing

‏2013-03-22T17:52:42Z |
Did anyone experienced issues with Data Studio 3.1.1 where it is not showing the stored procedure parameters correctly /

I have a stored procedure with 10 parameters and DS 3.1.1 is showing only 4 of them while looking at the properties. SYSROUTINES show them correctly and I have run a trace on DS 3.1.1 to get the SQL statements issued to get the parameter list. Running them separately get me the results properly, but properties window in DS 3.1.1 is not showing it correctly.

SELECT PARMNAME, ROWTYPE, LOCATOR, SCALE, LENGTH, SUBTYPE, RTRIM(TYPESCHEMA) AS TYPESCHEMA, TYPENAME, CCSID, ENCODING_SCHEME FROM SYSIBM.SYSPARMS WHERE SCHEMA = 'XXXXX' AND SPECIFICNAME = 'XXXXXXXXXX' AND VERSION = 'V1' ORDER BY ORDINAL

Thanks
Updated on 2013-03-23T16:39:50Z at 2013-03-23T16:39:50Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    1632 Posts
    ACCEPTED ANSWER

    Re: Bug in Data Studio 3.1.1 - Stored Procedure Parameters are not showing

    ‏2013-03-22T21:22:03Z  in response to SystemAdmin
    Does your stored procedure have a parameter with TIMESTAMP data type? If it does, you hit a known defect which was already fixed in Data Studio 3.2.

    Can you download Data Studio 3.2 to check if the problem goes away? If the problem still exists, can you share the source of the stored procedure, or send us the source via IBM support for further investigation?

    Thanks,
    Emily
    • SystemAdmin
      SystemAdmin
      1632 Posts
      ACCEPTED ANSWER

      Re: Bug in Data Studio 3.1.1 - Stored Procedure Parameters are not showing

      ‏2013-03-23T16:39:50Z  in response to SystemAdmin
      Infact it does have an output parameter with TIMESTAMP datatype and I guess that explains my situation. I will try unloading Data Studio 3.2 and check the behavior. Thanks a bunch for the help !!