Topic
  • 3 replies
  • Latest Post - ‏2013-03-22T17:47:57Z by Jim-Young
SystemAdmin
SystemAdmin
847 Posts

Pinned topic TEP displays no Wokspaces for ITCAM Agent for DB2 V7.2

‏2013-03-22T13:53:11Z |
Hello Everyone,

I've spent a lot of time with this problem but couldn't find any Solutions or Infos in User/Admin Guides on it, so i'm posting it here.

I'm having a problem with displaying the Workspaces/Collected Data from an ITCAM DB2 Agent in a TEP latest version 6.2.3 Fp1. You can see it in my Screenshot of TEP.

I've installed following Component in this Order:

Linux CentOS 6.3 Mashine 1:
TEMS (Name: itm_TEMS)
TEPS

ITCAM DB2 Agent Support Files for TEMS, TEPS and Web Browser Client

Linux CentOS 6.3 Mashine 2 (with a DB2 Instance on it):
ITCAM DB2 Agent

I seem to do all the necessary steps in the right order:
1.Installed Support Files on TEMS & TEPS & Web Browser.
2.Installed & Configured the ITCAM DB2 Agent. Set the Environment Variables and started it under the Instance Owner User.

When i check the Logs of the Agent i can see that it is successfully connected with the TEMS. The Logs of all three Components TEMS (ms), TEPS (cq) and DB2 Agent (ud) show no evident errors that would give infos on the problem (i'm attaching the logs), and still there are no default Workspaces with data available when i start the Web Start Client. (Browser or Desktop clients are not available)

Any Ideas on what could be the Problem, or how can i procede searching for the Problem?

The last Records that i get in TEMS Log after clicking the DB2 Agent in the TEP are:
KFAA008W KFAASITR LOOKUP TABLE IS EMPTY
KFAA092I ACTIONS HAVE BEEN DISABLED
KFAA001W KFAASITR LOOKUP TABLE NOT LOADED
Updated on 2013-03-22T17:47:57Z at 2013-03-22T17:47:57Z by Jim-Young
  • Jim-Young
    Jim-Young
    14 Posts

    Re: TEP displays no Wokspaces for ITCAM Agent for DB2 V7.2

    ‏2013-03-22T15:33:27Z  
    To display workspaces after you have installed a new agent, you may have to rebuild the Tivoli Enterprise Portal Server (TEPS) configuration.

    To rebuild the TEPS, complete the following steps:
    1. Change to the ITM_Home/bin directory.
    2. Enter the following command to open the Manage Tivoli Enterprise Monitoring Services utility: ./itmcmd manage
    3. Right-click Tivoli Enterprise Portal Server.
    4. In the pop-up menu, click Rebuild Configuration.

    Hope this helps.
  • SystemAdmin
    SystemAdmin
    847 Posts

    Re: TEP displays no Wokspaces for ITCAM Agent for DB2 V7.2

    ‏2013-03-22T17:09:22Z  
    • Jim-Young
    • ‏2013-03-22T15:33:27Z
    To display workspaces after you have installed a new agent, you may have to rebuild the Tivoli Enterprise Portal Server (TEPS) configuration.

    To rebuild the TEPS, complete the following steps:
    1. Change to the ITM_Home/bin directory.
    2. Enter the following command to open the Manage Tivoli Enterprise Monitoring Services utility: ./itmcmd manage
    3. Right-click Tivoli Enterprise Portal Server.
    4. In the pop-up menu, click Rebuild Configuration.

    Hope this helps.
    Hi, Thanks for answering, is there a command line equivalent to this action in GUI?

    I tried to find it in the ITM_CommandReference but it seems not to be there..

    Thanks.
  • Jim-Young
    Jim-Young
    14 Posts

    Re: TEP displays no Wokspaces for ITCAM Agent for DB2 V7.2

    ‏2013-03-22T17:47:57Z  
    Hi, Thanks for answering, is there a command line equivalent to this action in GUI?

    I tried to find it in the ITM_CommandReference but it seems not to be there..

    Thanks.
    Full list of CLI options and syntax for this command here:
    http://pic.dhe.ibm.com/infocenter/tivihelp/v61r1/topic/com.ibm.itm.doc_6.3/cmdref/candleconfig.htm

    If this doesn't work for you - there's a troubleshooting topic for the DB2 agent workspaces here:
    http://publib.boulder.ibm.com/infocenter/tivihelp/v24r1/topic/com.ibm.itcama.doc_7.1/db2agent71_user345.htm