Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
9 replies Latest Post - ‏2013-04-04T12:03:30Z by denisF
denisF
denisF
6 Posts
ACCEPTED ANSWER

Pinned topic Content assist for primefaces components not working

‏2013-03-21T14:06:14Z |
I know this is a recurring problem but I found nowhere a solution to this.

With RSA v8.5.1 we can't have content assist for primefaces components attributes to work.

We created a faces definition library project as described here :
http://www.ibm.com/developerworks/rational/library/09/faceslibrarydefinitionrationalapplicationdeveloper/

When this project is included in the workspace, content assist works for the components but not for the attributes of the components. We have to use the "properties" view to see the attributes of the components. Very poor compared to standard jsf components

Q1: How to activate component's attributes content assist?

Q2: Also, is there a smarter way to have primefaces component content assist than having to include a whole project (the faces definition project) in each workspace of each project? could we just tell RSA (within the preferences or somewhere else) where the ".jld" file is ? or maybe include it in a jar (primefaces-3.5.jar in this case) and have RSA scan/use it ?

Thx
Updated on 2013-04-04T12:03:30Z at 2013-04-04T12:03:30Z by denisF
  • adbdkb
    adbdkb
    45 Posts
    ACCEPTED ANSWER

    Re: Content assist for primefaces components not working

    ‏2013-03-28T23:59:50Z  in response to denisF
    Answer to Q1 - There is a fix available from IBM for this issue for RAD 8.5.1, so I presume same may work for RSA 8.5.1. We had the same problem in RAD 8.5.1, we opened a PMR and received the temporary fix. Do not know, which version update of RAD will this be included in.
    • denisF
      denisF
      6 Posts
      ACCEPTED ANSWER

      Re: Content assist for primefaces components not working

      ‏2013-04-02T11:22:13Z  in response to adbdkb
      Thanks for your answer
      Do yo have the PMR / APAR number for it?
      It will go faster when I will request it from IBM
      Thx
    • Mark_Winton
      Mark_Winton
      3 Posts
      ACCEPTED ANSWER

      Re: Content assist for primefaces components not working

      ‏2013-04-04T10:59:50Z  in response to adbdkb
      I'm also hitting this issue, although with RAD 8.5.1 rather than RSA; if it's possible to do so please could you let us know the reference for the PMR - as denisF mentioned it understandably helps speed up the process of receiving the fix from IBM.
      • adbdkb
        adbdkb
        45 Posts
        ACCEPTED ANSWER

        Re: Content assist for primefaces components not working

        ‏2013-04-04T11:24:29Z  in response to Mark_Winton
        The APAR number is PM74700.

        Our PMR was 31784,442,000, but I don't know how IBM associates reference PMR, unless, they don't need to do new research on the new PMR that you would open, because the same issue has been resolved in another PMR
        • adbdkb
          adbdkb
          45 Posts
          ACCEPTED ANSWER

          Re: Content assist for primefaces components not working

          ‏2013-04-04T11:28:45Z  in response to adbdkb
          I think I just mixed the APAR and the PMR. The PMR # is correct, the APAR is for another issue we had at the same time - not being able to use ctrl+ keys in jsp / facelet pages
          • adbdkb
            adbdkb
            45 Posts
            ACCEPTED ANSWER

            Re: Content assist for primefaces components not working

            ‏2013-04-04T11:34:03Z  in response to adbdkb
            APAR for this particular issue is PM81167
            • denisF
              denisF
              6 Posts
              ACCEPTED ANSWER

              Re: Content assist for primefaces components not working

              ‏2013-04-04T12:03:30Z  in response to adbdkb
              > adbdkb wrote:
              > APAR for this particular issue is PM81167

              Thanks for the information!

              Also WAS v8.5.0.2 is supposed to be out next week, April 15
              I'm wondering if there is a new version or RAD/RSA v8.5 comming soon, ie RAD/RSA v8.5.2 including those fixes.
        • Mark_Winton
          Mark_Winton
          3 Posts
          ACCEPTED ANSWER

          Re: Content assist for primefaces components not working

          ‏2013-04-04T11:39:23Z  in response to adbdkb
          Thank you, that's great - hopefully it'll save IBM some effort.

          As a side note I found out about PM80908 (http://www.ibm.com/developerworks/forums/thread.jspa?threadID=453534&tstart=0&start=30) too while Googling your APAR number, which is another issue we're facing - always nice to find out these things aren't just due to me doing something stupid!
          • Mark_Winton
            Mark_Winton
            3 Posts
            ACCEPTED ANSWER

            Re: Content assist for primefaces components not working

            ‏2013-04-04T11:40:03Z  in response to Mark_Winton
            Ah, I see you're also getting the issue in PM80908 - that'll teach me to refresh the page before submitting a comment!